QTS 4.4.3.1421 build 20200907

  • Hallo zusammen,


    so macht das Updaten freude, wenn es anstandslos und ohne meckern läuft!!

  • Seit dem Update hatte ich bereits 2 mal auf meiner TS-453Be einen unerwarteten System-Shutdown. Das hatte ich vor dem Update noch nie. Es ist auch weder hardwaremäßig noch etwas in der Konfiguration verändert worden...

  • Seit dem Update hatte ich bereits 2 mal auf meiner TS-453Be einen unerwarteten System-Shutdown.

    • Meintest Du unerwarteten System-Shutdown oder unerwarteten Reboot?
    • Und was musstest Du machen, um das System wieder benutzen zu können, mit welchen zusätzlichen Warnungen?
    • Und wie waren typische und maximale Nutzung von CPU (-Last) und Hauptspeicher vor dem Update und wie vor den Abstürzen?


    Unter unerwarteten System-Shutdown verstehe ich ein Symptom, bei dem das NAS nicht nur unerwartet abstürzt oder herunter fährt, sondern als weiteres Merkmal auch nicht mehr von alleine wieder hoch fährt.


    Mavalok2 hat berichtet, mit welchen QTS-Updates seine NAS langsamer geworden sind und mit welchen beschleunigt. Wenn ich es richtig in Erinnerung habe, führten deutlich mehr Updates zu einer Verlangsamung als zu einer Beschleunigung, und einige zu keinen signifikanten Veränderungen der Auslastung.


    Ich kenne das Symptom von unerwarteten Reboots. Ein Symptom unerwarteter Shutdowns kenne ich noch nicht von meinen NAS. Es kommt auf allen meinen NAS vor. Alle 7-8 Monate erlebe ich so etwas. Eines meiner bislang 3 Systeme ist das TS-453Be. Also je NAS kann es durchaus länger dauern. Und wenn ich QTS zwischenzeitlich aktualisiere, reboote ich selbstverständlich ebenfalls das System, und ist dann auch erwartet.

  • einen unerwarteten System-Shutdown.

    Spielt event. ja auch eine Rolle ob das System vor dem Update rebootet wurde.

    Und wie wurde das Update gemacht. Offline oder Online?

  • Mitbekommen hatte ich das über die Emailbenachrichtigung. Diese kam von der Container-Station und meldete einen unerwarteten System-Shutdown. Zuerst dachte ich, dass nur ein Container runtergefallen ist, aber nach dem Anmelden an dem QNAP kam schon, dass die Platten überprüft werden und neu synchronisieren müssen... Das Update hatte ich über die QNAP Admin Seite durchgeführt. Reboot vorher habe ich gemacht.

  • Das Update hatte ich über die QNAP Admin Seite durchgeführt. Reboot vorher habe ich gemacht.

    Reboote nochmals und dann offline nochmals das aktuelle drüber installieren. Kannst Du auch über die Website machen, manuell installieren.

    Screenshot 2020-09-17 094519.jpg

    Vorher natürlich die entsprechende Version von Hand herunterladen...

    QTS TS-453Be

    QTS TS-453Be Übersicht

  • aber nach dem Anmelden an dem QNAP kam schon, dass die Platten überprüft werden und neu synchronisieren müssen...

    Also das klingt nicht nach einem unerwarteten System-Shutdown sondern nach einem unerwarteten Reboot. Diese Warnungen sind typische Folgeerscheinungen, weil das System eben gerade nicht herunter gefahren wurde.


    Hast Du schon einmal nachgeschaut nach der Systemauslastung und in welchen zeitlichen Abständen diese unerwarteten Reboots erfolgen?


    Durch das Update kann die Systemauslastung etwas angestiegen sein. Das ist nichts ungewöhnliches bei QTS und QNAP. Wenn diese zuvor knapp unter kritischen Situationen war, kann dies jetzt knapp darüber sein, und sollten daher nicht mehr benötigte Dienste deaktiviert oder auf andere Geräte verlagert werden, um hoffentlich wieder einen stabilen Betrieb zu erreichen. Du kannst auch vorübergehend Dienste deaktivieren, dann erst die Dateisystemprüfungen durchführen, und dann einen Teil der deaktivierten Dienste wieder aktivieren. Denn auch dieser Check und diese Dateisystemprüfungen fordern ihren Tribut bei der Systemauslastung. Und bevor diese Dateisystemüberprüfungen nicht erfolgreich durchgeführt wurden, kommen sie bei jedem weiteren (Re-) Boot, egal ob erwartet oder geplant.

  • Es tritt inzwischen 1 bis 2 mal am Tag auf.

    1. Fehlermeldung :

    Code
    1. Schweregrad Datum Uhrzeit Benutzer Quellen-IP Anwendung Kategorie Inhalt
    2. Warnung 2020/09/18 18:31:07 System 127.0.0.1 Storage & Snapshots Volume [Storage & Snapshots] File system not clean. Volume: Daten, Storage pool: 1. Run a file system check.


    2.

    Code
    1. Schweregrad Datum Uhrzeit Benutzer Quellen-IP Anwendung Kategorie Inhalt
    2. Warnung 2020/09/18 18:32:05 System 127.0.0.1 Power NAS Power Status [Power] The system was not shut down properly last time.


    3.

    Code
    1. Schweregrad Datum Uhrzeit Benutzer Quellen-IP Anwendung Kategorie Inhalt
    2. Fehler 2020/09/18 18:36:30 System 127.0.0.1 Container Station General Operation [Container Station] An unexpected system shutdown occurred. You must manually restart the containers, because containers do not automatically start after an unexpected system shutdown.


    Das System langweilt sich bei 5-15% CPU Auslastung und 6-10% Speicherauslastung (von 16 GB). Wie gesagt sind die Probleme3 vorher nie aufgetreten. Ich befolge jetzt mal den Tipp zu rebooten und das vorher runter geladene Image zu installieren. Ich werde berichten...

  • @Romeleitis Deine Meldungen sind aber typisch und zeigen nur das das System unkontrolliert herunter gefahren wurde.

    Solche Meldungen werden mir auch angezeigt, wenn sich bei mir auf meiner TVS-882 die Raid-Bereinigung festgefressen hat und ich nur noch hart das Gerät ausschalten kann.

  • Nachdem auch das Reflashen der Version TS-X53B_20200907-4.4.3.1421 nicht erfolgreich war versuche ich es jetzt wieder mit der Version TS-X53B_20200817-4.4.3.1400.

    Damit hatte ich ursprünglich keine Probleme. Mal sehen, ob damit die Probleme aufhören.

  • @ Romeleitis, dann hoffentlich viel Erfolg. Ich habe mit meiner TS-453A auch ab und an mal Probleme gehabt, wo ich eine Version mal zurück gegangen war und irgendwann hatte sich der Fehler gefunden oder behoben.

    Mit meiner TVS-882 habe ich seit irgendwann ein dauerhaft bestehendes Problem bekommen, was ich auch noch nicht behoben bekommen habe. Das Teil frisst sich bei seiner monatl. RAID-Bereinigung fest. Das Teil bleibt einfach irgendwann mitten drin dabei stehen. Mal blinken 4 LED's der Festplatten ganz gleichmäßig, mal 2 mal auch 5. Normal während der Bereinigung sind aber alle, die den RAID-Verbund darstellen. Ich hab es aber aufgegeben... Wird mein RAID halt zu gemüllt...

  • Microby Also ich habe ja auch eine TVS-882 und eigentlich nur Probleme mit der Kiste wie man hier nachlesen kann. Aber das Problem, dass sich die Raid-Bereinigung festfrisst habe ich nicht. Wenn Du magst können wir unterschiede suchen im Setup. Platten z. Bsp.

  • Hallo,


    wegen der Probleme bei der RAID-Bereinigung: Sind die Platten alle für NAS/RAID geeignet?


    Desktop-Platten haben mitunter kein Timout bei Lesefehlern, sondern versuchen ewig, den Datenblock zu lesen.

    Das Timeout ist für RAID aber unbedingt erforderlich, damit in so einem Fall Daten der anderen Platten gelesen werden können.


    Es könnte also ein "Defekt" (Lesefehler) auf einer der Platten sein.
    Evtl. siehst Du das sogar in den SMART Infos.


    Tschau

    Uwe

  • Heute auch Installiert.


    Keine Probleme bei Installation und auch sonst bis jetzt nichts aufgefallen.

    Wie die letzten 2-3 Updates auch.


    Gruss

    Roli

  • Also ich habe ja auch eine TVS-882 und eigentlich nur Probleme mit der Kiste

    Und ich eigentlich absolut keine. Nur die Bereinigung.

    Gerne vergleichen. Habe zuerst 2 baugleiche M2-Platten eingebaut. Dort das System drauf. Dann 2 unterschiedliche SSD, aber mit etwa derselben Kapazität, in den kleinen Slots. Dann in den restlichen großen 4 TB und 3 TB als RAID5.

    Die M2 RAID1 als Festplatte für ein virtuelles System, die 2,5"-SSD als weiteres RAID1 für ein zweites virt. System. Die beiden auch keine Probleme.

    Die RAID-Bereinigung der 6-Datengrab-Spindeln bleiben immer hängen. Alles andere völlig problemlos...


    wegen der Probleme bei der RAID-Bereinigung: Sind die Platten alle für NAS/RAID geeignet?

    Jupps, 4x WD40EFRX und 2x WD30EZRX.

    Lediglich marginale Unterschiede:


    1x WD40EFRX-68N32N0

    3x WD40EFRX-68WT0N0

    1x WD30EZRX-00MMMB0

    1x WD30EZRX-00D8PB0


    Die SSD's mit dem System:

    2x SSD 860 EVO M.2 250GB

    und die anderen beiden wo nur eine virt. FP läuft:

    1x OCZ-ARC100

    1x OCZ-TRION100


    Das waren übrig gebliebene... Aber die machen ja nun auch keine Probleme.

    Die sind auch nur als statische Volumes eingerichtet.

    Das Datengrab ist RAID5.

    Screenshot 2020-09-24 134109.jpg

  • Arbeite nicht mit Snapshots. Bedeutet die Zahl :167 die Anzahl der aktiven Snapshots, also 167? Das könnte nämlich so einiges erklären.


    Ach ja: TS-253D bis jetzt keine Probleme mit neuer Firmware.

  • Bedeutet die Zahl :167 die Anzahl der aktiven Snapshots, also 167?

    Ja.

    Das könnte nämlich so einiges erklären.

    Warum? Habe das von meinem alten Netgear so übernommen. Finde ich ganz gut, wenn man Monate später doch nochmals was wieder zurück will.

    War mir nämlich damals bei der Datenübernahme aufgefallen. Vom Netgear... "Oh so was tolles... Doch nochmals wieder herstellen."

    Hat Qnap damit Probleme?

    Wäre traurig. Beim Netgear ging das sogar 2 Jahre zurück. Und das ohne Probleme...

  • Habe zuerst 2 baugleiche M2-Platten eingebaut. Dort das System drauf. Dann 2 unterschiedliche SSD, aber mit etwa derselben Kapazität, in den kleinen Slots. Dann in den restlichen großen 4 TB und 3 TB als RAID5.

    Die M2 RAID1 als Festplatte für ein virtuelles System, die 2,5"-SSD als weiteres RAID1 für ein zweites virt. System.

    Wir haben es ähnlich aufgebaut. M2 und SSD 2,5" sind bei mir 850 EVO mit je 500GB. Die M2 bilden ein Raid 1 und werden als Cache verwendet, die SSD ebenso Raid 1, ein thick Volume mit einem virtuellen Server. In den anderen Slots stecken WD Red drinnen mit 3TB, alle das selbe Modell, bilden ein Raid 5 mit zwei Thin Volumes.


    Ich habe auf einem Volume 147 Snapshots, macht keine Probleme.

    Bring uns also leider nicht recht weiter... :-/

  • Jeder Snapshot bedeutet ein gewisses Mass an Performance Einbussen. QNAP weißt auch ausdrücklich darauf hin. Natürlich ist dies sehr angenehm. Aber Dein Festplatteinhalt ist inzwischen auf 167 Container verteilt. Dies muss auch so auch vom System gemanagt werden. Bin nicht sicher ob dies von QNAP in diesem Umfang so vorgesehen ist. Hatten hier im Club schon vermehrt mit Snapshots von hoher Anzahl Probleme. Bei Virtualisierung wird dies auch so eingesetzt. Zugegebener Massen ist da das ganze System mit betroffen von. Nach ein paar Snapshots ist hier bei weit potenteren Prozessoren (Xeon) schon deutlich einen Performancerückgang spürbar. Auf den Servern werden die bei mir nach getaner Umstellung nach kurzer Zeit wieder gelöscht. Die Snapshots ersetzen keine vernünftige Backupstrategie. Festplatten kaputt > Snapshots kaputt > Backup kaputt > Daten kaputt.