Beiträge von Mavalok2

    Das Standard Antiviren Programm von QTS benötigt normalerweise kein eigenes Volume. Sehe jetzt so überhaupt keinen Sinn für AntiVir ein neues eigenes Volume anzulegen. Hier muss anderswo ein Problem sein.

    Hat das NAS noch genügend freien Speicher?

    Welche Firmware ist installiert?


    Habe hier mal was zum Thema AntiVirus zusammengestellt:

    Sicherheit - Security Tools für die QNAP

    Da war ClamAV im Ordner /usr/local/bin/ beheimatet. Denke mit der aktuellen QTS-Version wird es nicht viel anders sein.


    Schon mal versucht die Definitionen manuell herunterzuladen und zu installieren?

    Clamav.net: main.cvd | daily.cvd | bytecode.cvd

    Möglicherweise ist es auch ein Internetproblem.

    nach 2 Tagen ist die Datei auf sagenhafte 11K angewachsen.

    Sind wir großzügig, dann sind es nach einem Jahr 2 MB, nach 10 Jahren 20 MB und nach 100 Jahren 200 MB. Ich schätzte das killt die Festplatte noch länger nicht. Vielleicht alle paar Jahre eine neue Datei anlegen. Die Frage ist allerdings, wieso langfristig Protokollieren. Dient dies nicht zur aktuellen Analyse des Arbeitsspeicherverbrauchs? Dann wird dies nach ein paar Tagen und Wochen ohnehin nicht mehr gebraucht. Für ein langfristiges Überwachen stellt sich dann die Frage der Art der Analyse der Daten. Mit einen reinen Textfile kannst Du schnell nichts mehr anfangen.

    Das wäre jetzt der richtige Zeitpunkt, da das Geschehen und die Abläufe noch frisch in Erinnerung sind, hier oder im Blog eine Schritt für Schritt Anleitung / Erklärung zu erstellen, wie Du das Problem angegangen bist und lösen konntest. Der Nächste mit dem gleichen Problem muss dann die ganze Odyssee nicht komplett durchmachen. Versehentliches löschen von Daten ohne Backup soll ja des öfteren vorkommen. ;)

    Hatte Q'Center lange auf 3 TS-231+ am Laufen. Sind kleine ARM-Modelle. Ein paar Prozent Leistung hat sich der Q'Agent schon genehmigt, hat aber zu keinen Problemen geführt. Wichtiger ist zu wissen, dass ab Installation des Q'Agent das NAS nicht mehr schlafen geht, auch die Platten nicht.

    ich kann jedoch immer noch nicht verstehen, dass ich über das Handling einer externen USB Schnittstelle eine Formatierung eines Raid 5 Systems auslöse.

    Also wenn wir mal davon ausgehen, dass es keine Fehlbedienung war...

    ...könnte es dann auch noch ein Bug in der Firmware sein. Damit meinte ich unter anderem die schwere Nachvollziehbarkeit. Da müsstest Du - oder jemand anderes - die exakte Situation nochmals nachspielen. Aber ändern daran kannst Du sowohl an dem Datenverlust auch an dem gegeben Falls vorhanden Bug nichts mehr. Du könntest in den Tiefen der Archive prüfen, ob jemals so ein Bug erwähnt wurde. Ich denke mir, ein so massiver Bug würde wohl aufgefallen sein und vermutlich auch von QNAP noch behoben worden sein. Aber nach 6 Jahren sicher nicht mehr.

    ...könnte aber auch eine Malware sein. Es ist wenig bekannt, was und welche Malware auf alten Systemen anrichten kann. Aber wenn das System nicht im Internet war (bei einer so alten Firmware hoffe ich doch schwer nicht) kann ich mir einen Befall nur schwer vorstellen.

    ...könnte es auch eine Verkettung unglücklicher Umstände sein. Kaum zu glauben was entstehen kann, wenn verschiedene Faktoren zusammen kommen. Dies kann von keiner Testumgebung je alles erfasst werden. Was ich hier schon erlebt habe lässt einem graue Haare wachsen. Z.B. könnte ein aktueller Browser auf eine so alte WebGUI ein Problem darstellen und zu Fehlverhalten führen, z.B. gepaart mit einem Virenschutz, Firewall oder sogar Gerätetreiber. Dies wird wohl niemand exakt getestet haben.


    Unterm Strich: Ändern kannst Du Situation wohl trotzdem nicht mehr, nur daraus lernen. Ich bin ohnehin kein Freud des Formatierens an der QNAP. So etwas mache ich eigentlich grundsätzlich am PC / Gerät, an welchem die Daten im Schadensfall eingelesen werden können müssen. Daten, die im Ernstfall nicht mehr eingelesen werden können oder nur am NAS sind auch nicht mehr viel wert.


    Ich weiß, das hilft Dir alles nicht wirklich weiter, aber leider ist IT nicht so eine exakte Wissenschaft wie wir alle es oftmals gerne hätte. Und bevor ein Scherzkeks wieder einwendet, dass alles doch nur aus Nullen un Einsen besteht und somit sehr exakt ist... :rolleyes: Schon klar. :D

    Die Firmwareversion ist 3.3.3 build 1003

    Oha, die Firmware hat aber auch schon ein zwei Tage auf dem Buckel - knapp 6 Jahre. Da wird es mit dem Nachvollziehen eher etwas schwierig werden. Kann mich an QTS 3.3.x nicht mehr erinnern, wenn ich denn je wirklich damit gearbeitet habe.

    Wie gesagt: Ich wollte nur die externe HD mounten und da hab ich versucht diese über den USB Disk Device tool zu formatieren.

    Was dann irgendwie voll daneben ging. Dabei reicht es, irgendwo versehentlich <OK> anstelle <Abbrechen> zu drücken, oder das entsprechende Warnfenster einfach falsch verstehen.


    Wie und ob man bei einem formatierten RAID5 wieder an seine Daten kommt kann ich Dir auch nicht sagen. Vermutlich eher nicht oder besten Falls über eine Spezialfirma, welche dann aber nicht ganz günstig sein dürfte. Ansonsten gilt:

    Für solche Situationen hat der liebe Gott das Backup erfunden. :)

    Ich weiß, Du wolltest ja ein neues Backup anlegen, weil das alte nicht mehr funktioniert hat. Aber ein Backup ist genau genommen auch zu wenig, genau für solche Fälle. Ich kann vielleicht kurz anhand meiner eigenen Backup-Strategie - zugegeben alles anderes als eine Standardlösung - Dir mal ein Beispiel nennen:

    • Ein komplettes Backup mit mehreren Ständen auf ein QNAP-NAS, RAID1
    • Ein komplettes Backup mit mehreren Ständen auf ein Syno-NAS, RAID1
    • Ein komplettes Backup mit mehreren Ständen auf mehrere externe USB-Festplatten, gelagert an einem anderen Standort
    • Eine synchronisierte Teil-Kopie auf drei Computern
    • Eine synchronisierte Teil-Kopie in die Cloud

    In der Hoffung, dass im Fall der Fälle irgendwas übrig bleibt. Bei einem Backup geht es nicht ausschließlich um den Crash von Festplatten. Weit häufiger löscht oder überschreibt man versehentlich noch benötigte Daten. Da nützt oft eine einzige Kopie nicht viel.

    Vor dem Formatieren des RAID5 wurde auch noch das System zurückgesetzt? Wie dass denn?

    Während dem Formatieren des RAID5 wurde auch weiterhin einiges ausprobiert.

    Schwierig nachzuvollziehen was hier schief ging. Systemrücksetzung mit Daten löschen? Die Formatierung hat 40 Minuten gedauert. Hmm, ob da noch etwas übrig geblieben ist?

    Datenrettung ist bei RAID5 ohnehin nicht einfach.


    Um welche Firmware-Version handelt es sich denn?

    Pachnes

    Viel Arbeit für...? Hast Du Dir schon mal MicroServer z.B. von HPE angesehen? Klein, leistungsstark und vor allem dafür ausgelegt und auch nicht teuerer als ein NAS. So um die 400.- Euro bist Du schon dabei.

    Ja, wenn man mit der Konsole zurecht kommt ist dies natürlich die einfachere Lösung. Allerdings bietet das Q'Center noch sehr viel mehr Möglichkeiten als den Arbeitsspeicherverbrauch auszulesen. Für mehrere NAS meiner Meinung nach ein Musthave, zumindest wenn diese 24x7 laufen.

    Bei den Platten habe ich 5x WD Elements 4TB USB-Platten für je 89€ gekauft.

    Ähm, verstehe ich das jetzt richtig, dass Du Festplatten im externen USB-Gehäuse kaufst, diese ausbaust und dann im NAS einbauen willst? Ich hoffe mal die 3.5" Variante, also die Desktop. Gibt es die überhaupt noch? Hatte schon ewig keine externe 3.5" USB-Festplatte in den Händen. Denn bei der 2.5" Variante könntest Du Pech haben, denn da gibt es Varianten, da ist der USB-Controller direkt in der Festplatte integriert anstelle des SATA-Controllers. Da ist dann nix mit im NAS einbauen.

    Beginne mal in umgekehrter Reihenfolge. :)

    Hier ist die CPU-Auslastung aber gerade mal bei 2 %.

    Der DNS Server löst nämlich auch nicht mehr auf.

    Déjà-vu. Da war auch irgendetwas mal bei einem meiner NAS nach einem Update. Es hat sich dann herausgestellt, dass irgendetwas bei der Netzwerkkonfiguration nicht gepasst hat. Ich glaube, wenn dann der Antivirus das Update der Definitionen gemacht hat ist die CPU-Leistung immer höher geworden, oder so was. Ist schon länger her und weiß nicht mehr exakt was es war. Ich würde mal die Netzwerkeinstellungen allesamt durchkontrollieren. Aber auch der DC kann hier Probleme verursachen, wenn die Netzwerkkonfiguration nicht passt.

    Bevor Du sagst: "Aber ich habe nichts verändert". War bei mir damals auch so. Update installiert und die Probleme waren da. Ob die Einstellungen immer schon so waren - also von mir falsch eingestellt, sich durch das Update verändert haben oder einfach durch das Update so nicht mehr richtig funktioniert haben, habe ich nie wirklich herausgefunden. Also kontrollieren und anpassen. Prüf auch die Einstellungen des DC und DNS-Servers. Solange der DNS-Server nicht funktioniert kannst Du davon ausgehen, dass das Problem auch weiterhin besteht. Abgesehen davon wirst Du den DNS-Server ja auch brauchen. ;)

    frankyjones

    Dies ist zum Einen Pech aber auch gemein, zum Anderen wird dies aber so nicht auf der Homepage kommuniziert. Das ließt sich dort ganz anders. Das führt uns unweigerlich mal wieder dazu, dass QNAP - gerade was unbequemere und unangenehmere, oder sagen wir ganz einfach nicht positive Fakten anbelangt - ein Informationsdefizit hat. Solche Sachen verschweigen sie einfach gerne.

    Wie Du sicher festgestellt hast, habe ich selbst ein TS-873U-RP im Einsatz, mit 3 Jahre Garantie (mit der Hoffnung selbige nie zu brauchen). Deshalb auch mein Unglaube, dass hier mit Garantie nichts mehr zu machen ist.

    Wenn das NAS als Auslöser feststeht, dann würde ich das nur noch mit höchster Vorsicht anfassen ;) .

    Bin jetzt kein Elektriker/Elektroniker, aber da der FI-Schalter anspricht müsste hier Storm über die Erdung abfließen. Hier besteht also Gefahr, möglicherweise sogar erhebliche bis lebensgefährliche. Wenn das Problem wirklich mit dem Einschalten des NAS verursacht wurde, würde ich dringendst davon Abraten das NAS nochmals an das Stromnetz zu hängen. Das NAS unbedingt vom Netz nehmen / ausstecken. Unter Umständen stehen sogar metallische Gehäuseteile unter Strom. Bitte dies wirklich ernst nehmen.

    dr_mike Du kennst Dich hier besser aus. Was meinst Du dazu?

    Ansonsten sollte mal ein Fachmann ran.

    Wird wohl das einfachste und günstigste sein das Gerät mal von einem Spezialisten überprüfen / messen zu lassen.