Ip Adresse - Linux Station

  • Hallo


    Meine Linux Station hatte einst eine IP Adresse aus dem Heimnetzwerk (192.168.178.21).


    Neuerdings hat die Linuxstation eine andere IP Adresse: 10.0.5.2.


    Ich kann nirgendwo finden, welche Einstellungen ich ändern muss, damit die Linuxstation wieder eine IP aus meinem Heimnetz bekommen.


    Kennt sich da jemand mit aus? :saint:


    LG,


    Chris

  • frosch2 Ich gehe davon aus, dass er die Linux Station meint, also die auf LXC basierende "Fertiglösung" von QNAP, keine VM.


    MonoChris Du musst die Einstellungen im Virtuellen Switch des NAS tätigen. Dort wird eigentlich recht anschaulich dargestellt, was einzustellen ist damit die Linux Station die richtige IP bekommt. Das gleich gilt im übrigen auch für Docker Container.

  • Wie Du an anderer Stelle selbst schon einmal gemutmaßt hast scheint es durch ein FW Update verursacht worden zu sein: IP verändert .


    Gruss

  • Vielen Dank an alle


    Bei mir war es wohl folgender Grund.


    --> Ich hatte IPV6 aktiviert.


    Wenn ich das aktiviere, dann bekomme ich keine Emailadresse aus dem richtigen NetzwerkAdressbereich.


    Nachdem ich es deaktiviert habe, bekomme ich eine IP Adresse aus dem 192.168.2.xxx Bereich.


    Ich muss rausfinden, wie man IPV6 aktiviert haben kann und trotzdem eine IP aus dem richtigen Adressbereich bekommt.



    Chris

  • Auch wenn es schon ein wenig her ist, möchte ich an dieser Stelle eine Ergänzung zum Vorgehen bei diesem Problem machen, - auch, weil ich selbst lange suchen musste.

    Einstieg in die Linuxumgebung über den Remote-Desktop. Dazu am besten den Link nehmen, der in der QNAP-Oberfläche zur LinuxStation angeboten wird. Der Login sollte kein Problem sein.

    Jetzt in den "System-Settings"-"Network" den Wired-Adapter anwählen und den Schalter rechts oben von "on" auf "off" stellen.

    Jetzt in den "Options" IPv4-Settings z.Bsp. auf DHCP stellen und in IPv6-Settings auf Ignore stellen. Jetzt natürlich "save" wählen.

    Schalter wieder auf "on" und jetzt sollte sofort eine IPv4-Adresse gefunden und angezeigt werden. Im gleichen Moment zeigt auch die QNAP-Oberfläche die Adresse an.

    Ich selbst hatte zunächst den ON/OFF-Schalter nicht beachtet. Da ging dann trotz save und Neustart nix.