Linux Station VNC Passwort ?

  • Ich kann mich, ich glaube nach dem letzten Update der Linux Station, nicht mehr per VNC anmelden.
    Es zeigt mir, dass es ein falsche Passwort ist.
    Es hat bis jetzt immer mit dem Passwort von meinem Qnap funktioniert.
    Ich habe die Linux Station sogar zurückgesetzt, ohne Erfolg.
    Im Browser kann ich mich mit der Linux Station am PC mit der Adresse :http://192.168.1.212:8080/linux-station-vnc/ verbinden.

  • @aanona


    Ja ging mir genauso. Ich habe herausgefunden das mit dem command x11vnc -storepasswd ein Passwort vergeben werden kann. Jedoch ist es nicht mehr möglich sich dann anzumelden.
    Auch wenn das richtige Passwort verwendet wird.


    Ich hatte aber Glück. Ich konnte via SSH unter /etc/systemd/System/x11vnc.service die config für den x11vnc Server zurücksetzen ohne Passwort. Dann ging es wieder.

  • Hallo zusammen,


    ich hatte das gleiche Problem. Ich habe rausgefunden, dass das Passwort scheinbar bei jedem Neustart per Zufallsgenerator neu erzeugt wird.
    Der entscheidende Code findet sich ab Zeile 7 in der Datei /etc/systemd/System/x11vnc.service:



    In der Datei /tmp/.qnap/vncpassword befindet sich das Passwort im Klartext. Dieses wird mit x11vnc -storepasswd nochmal gehashed und anschließend der vnc Server mit dem soeben generierten Password gestartet.
    Man könnte die Zeilen entsprechend abwandeln, dass entweder gar kein Password erzeugt wird, oder ein festes Password genommen wird. So richtig erschließt sich mir der Sinn auch nicht, warum qnap ein Zufallspasswort erzeugt. Soll das etwa die Sicherheit erhöhen?


    Grüße,
    Andreas

    Einmal editiert, zuletzt von derWessi ()

  • Also bei meiner 253A mit aktueller Firmware 4.3.4.0427 und Ubuntu 14.04 in der Linux-Station sieht es so aus:


    Über SSH (Putty) eingeloggt zeigt sich die upstart-conf für den VNC-Server
    . /etc/init/x11vnc.conf


    als Sym-Link auf
    . /usr/share/qnap-vnc/init/x11vnc.conf
    darin wird wie oben angemerkt ein Zufälliges Password im Prestart-Script erzeugt und dann beim VNC-Start (x11vnc) übergeben:

    Code: /usr/share/qnap-vnc/init/x11vnc.conf
    1. # x11vnc -#description "x11vnc"start on started lightdmstop on stopping lightdmrespawnrespawn limit 10 5env XAUTHORITY=/var/run/lightdm/root/:0env DISPLAY=:0pre-start script /bin/mkdir -m 0700 -p /tmp/.qnap [ -f /tmp/.qnap/vncpassword ] || openssl rand -base64 8 > /tmp/.qnap/vncpassword x11vnc -storepasswd `cat /tmp/.qnap/vncpassword` /tmp/.qnap/rfbpassword /bin/chmod 400 /tmp/.qnap/vncpassword /tmp/.qnap/rfbpasswordend scriptexec x11vnc -display :0 -xkb -forever -shared -rfbauth /tmp/.qnap/rfbpassword

    Lösen kann man das Problem sicher auf verschiedene Wege:


    A) In der Uptart-Conf einfach x11vnc mit der option -nopw starten, dann wird auch kein Password abgefragt


    Code: /usr/share/qnap-vnc/init/x11vnc_nopw.conf
    1. ...
    2. env XAUTHORITY=/var/run/lightdm/root/:0
    3. env DISPLAY=:0
    4. #exec x11vnc -display :0 -xkb -forever -shared -rfbauth /etc/x11vnc.pass
    5. exec x11vnc -display :0 -xkb -forever -shared -nopw

    B) Wer lieber den VNC-Zugriff mit Password absichern möchte löscht in meinem Vorschlag oben Zeile 17 und das "#" am Anfang von Zeile 16
    und muss in
    . /etc/x11vnc.pass
    ein passendes Password ablegen. Da man eh schon über SSH angemeldet ist geht das wie hier beschrieben
    http://c-nergy.be/blog/?p=5870
    am Besten mit
    sudo x11vnc –storepasswd /etc/x11vnc.pass


    Egal ob A) oder B) nach eimen Neustarten der Linux-Station aus dem Web-Interface des QNAP verhält sich der Start des VNC wie gewohnt mit oder ohne Password.




    Achtung,


    die Aufgaben der
    . /usr/share/qnap-vnc/init/x11vnc.service
    oder der anderen Files in
    . /usr/share/qnap-vnc/init/[/tt]
    habe ich nicht untersucht, könnte mir aber vorstellen, dass je nach Ubuntu-Version und Konfiguration der Linux-Station ein anderes Service- oder Config-Script aus
    . /etc/init/x11vnc.conf
    verlinkt gestartet wird.


    Daher habe ich meinen Vorschlag als eine umbenannte Kopie
    . /usr/share/qnap-vnc/init/x11vnc_nopw.conf
    ebenfalls ins Verzeichnis
    . /usr/share/qnap-vnc/init/
    kopiert und den Symlink
    . /etc/init/x11vnc.conf
    auf
    . /usr/share/qnap-vnc/init/x11vnc_nopw.conf
    umgebogen.
    Reboot-Fest ist diese Lösung, Inwieweit das aber auch Update-Fest ist muss ich noch herausfinden...


    Gruß
    Michel

    Einmal editiert, zuletzt von michel8 ()