TS-453BE mit PCIe - NVMe auf 4.5.3 - ein Erfahrungsbericht

  • Hallo zusammen,


    ich möchte meine Erfahrungen mit einer neuen TS-453BE auf 4.5.3 und dem Einsatz eines NVMe-Speichers teilen.

    Mein Plan war:

    TS-453BE, NVMe-Speicher als Systemplatte und 3 SATA-Drives als Datengrab.


    Zum Einsatz sollte ein 3rd-Party PCIe-Adapter (DELOCK ca. 25 Euro) und eine WD Black 512GB NVMe-SSD (ca 150 Euro).


    Also erst einmal nur die WD-SSD rein und System booten.

    Leider waren die Gerüchte zu 4.5.3 richtig. :(;(


    Das System akzeptiert die PCIe-SSD nicht als Systemplatte, sie wird schlichtweg einfach nicht angezeigt.

    (Ich bin gespannt wie sich alte Systeme mit der Konfiguration nach einem Update verhalten!)


    Also testhalber eine normale SATA-Platte rein, darauf das System installiert und dann mal den Speichermanager gestartet.

    Dort wird die NVMe-Platte angezeigt, aber man kann sie tatsächlich leider nur als Cache-Speicher konfigurieren.

    Speicherpool, JBOD, etc ...immer grau unterlegt.


    Zumindest der Performancetest war möglich, aber auch hier die Realität:

    Aufgrund des langsamen PCIs-Slots des 453be (nur 2 Lines, 2x) sind nicht mehr als 860MB/s möglich.


    Das Ergebnis ist somit ziemlich ernüchternt. Somit bliebe nur der Kauf der QM2-2P-Karte für gut 130Euro oder gleich die 10GB-Karte für über 200Euro.

    Damit wäre zwar der Einsatz als Systemplatte möglich, aber der Geschwindigkeitsvorteil von NVMe-Speichern kommt weiterhin kaum zum tragen.

    Da bleibe ich lieber bei einer normalen SSD (auch wenn ich einen Slot verliere), komme zwar nur auf 550MB Transferrate, zahle aber dafür mindestens 200 Euro weniger.


    M.E. ist der Einsatz von PCIe in den 2x-System nur in besonderen Anwendungsgebieten sinnvoll und aktuell den Mehrpreis nicht wert.


    Viele Grüße

    Christian





  • Was ist denn der Unterschied der QM2-2P-Karte und der von die gekauften DELOC-karte? Warum ist die QM2-2P-Karte schneller?


    Grüße

  • Ich bin gespannt wie sich alte Systeme mit der Konfiguration nach einem Update verhalten!

    Ich habe auch einen Delock PCI NVMe Adapter in Verwendung.

    Seit ich im Changelog zur 4.3.4 gelesen habe, dass NVMe Adapter von Drittherstellern nicht mehr unterstützt werden, habe ich beschlossen auf weitere Updates zu verzichten...

  • Darf ich mal frech nachfragen, warum die 860MB/s ein Problem für dich darstellen und in wiefern du eine Ausbremsung merkst?


    Soweit ich sehe, hast du keinen 10GbE Anschluss, d.h. Daten übertragen kannst du über das Netzwerk sowieso nur mit 100MB/s, was jedes HDD RAID schon auslastet.


    Als Systemplatte sehe ich den Sinn auch nicht, die NAS läuft ja, die Apps sind im RAM, was soll da die SSD verbessern, bzw. was ist bisher langsam?


    Und als Cache, ja, da kommt es aber sehr stark auf die Zugriffszeiten an und nicht auf die Transferraten. Und hier ist auch die NVMe auch im Vorteil gegenüber einer SATA SSD. Also profitieren kann man schon, trotzt PCIe 2x.

  • Chris8888

    Kleines Detail am Rande: Es hat sich wohl ein Zahlendreher was die Version von QTS anbelangt eingeschlichen. Bis QTS 4.5.3 bei QNAP soweit ist dürfte wohl noch das eine oder andere Jahr dahinziehen. Bis dahin... Im Moment ist QTS 4.3.5 aktuell. :)


  • klar darfst du....dafür ist ein Forum ja da. :-)


    Ich betreibe einige virtuelle Maschinen auf dem NAS, daher ist die Performance der Systemplatte für mich wichtig. Auch liegen die Apps m.E. nicht im RAM (nur das Betriebssystem wird in der RAM-Disk betrieben), die liegen auf der Systemplatte.

    D.h. die theoretische Übertragungsgeschwindigkeit jenseits der 3Gb eines NVMe-Speicher wird hier nicht genutzt. Und dafür ist das dann alles m.E. zu teuer.


    Daher ist auch die Netzwerkperformance für mich nicht das Problem, und ja, auch meine beiden Giga-Bit-Ports kann ich mit SATA-Platten locker auslasten.


    Und ja, als Cache mag es okay sein. Aber genau das habe ich ja auch geschrieben.


    Trotzdem stelle ich den Nutzen von PCIe für die meisten Anwender in Frage. Selbst ohne die 10GB-Ethernet-Karte ist die Anbindung einfach ein richtiger Flaschenhals.


    Zu einem der Preis (25 Euro zu 130) und die Ausstattung (2x NVMe zu 1xNVMe (plus 1x SATA).

    Die QM2-Karte ist aufgrund des 2x-Slots in der 453BE nicht schneller.

  • Hallo Chris,


    bringt eine SSD als erste / Systemplatte so viel mehr Performance? Bei welchen Aufgaben des NAS merkt man das? Und was passiert wenn die SSD kaputt geht? Läuft das NAS dann mit den Kopien des Systems auf den anderen Platten problemlos weiter?


    Sorry für die doofen Fragen aber die Idee reitzt mich gerade da ich noch ein 500GB SATA SSD über habe. Will deshalb mal diesen Ansatz genauer beleuchten ;-)

  • Hi,

    ich finde schon. Gerade wenn du die Virtuallisierung nutzt.

    Aber ich glaube, du verwechselst da etwas.

    ...Kopien des Systems auf den anderen Platten...

    Ich habe kein Raid für die Betriebssystemplatte...also eine Kopie gibt es nicht.

    Geht sie kaputt...dann ist sie kaputt.

    Wenn du das möchtest, dann musst du 2 SSDs nutzen.

    Meine wichtigen Daten spiegel ich auf ein zweites NAS bei meinem Vater und in die S3-Cloud. Von daher habe und brauche ich kein Raid...


    Viele Grüße

    Christian

  • Ich habe auf einem TS-451+ eine Samsung 500 GB SATA SSD als Systemplatte am Laufen.

    Für den normalen Betrieb des Systems und der Apps merkt man von der SSD nicht so viel, auch die Boot-Zeit ist verglichen mit einer HDD nicht so viel schneller.

    Für mich bringt eine SSD im System nur etwas, wenn man VMs oder eine Datenbank nutzt oder wohl bei Verwendung der SSD als Cache.

  • Ich habe kein Raid für die Betriebssystemplatte...also eine Kopie gibt es nicht.

    Doch, gibt es. Das System liegt in eigenen Partitionen, die über alle Platten gespiegelt werden.

    Was du meinst sind die Standardfreigaben und die Apps und deren Einstellungen. Die liegen nur auf der mit "System" gekennzeichneten Platte.

  • Hallo,

    meine eigentliche Frage ist, ob es Sinn macht die SSD als erste und zur Ersteinrichtung einzige Platte zu verbauen um das QNAP NAS zu zwingen da alles drauf zu packen (ich sag jetzt mal Systemdaten dazu ;-) und erst dann die weiteren Platten die dann im RAID als Datengrab laufen dazu zu packen.


    Läuft das NAS dann schneller und was passiert wenn meine einzelne SSD kaputt geht? (Das die VMs die ich auf der SSD ablege flotter sind ist mir klar.) Ist das NAS dann funktionsunfähig (Daten sind nach noch auf den RAID Platten)?

  • Zumindest zum Performancegewinn bei Einsatz als boot-Medium kann ich Dir sagen:

    Wenn das der einzige Zweck der SSD ist, dann spar Dir das Geld, bei QTS brauchen die einzelnen Server die meiste Zeit, um zu starten und das dauert dann eben seine Zeit, die werden wohl auch gegenseitige Abhängigkeiten haben, da hilft das gleichzeitige Laden vieler Dateien nicht so viel.

  • Danke für die Antwort. Ging mir ja auch ums Booten aber auch um die Schwuppdizität des QTS an sich. Aber meine große Sorge ist, dass im Fall eines SSD Schadens das ganze NAS nicht mehr läuft. Ich denke ich werde deshalb wohl zuerst meine zwei WD Red als RAID1 und dann eine SSD für die VMs und eine WD Black Enterprise als Speicher für die Surveillance Station einbauen. Wenn die WD Black oder die SSD verreckt läuft das NAS dann sicher weiter...