IoBroker auf QNAP installieren

  • Guten Abend,

    ich habe die QNAP TS 251+ mit dem aktuellen OS. da bei mein IoBroker Raspberry die SD Karte den geist aufgegeben hat, wollte ich das ganze auf der QNAP mit der Container Station in Docker installieren.

    Soweit hat alles geklappt, ich habe mich an diese Anleitung gehalten (Standartinstallation des IoBrokers), diese Anleitung ist allerdings für die Disk Station von Synology. Der Iobroker läuft aber. Meine Netzwerkeinstellungen sind Bridge modus mit fester IP, die Iobroker Oberfläche wird über den Port 8081 aufgerufen.

    Nun wollte ich, um das ganze sicherer und komfortabler zu machen die erweiterten Einstellungen nach dieser Anleitung vornehmen. Erweiterte Einstellungen. Das Problem ist aber nun, das Ordner gemundet werden müssen. Das geht im Nachhinein in den Einstellungen bei der Synology aber leider nicht bei QNAP.

    Also alles noch einmal von forne, alten Container gelöscht.

    Ich hab also die erforderlichen Ordner aus der Anleitung über die File Station erstellt. Beim anlegen des neuen Containers habe ich in den Einstellungen unter Freigabe bei Host die 2 erforderlichen Ordner mit Mountpoint eingebunden. Die Netzwerkeinstellungen wurden genauso vorgenommen wie beim vorhergehenden Container, also Bridge Modus mit fester IP. Ordner erstellt und siehe da, der Iobroker war nicht über den Browser zu erreichen. was ist da los? also habe ich parallel eine 2. Container mit den selben einstellungen nur ohne Freigaben und natürlich anderer fester IP erstellt. siehe da der Iobroker ist wieder zu erreichen. das ganze spiel hab ich dann noch nach löschen der Container 2. wiederholt. mit dem selben Ergebnis. Woran kann das liegen? ich hab es auch mit dem Netzwerkmodus Host probiert, da bringt er dann aber eine Fehlermeldung die aussieht wie diese.

    ich probiere und lese nun schon ein paar tage aber leider ohne gewünschten erfolg. Kann mir jemand bei der Umsetzung helfen?

    vielen dank und Gruß Marco

  • Hallo,


    da es ja vielleicht noch mehr Leute gibt, die den ioBroker installieren wollen, aber sich nicht trauen, wäre es vielleicht möglich das YellowFellow ein Tutorial schreibt, wie man das am besten anlegt?!


    Das wäre wirklich Klasse


    Gruß

  • Hallo und guten Morgen. Danke für die Antworten. Zum laufen bekommt man den iobroker ja mit der Anleitung die ich gepostet habe. Man kann ihn auch super einrichten und es funktioniert alles. Nur ist er In der Standardinstallation in seinem Container gefangen. Mir geht es um die umsetztung der erweiterten Einstellung mit grmounteten Verzeichnissen zur Synchronisierung. Nur die von mir gepostet Anleitung ist für Synology und da verhält sich die Container Station anders wie bei QNAP. Eine Anleitung speziell für QNAP wäre natürlich klasse.

  • YellowFellow hat auch die nächste Zeit noch landunter, hat aber nichts anderes bemacht, als den ioBroker zu installieren und fertig (buanet/iobroker latest).
    Hatte auch ein wenig Probleme, hatte ihn wieder runtergeworfen und nun mit stabil laufendem Admin 3 neu aufgesetzt. Seitdem top :thumbup:

    Install ansich war kein Problem, schwieriger könnte da u.U. v.a. der Virtual Switch werden und ggf. die Netzwerk-/Router-Konfig, je nachdem, was man vor hat.
    Ich greife aktuell nicht auf andere Verzeichnisse zu, aber da ich sowohl im Heimnetz auf alle Smart Devices komme, als auch ins Internet, sehe ich kein Problem in der Erreichbarkeit (und somit auch Einbindbarkeit) von NAS-Shares... Wie gesagt: falls was nicht geht, liegt's meist an der Konfig des Virtual Switch - und der ist absolut nicht mein Freund :rolleyes:
    (Hoffe auf deutliche Verbesserung in der kürzlich gezeigten, komplett neu aufgelegten Fassung)

  • Hallo,


    eine Frage an marco-mh: Hast du eine Lösung zu dem Ordner Problem finden können?!


    Denn bei mir geht es nach dem erstellen der Ordner auch nicht.

  • Ich habe auf dem NAS ein Verzeichnis "Container" angelegt.

    Unterhalb von "Container" nun wiederum die Verzeichnisse

    \Container\ioBroker

    \Container\ioBroker_Transfer


    und darüber hinaus habe ich noch einen zentralen Pfad für Backups auf meinem NAS und dort entsprechend ein Verzeichnis für ioBroker Backups:

    \Backup\Docker\ioBroker


    Hieraus ergeben sich dann für mich bei der Anlage des ioBroker Containers folgendes Mapping im Bereich "Freigabeordner":

    /opt/iobroker -> /share/Container/ioBroker

    /opt/transfer -> /share/Container/ioBroker_transfer

    /opt/iobroker/backups -> /share/Backup/Docker/ioBroker


    Wobei man bei Anlage des Containers über die Container-Station ja nicht "/share" mit angibt, sondern das Zielverzeichnis per Dropdownliste auswählt.

    Sofern der Container per SSH und dem "run" - Befehl angelegt wird, wäre bei Verwendung der oben bezeichneten Verzeichnisse das gesamte Kommando also beispielsweise:

    Code
    1. docker run -d --name ioBroker --network host --restart always -e TZ="Europe/Berlin" -p 8081:8081 -p 8082:8082 -p 8083:8083 -p 8084:8084 -v /share/Container/ioBroker:/opt/iobroker -v /share/Container/ioBroker_transfer:/opt/transfer -v /share/Backup/Docker/ioBroker:/opt/iobroker/backups buanet/iobroker

    Nachtrag:

    etwas allgemeiner habe ich das ganze hier auch schon einmal versucht zu erläutern:

    Einmal editiert, zuletzt von meMyself ()

  • Hey.


    Aber startet dann dein dicker normal!? Weil ich komme dann über das webinterface nicht mehr drauf :-(

  • wir reden doch nach wie vor vom ioBroker auf Basis Docker, oder?

    ja klar, ich komme drauf und kann ioBroker ganz normal administrieren


    welche Netzwerkeinstellungen benutzt Du ?

    Hast Du ioBroker im "Bridge" Modus installiert/eingerichtet und anschließend eine statische IP vergeben? (so habe ich es bei mir eingestellt)


    Dann kann es sein, dass Du kurzfristig eine zusätzliche "Admin Instanz" einrichten musst, um deinen eigentlichen "admin.0" auf diese neue IP-Adresse (bzw. auf die "neue Netzwerkkarte") umzustellen.


    Das geht folgendermaßen:

    - in der Container-Station auf "Übersicht" gehen

    - auf deinen "ioBroker-Container" klicken.

    - dann müsstest Du das "Konsolen-Fenster" sehen

    - dort reinklicken und einmal die Eingabetaste drücken

    - Du solltest nun in etwa folgenden "Prompt" sehen: root@ioBroker:/opt/iobroker#

    - dort folgenden Befehl eingeben

    Code
    1. iobroker add admin --port 8090 --enabled

    - der Port "8090" ist nur ein Beispiel, bei mir war der auf jeden Fall noch frei


    Nun solltest Du ioBroker unter http://<VonDirVergebeneIP>:8090 aufrufen können.


    Anschließend änderst Du die Einstellungen vom "admin.0" auf die neue IP-Adresse und schaust bei anderen Adaptern ob dort auch irgendwo noch eine Anpassung erforderlich ist (z.B. "socketio"," web" ...)


    [Edit] anschließend kannst Du deinen "Behilfs"- "admin.1" wieder löschen, da Du nun ja wieder über http://<VonDirVergebeneIP>:8081 auf ioBroker zugreifen kannst


    Ich hoffe das hilft.


    Ciao und Gruß,

    Heiko

    4 Mal editiert, zuletzt von meMyself ()

  • meMyself Sehr schön erklärt :thumbup:

    Genau so hab ich's auch konfiguriert - brauchte aber keinen 2. Admin.

    Wenn man direkt bei der Container-Erstellung alles sauber so konfiguriert, wird's ja gleich mit übernommen.

    Ist aber sicher ein guter Hinweis für Leute mit genau diesem Problem :thumbup:

  • Hallo marco-mh,

    ich genau dieses Problem wie Du.

    Erstelle ich ein Image ohne Freigaben funktioniert der Aufruf über den Browser.

    Mit Freigabe funktioniert es nicht mehr.

    Hast Du mittlerweile eine Lösung gefunden. Ich verzweifle noch langsam

    Gruß

    Hans

  • Wie erstellst Du die Freigaben?

    - über die Container Station

    - über einen "-run Befehl" ?


    Hast Du zudem mal einen Screenshot deiner Freigaben?

  • Versuche selbiges gerade via docker-compose. Funktioniert leider noch nicht:


    Console Log

    Code
    1. usr@home:/smb/ioBroker$ docker-compose up
    2. Recreating ioBroker ... done
    3. Attaching to ioBroker
    4. ioBroker | rm: das Entfernen von '/var/run/dbus/pid' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
    5. ioBroker | Stopping Avahi mDNS/DNS-SD Daemon: avahi-daemon.
    6. ioBroker | Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon.
    7. ioBroker exited with code 0


    docker-compose.yml

  • Also wenn ich in der COntainer Station die Ordner einbinden möchte, dann kann ich mich nicht mehr mit dem Container verbinden

  • ich wiederhole mich ...



    Wie erstellst Du die Freigaben?

    - über die Container Station

    - über einen "-run Befehl" ?


    Screenshot deiner Freigaben

    Screenshot deiner Netzwerkeinstellungen vom Container


    ... ansonsten bin ich raus

  • Hallo MeMyself,


    über die ContainerStation.


    ShareFolder:


    /opt/ioBroker /share/Contaier/iBroker


    Netzwereinstellungen: Bridge Modus ( feste IP )