PCIe-Switch in der TS-453A

  • Hallo zusammen,


    ich habe an meiner TS-453A alle 4 Netzwerkanschlüsse im Betrieb und habe mich über die teilweise, schlechte Transferrate gewundert.

    Nach ein wenig Recherche habe ich in einem Artikel gelesen, dass je 2 Ethernet-Controller über einen PCIe-Switch angeschlossen sind. Diese erklärt natürlich einiges.

    Leider konnte ich nicht herausfinden, welche der Ports über einen PCIe-Switch verbunden sind. Für einen Hinweis wäre ich sehr dankbar.


    Eigentlich sollten solche Informationen von QNAP selber publiziert werden, gerade im Bezug auf Link-Aggregation.

  • Ähm, Moment, mein Bild ist gerade etwas getrübt …


    Gibt's dazu auch etwas mehr an Daten?


    Was ist eine schlechte Transferrate?

    Was geht drüber?

    Welche Daten, wohin?

    Welcher Switch?

    Wie ist der konfiguriert?


    Zeig mal ein paar Leistungsdaten her, sonst packe ich mal meine Pokerwürfel, oder die Knochen vom Mittagessen aus und werfe die mal, zwecks Datenerhebung ...


    PS.: QNAP gibt die Transferrate mit etwas über 400MB/s an, ABER (!) nur, bei den genannten Parametern !!!

    Will heißen, das QTS 4.2.0 (!), all neueren sind schon langsamer … -> transfer speeds of up to 412 MB/s


    Hatte vor längerem schon mal die Leistungsdaten der unterschiedlichen QTS Versionen an meiner alten NAS verglichen, der Leistungseinbruch ist eklatant ...


    QTS-Benchmark-TS-412.png

    3 Mal editiert, zuletzt von RedDiabolo ()

  • In dem Artikel ist doch von einem internem Switch die Rede?

    Oder hab ich das falsch verstanden?

    Kann man denn mit CLI Befehlen den Switch ansprechen?


    Gruss

    Einmal editiert, zuletzt von FSC830 ()

  • Crazyhorse

    Während der Kollege deine Befehle ausführt, hast du doch sicher etwas Zeit, dir mal wiederdie Forenregeln bezüglich Inlinecode/Codeblocks zu verinnerlichen.:handbuch:;)

  • Genau, von einem PCIe-Swich. Das bedeutet, dass 2 NIC's an einem PCIe-Switch, wenn sie beide gleichzeitig "belastet" werden, nur die hälfte Leistung bringen.

    Hier mal ein Link: PCIe-Switch


    Zu meinem Aufbau:

    LAN1: unmanged (NAS, Switche, internes WLAN)

    LAN2: VLAN 10 (WAN) + VLAN 30 (für Fernseher, Receiver, etc)

    LAN3+4: LinkAggregation mit VLAN 20 (Benutzer) + VLAN 40 (WLAN)


    Zur Info: Die Schnittstellen sind u.a. an einer virtuallisierten OPNsense gebunden.

    Gestestet habe mit 2 Rechnern, mit ausgeschalter Firewall auf LAN3+4 mit LACP.

    Die Rechner wurden ordnungsgemäß auf beide Schnittstellen aufgeteilt.

    Leistungswerte kann ich gerade nicht liefern. Meiner Meinung nach spielt das auch keine Rolle. Wenn die NIC's wirklich an einem PCIe-Switch angebunden sind, kann auf den verbundenen NIC's kein voller Durchsatz möglich sein. Nach meinem Verständnis...

  • dr_mike

    Sorry ist auf dem Handy etwas doof und wird da gern vergessen.


    Dann liefere doch mal Details zum PCIe Switch in der Kiste.


    Oder aber mal iperf Werte der einzelnen NICs.

    Also 4 Server auf dem NAS starten auf jeder NIC dann einen Client dran und vollgas.

  • Details habe ich in meinen Beiträgen verlinkt.


    Die Schnittstellen mit iperf zu testen werde ich die Tage mal testen. Das Ergebnis müsste mir auch die Antwort auf meine Frage bringen, welche NIC's auf einem PCIe-Switch hängen.

  • Ich meinte mit Details welche PCIe Lanes für welche NIC, über welche Chip genau.

    Am besten als Schaltbild.

  • Also nach dem c't Bericht hat das TS-453A PCIe 2.0 mit 4 Lanes. Bei PCIe 2.0 hat eine Lane 500 MB/s, bei 4 Lanes ergibt dies 2'000 MB/s. Bei 4x 1GbE, die max. so 112 MB/s schaffen ergibt dies 448 MB/s gleichzeitig. Dann sind noch die 4 HDDs. Wenn Du gute hast schaffen die so 180 MB/s. Das sind dann 720 MB/s. Zusammen, brutto mit Verlust, Header trallala - sind wir großzügig, so 1'400 MB/s über alle Lanes, zumindest theoretisch. Von der Seite also sicher kein Engpass. Und wie häufig befeuerst Du alle 4 Netzwerkanschlüsse gleichzeitig unter Volllast?

    Die Wahrscheinlichkeit dass ein Konfigurationsfehler vorliegt sehe ich hier eher als dass das Switchen ausbremst.

    Das TS-453A hat nur ein Celerönchen als CPU. Wenn Du von 4 LANs auf Volllast fährst wird wohl die CPU nicht mehr mitkommen, oder auch die Festplatten. Wie sind die den übrigens eingerichtet? RAID?

    Oder verwendest Du das NAS auch als Netzwerk-Switch?

  • Mavaklok2, du hast Recht. Der PCIe-Switch ja schneller angebunden. Mea Culpa.


    Ich vermute mal, dass ich die NAS doch ein wenig überfordert habe. Die Firewall wird dann wohl auf einem gesonderten Recher landen.


    Vielen Dank für den Hinweis

  • Ach du hast die in der QVS laufen?

    Dann gehen 250-600Mbit durch, je nachdem wie viele Kerne du ihr gibst und was du aktiv hast.


    Bei ClamAV und Cachingproxy sind es ggf. sogar noch weniger.


    Ich habe damit auch erst experimentiert, dann jedoch eine Netgate SG-1100 ins Rack gestellt, die hat mehr Power und die 3,5W Verbrauch sind mir das Wert, die sauber getrennt auf einer stabilen Hardware zu betreiben.