Beiträge von Crazyhorse

    Die alten Bracudas im NAS waren nicht hörbar, die neuen Exos interagieren mit dem verschraubtem Rackboden und dem massivem Rital Wandschrank so dermaßen, dass es im Flur zu hören war.


    Also NAS shut und die Gummifüße um 2 Lagen erweitert.

    Seit dem geht es.


    Aber Exos sind da echt megal Brutal, dafür rennen die wie blöde im Vergleich zu den alten SMR Gurken.


    Kann die Situation also nachempfinden.


    Da hilft nur NAS vom Rack oder Regal massiv zu entkoppeln.


    Ein Stück Waschmaschienenmatte wirkt wunder, sieht nur mega hässlich aus, daher ist es auch wieder aus meinem Rack geflogen und es blockte die Luftlöcher im Rackboden.


    Es hängt also massiv von den verwenden HDs ab.

    Hatte hier mal 4TB Seagate Baracuda mit SMR drin, die hatte auch solche Antwortzeiten, jetzt 4*10TB Exos (Raid 5) mit PMR und die reagieren ganz anders.


    Hier läuft gerade ein Backup auf externe HD, eine der alten 4TB SMR Gurken und ich schiebe Daten runter, da geht der Pool nicht mal über die 300er Marke.

    pasted-from-clipboard.png


    SMR taugen fürn externe Backup, wo es egal ist ob das jetzt 5 Minuten oder 50Minuten läuft.


    Aber nicht für interne HDs wo es auf Performance ankommt.

    Einen Client bekommen die ja gerade noch hin, bei 2 parallelen Zugriffen ist das dann Ende.

    Dieht so aus, als wenn die HDs und die CPU das Limit bestimmen.


    Die Disks haben ja 40-60ms Reaktionszeit, das ist recht viel.

    Die Grafiken der CPU deuten auch vollast an.


    Dann hat dein Speicherpool 1000-4000ms Reaktionszeit, das ist echt lange.


    Sind das SMR HDs?

    Hast du nich eine alte aktuell nicht genutzte HD?

    Dann ausschalten, alle HDs raus aber Reihenfolge beschriften und die andere rein.

    Dann schauen ob du die Kiste damit initialisieren kannst.


    Aber Daten sollten auf der HD keine mehr sein, die wird dabei ja gelöscht.

    Und die sollte noch nie im NAS gewesen sein.

    Ansonsten zuvor alle Partitionen am PC entfernen.

    Ressourcen Monitor auf der QTS Gui, da kannst das alles sehen.


    Wenn die Antwortzeit vom Volumen, dem Raid und den HDs in relation setzt, dann kannst du sehen wo es klemmt.


    HD zu langsam, dann geht alles hoch, HD schnell genug, dann geht Raid und Pool hoch. Ist das Thin Vol zu langsam, dann geht die Vol Antwortzeit deutlich über Raid und weit über HD hinaus.


    CPU kannst hier auch einsehen, wenn die am Anschlag ist, dann wird die Paritätsberechnung zu viel für die Kiste in Verbindung mit SMB 3 inkl. Verschlüsselung.

    Du hast aber einen Speicherpool erstellt, der Snapshots unterstützt.


    Wenn du keine Willst, erstelle ein statisches Volume.


    Ansonsten kannst du jetzt auch schon ein Volume anlegen. Mit dem befüllen solltest du aber den Raid Sync. abwarten, das belastet sonst deine HDs, da die dann Random IOs liefern müssen.

    Jetzt schreiben und lesen die einfach sequenziell und das ist total entspannt für die HDs.

    SMB aufs Raid hast du doch schon getestet indem du Daten vom Client gelesen oder geschrieben hast.


    Du musst dann 2 mal den Server auf dem NAS starten und mit verschiedenen Ports und dann jeweils einen Client zu jedem iPerf Server hin verbinden.

    Eine richtige Firewall betreibt man nicht mit USB Netzwerkkarten.

    Die haben Probleme beim Offloading und dann muss man das deaktivieren und die CPU muss das mit leisten.

    Daher kauft man für Firewalls entsprechende Boads.

    Hier ein Bsp.:

    https://www.supermicro.com/en/…otherboard/A2SDi-2C-HLN4F


    Session = Verbindung die aus 2 states besteht.

    Eine Fritz kann 2-3k, also 5-6k States verwalten.

    Ist die Tabelle voll wartet der nächste Client bis wieder was frei wird.

    Kennst bestimmt, wenn ein Rechner den ganzen Upload blockiert ist dein Ping im Eimer.


    Hast du aber jetzt ein SG-1100 kannst die 99k States verwalten, also ist immer was frei und neue Anfragen von clients bekommen eine ack und keinen nak oder rst zurück.

    Die werden also direkt in den Sendebuffer aufgenommen und gehen einfach so mit raus.


    Das ist halt der Unterschied zwischen Home Zeugs und Enterprise und das SG-1100 ist im Vergleich zum Rest nur ein Spielzeugs.

    Hat aber schon mehr Ram als eine Fritz, habe da Werte von 512MB gefunden für Puma 7 in der 6591.


    Bei Cisco findet sich im Datenblatt noch wie viele Verbindungen oder Sessions eine FW pro Sekunde neu aufbauen kann.

    Wenn die überschritten wird, wird die Verbindung für den Client wieder abgelehnt statt aufgebaut.


    Ich kann hier zocken obwohl gerade ein Backup mit Max Upload durch den VPN-Tunnel läuft.

    Ich merke es einfach nicht, weil meine FW die Anfragen einfach immer bearbeitet.


    Bei der Fritz war ich immer tot wenn meine Frau ihr Handy Abends ansteckte und das Backup den kompletten Uplink vernascht hat.


    Kann man aber als nicht Netzwerker kaum nachvollziehen, man muss es mal erlebt haben was mit so einem Teil alles geht.


    Mit VPN Performance und Sicherheit geht es dann weiter. IKEv1 mit Aggressive Mode gab jedenfalls immer einen Anschiss von meiner pfsense beim Mail Report.


    Code
    1. fpm[53025]: /rc.newipsecdns: WARNING: Setting i_dont_care_about_security_and_use_aggressive_mode_psk option because a phase 1 is configured using aggressive mode with pre-shared keys. This is not a secure configuration.


    Sicherheit und Performance kosten Geld.

    Auch beim Auto.