Netzwerkgeschwindigkeit

  • Ich erreiche NAS/PC bei großen Files bis zu 750MB/sec lesend (wenn ich von einer SSD in der NAS lese). Von den Platten weiß ich es grade nicht auswendig, das müsste ich heute Abend mal prüfen. Genauso verhält es sich mit per iSCSI eingebundenen Laufwerken. Unter CrystalDiskMark habe ich in etwa die selben Werte (minimal höher). Von daher scheint es zu passen. Dem TS würde ich raten, wirklich zu allererst mal die NAS prüfen - da scheint mir der Hase im Pfeffer zu liegen - wenn ich diese Leistung mit einer TS-453Be erreiche, dann sollte er die auch bekommen.



    Gruß,


    Lauri

  • Hallo

    Sorry ich habe am Wochenende geheiratet, daher erst heute meine Antwort.


    Zuerst mal das NAS prüfen, wie sollte ich hier vorgehen?


    Bereits durchgeführt habe ich:

    Kopieren von PC auf NAS via 10Gbit und 1gbit

    Freigabelink erstellt und im Internet runtergeladen (max 50Mbit)

    Im Performance Monitor worauf soll ich achten?

    Ich habe auch einen Jdownloader Container, dort habe ich eine max Downloadrate von 16MB/s


    Schädling kann ich nicht wirklich sagen, ich habe den Malware Remover oben, der findet nichts.


    Leider bin ich neu in der Welt von Qnap und hatte vorher Synology. Falls ihr mir auf die Sprünge helfen könnt mit einzelnen Tests die ich durchführen soll, bzw was ich mir anschauen soll wäre ich dankbar.

    Einmal editiert, zuletzt von chriscres () aus folgendem Grund: Vergessen JDownloader Container aufzuführen

  • Sorry ich habe am Wochenende geheiratet...

    Na dann gratuliere ich. Oder doch: Oje, das tut mir aber leid... :/ Schätze das wird sich in ein paar Jahren zeigen. :D

    Bereits durchgeführt habe ich:

    Kopieren von PC auf NAS via 10Gbit und 1gbit

    Und was ist dabei rausgekommen? Hast Du uns Werte dazu? Wie genau hast Du hier getestet?

    Wenn es vom PC zum NAS funktioniert, der PC ins Internet funktioniert, dann kann es nur noch...???

    Wie sieht es mit dem verwendet Kabel aus?

  • Und was ist dabei rausgekommen? Hast Du uns Werte dazu? Wie genau hast Du hier getestet?


    Wenn ich vom PC auf NAS kopiere komme ich auf circa 112 via 1 Gbit

    Wenn ich vom PC auf NAS kopiere komme ich auf circa 145 via 10 Gbit


    Habe hierzu ein File mit 2.65 Gb hinauf und runter verschoben.


    Getestet habe ich auch via Container /JDownloader da komme ich beim Download auf max 16MB/s


    Getestet wurde Speedtest via Browser Station das ist ein Witz hier komme ich auf 45 Mbps


    Wenn man ein File via ShareLink runterlädt von extern kommt man circa auf 50MB/s, kannst es mal ausprobieren hier der Link. >> korrigiere hier komme ich auf 104 MB/s.


    Mod: Link zu externer Datei entfernt!


    Na dann gratuliere ich

    Danke :-)

    Einmal editiert, zuletzt von chriscres () aus folgendem Grund: nochmals den Speed getestet

  • Hast du mal Jumbo Frames mit 10G zusammen versucht?

    Welchen Chipsatz hat die 10G Lan Karte im PC?

  • Jumbo Frames mit 10G zusammen

    Hi, ja ich habe überall 9000 eingestellt. leider kein Erfolg.


    Welchen Chipsatz hat die 10G Lan Karte im PC?

    ASUS XG-C100C 10GB (PCI-E x4)

    Mod: Link zu externer Datei entfernt!

    sorry, ich habe über Link Erstellung nichts unter Erste Schritte gefunden, worauf muss ich hier achten?

  • OK der Chip sieht ganz brauchbar aus:

    Mod: Extern verlinkte Datei entfernt.


    Was kommt bei iperf als Testtool raus?

  • Hallo

    Sorry ich habe am Wochenende geheiratet, daher erst heute meine Antwort.

    Dazu zuerst mal alles Gute - das ist das wichtigste - nix geht über die Familie ;)


    Ansonsten, zu Deiner Hardware:

    Ich nutze exakt die selbe Konstellation wie Du - die Asus-10GBe Karte im Rechner und die QM2-2P10G1T in der TS-453Be. (Ich hatte zum testen auch einmal die Intel X540T-2 im Rechner, diese schafft dann zusammen mit der QNAP auch ohne Jumbo-Frames deutlich höhere Transferraten).

    Was ich allerdings feststellen konnte, ist, eine wirklich stabile und saubere Verbindung hatte ich erst, nachdem ich die Kabel (sowohl an die QNAP als auch an den PC) alle gegen Cat.7 ausgetauscht hatte. Es gab sehr seltsame Phänomene, der Rechner konnte sich teilweise nicht ans AD anmelden und ähnliches - das alles war schlagartig nach einem Tausch der Cat.6a gegen Cat.7 Kabel vom Tisch. Wichtig ist natürlich auch: Unterstützt Deine Switch Jumbo-Pakets bzw. benötigt diese dafür eine besondere Einstellung? Wenn diese z.B. für die Ports Jumbo-Pakets manuell eingestellt bekommen muss, kommen ähnliche Probleme wie von Dir geschildert zum Vorschein - Du hast mit 10GBe keinen wirklichen Geschwindigkeitszuwachs. Die 112MB/s über 1GBe sind im übrigen in Ordnung, die 147 über 10GBe viel zu langsam. Eine grundsätzliche Frage, Wenn Du testweise Daten von der QNAP auf Deinen PC kopierst, ist das Medium in der QNAP dann eine drehende Platte oder eine SSD? Für Geschwindigkeitstests nutze ich z.B. sowohl im PC als auch in der NAS Samsung evo 970 1TB. Damit ist sichergestellt, dass sowohl die SSD in der NAS als auch im PC über ausreichende Leistung verfügt um die Testfiles entsprechend schnell lesen bzw. schreiben zu können. Was Du z.B. einmal ausprobieren könntest, ist eine direkte Verbindung zwischen der 10GBe-Karte der NAS und der 10GBe-Karte im PC herzustellen (mit möglichst kurzem Kabel) und Dir dann mal die Kopiergeschwindigkeit anzusehen - dabei hättest Du dann schon mal die Switch als Fehlerquelle ausgeschlossen. Für Deine Geschwindigkeitstest solltest Du im übrigen auf dem PC Firewallsoftware, Virenscanner etc. kurz anhalten - diese führt teilweise zu fatalen Geschwindigkeitseinbrüchen, da die entsprechenden Unternehmen oftmals Verbindungen > 1GBe gar nicht auf dem Schirm haben und entsprechend ihre Software auf solche Transferraten auch nicht optimieren (bzw. gar nicht erst testen).



    Gruß,


    Lauri

  • Daher ja auch der Test mit iPerf.

    Mod: Zitat ohne Quellenangabe entfernt! :handbuch::arrow: Forenregeln


    Das wird nicht durch eine HD/SSD Anbindung limitiert, sonder läuft im RAM und generiert die Pakete für den Test dynamisch.

    Nur so kann man wirklich das LAN testen ohne äußere Einflüsse.


    Traue mich nicht mehr das zu verlinken, da schon Datenblätter durch die Moderation entfernt werden.

    Einfach google anwerfen.


    Jumbo Frames müssen bei einem managed Switch erst eingestellt werden, sonst wird fragmentiert und dann leidet die Performance extrem. Unbedingt kontrollieren und auch den LAN Oberhead für VLAN Taggs beachten.

    Also nicht genau 9k einstellen, sondern im Switch so groß wie möglich, wenn er 16 k kann dann das einstellen.

    Dann schiebt er die 9k vom Client so durch.


    Umgekehrt ist es wieder schlecht, 16k am Client und 9k am Switch, ist wieder fragmentierter Datensalat.



    Lauris Einwand was die Kabel angeht ist auch zu beachten, CAT6 gibt es als UTP und als STP, CAT 7 ist meist S STP und damit noch mal deutlich besser geschirmt.

    2 Mal editiert, zuletzt von Crazyhorse ()

  • Daher ja auch der Test mit iPerf.

    Wobei ich völlig bei Dir bin. Da sich aber viele nicht trauen, etwas über die Kommandozeile zu testen und/oder sich die Syntax vom iPerf anzuschauen, wollte ich den Hinweis mit den Datenträgern nicht weglassen ;)


    Gruß,


    Lauri

  • Ich habe mal den dd Test via Mac 1Gbit durchgeführt:

    Schreiben:

    1073741824 bytes transferred in 9.892606 secs (108539835 bytes/sec) 103.51 MB/s

    4294967296 bytes transferred in 41.981371 secs (102306504 bytes/sec) 97.56 MB/s

    Lesen:

    1073741824 bytes transferred in 10.438648 secs (102862155 bytes/sec) 98.09 MB/s

    4294967296 bytes transferred in 42.228887 secs (101706856 bytes/sec) 96.99 MB/s


    Die Werte sind denk ich in Ordnung.


    Test via Windows 10Gbit:

    Schreiben:

    1073741824 bytes transferred 251.59 MB/s

    4294967296 bytes transferred 278.45 MB/s

    Lesen:

    1073741824 bytes transferred 201.21 MB/s

    4294967296 bytes transferred 195.36 MB/s


    Die Werte finde ich nicht in Ordnung.


    Die Tests wurden mit drehenden Platten und SSD gemacht. Die drehenden Werte sind geringfügig schlechter.

    Was Du z.B. einmal ausprobieren könntest, ist eine direkte Verbindung zwischen der 10GBe-Karte der NAS und der 10GBe-Karte im PC herzustellen (mit möglichst kurzem Kabel) und Dir dann mal die Kopiergeschwindigkeit anzusehen - dabei hättest Du dann schon mal die Switch als Fehlerquelle ausgeschlossen.

    dies habe ich schon probiert, siehe ein paar Posts weiter oben. Das hat leider nichts geändert.

    Nix geht über die Familie

    Da hast du recht und danke dir!!


    etwas über die Kommandozeile zu testen und/oder sich die Syntax vom iPerf anzuschauen

    trauen schon aber ich muss mich hier noch einlesen, ich bin da kein Profi.


    Cat.7 ausgetauscht

    werde mal die Kabel austauschen auf Cat.7 - habe sie soeben bestellt.



    Jumbo Pakete unterstützt mein Switch mit max 9000. Ich habe auf beiden Seiten die gleichen Werte eingestellt. ich hoffe dies passt.


    Ich werde auch noch iperf testen aber wie gesagt da brauch ich ein bissl Zeit dazu.


    Mir kommt es auch sovor als würde das NAS die Geschwindigkeit des Internets gar nicht umsetzen können. Ich habe jetzt auch noch auf verschiedene Arten versucht Dinge auf die Qnap downzuloaden. Da bricht die Geschwindigkeit

    immer auf max 25Mbit. Jdownloader im Container, Windows 7 als VM, Download Manager der Qnap.


    Sobald ich iperf habe reiche ich die Daten nach.

  • Ok, kannst du beim Switch in den Portstatistiken was erkennen?

    CRV Fehler, verworfene Packete?


    ggf. hier Posten.

  • Einfach nur kurz, damit Du siehst, ich mal Dir keinen auf die Backe:




    Grundsätzlich kann die TS-453Be (und damit auch Deine 653Be) diese Datenraten erreichen. Wir müssen nun einfach nur die Stelle finden, an der Deine NAS so massiv zusammenbricht, irgendeinen Grund hat das definitiv.


    Gruß,


    Lauri

  • QNAP gibt offiziell auf deren Homepage 644 MB/s lesend und 714 MB/s schreibend an für die TS 653B an. Wie sieht es denn bei Dir mit der eingestellten SMB-Version aus? Bei Windows 10 ist Version 3.0 angesagt. Beim Mac / Linux würde ich NFS anstelle SMB verwenden.

    Fall(e) SMB

    Netzwerk – NFS: Die alternative zur Microsoft-Netzwerk-Freigabe (SMB / Samba)

    Netzwerk – NFS Teil 2: Die alternative zur Microsoft-Netzwerk-Freigabe (SMB / Samba) – Windows-Clients

  • Hi Leute.


    Es tut mir leid das ich mich einige Zeit nicht gemeldet habe. Es ist leider viel passiert, Mein Qnap ist abgeschwirrt und lies sich nicht mehr booten. Auch die Wiederherstellung hat nicht so richtig funktioniert, weder Hard noch Soft Reset. Letztlich war der ÜBELTÄTER anscheinend eine SSD, zumindest ist die nun hinüber. Ich bin gerade dabei mein Backup wiederherzustellen. Sobald ich dies erledigt habe führe ich weitere Tests durch. iperf Test habe ich auch noch nicht machen können, an diesem Abend war einfach nichts mehr zu machen :-)

    Grundsätzlich kann die TS-453Be (und damit auch Deine 653Be) diese Datenraten erreichen. Wir müssen nun einfach nur die Stelle finden, an der Deine NAS so massiv zusammenbricht, irgendeinen Grund hat das definitiv.

    Ja Laurenzis so sehe ich dies eigentlich auch. Ich denke irgendwo ist da ein Problem, sobald Backup wiederhergestellt, teste ich, vielleicht lag es an der SSD die schon defekt war und das verursacht hat.



    Ok, kannst du beim Switch in den Portstatistiken was erkennen?

    CRV Fehler, verworfene Packete?

    ne hier konnte ich eigentlich nichts auffälliges erkennen. Alles im grünen Bereich.