Netzwerkgeschwindigkeit

  • Hallo

    Ich habe folgendes Problem:


    Ich habe eine 10Gbe Erweiterungskarte und mein Internet hat eine 4 Gbit Leitung. Mein Router ist mit dem Qnap via 10G verbunden, dies erkennt mein Qnap auch richtig.


    Nur schaffe ich es leider nicht annähernd diese Geschwindigkeit des Internets auf mein Qnap zu bekommen.


    Anbei seht ihr mein System.


    Habt ihr eine Idee woran es liegen kann?


    Speziell merk ich es wenn ich etwas downloade oder beim upload merk ich es wenn ich vonwoanders darauf zugreife.


    lg Chris

  • Eine 4Gbit Internet Leitung? Wow wo bekommt man denn so etwas? Bist Du sicher, dass Du Dich da bei der Geschwindigkeitsangabe nicht vertan hast?

  • Hi nein, ich bin in der Schweiz, ich habe eine 10gbit (Sowohl up als down) Leitung von Salt.


    :-)


    nur komme ich mit meinen Notebook nur auf 4gbit down, was ja auch schon ausreichend ist.

  • Kaum zu glauben, dass es so etwas schon für private Haushalte gibt. Nicht schlecht. Und ich dümple da noch mit 40 Mbits herum. :) Wüste im Moment auch nicht für was ich mehr benötigen würde. Darf ich fragen, was man für so etwas zahlt?


    Nun zu Deinem Problem:

    Die selbe Verbindung im Internet ist von deinem PC / Notebook aber schnell?

    Die Verbindung QNAP <-> PC ist auch 10 bzw. 4 GbE? Wieso eigentlich 4 GbE?

  • du zahlst dafür 39 CHF also circa 35 Euro. 24 Monate Vertrag.


    Wir syncen ziemlich grosse Datenmenge mit dem NAS hin und her, daher wäre es halt toll wenn das klappt. :-)


    Also eigentlich sollte die Leitung 10Gbit sein. (Bis zu) da mein PC derzeit das einzige Gerät ist das auch 10Gbit kann, aber immer nur auf 4Gbit kommt, gehe mal davon aus das dies das Maximum ist (derzeit)


    was ich derzeit nicht testen kann, da ich auf meinen Router nur einen 10Gbit Anschluss habe ob es im LAN Funktionieren würde. Ich kann entweder PC oder NAS dran hängen. Nur am NAS bekomme ich einfach keine Geschwindigkeiten hin.

  • 35.- Euro für ein 10Gb Internetanschluss. Da laus mich doch der Affee. Ich zahle 54.- Euro für meine 40 Mbit Leitung, auch auf Glas. Könnte zwar auch 1Gb haben, aber die kostet nochmals so viel. Für 35.- Euro würde ich den Anschluss auch nehmen. Dafür muss man dann aber wohl in Zürich im Zentrum oder so wohnen. :)

    Für große Datenmengen ist eine so schnelle Datenleitung sicher nicht zu verachten.


    Als erstes:

    Welche Karte hast Du eigentlich in Deiner QNAP verbaut. Ich schätze es handelt sich um einen 10GBase-T Anschluss? Oder doch SFP+?

    Wie sieht es mit dem verwendetem Kabel aus? Bei 10Gb sollte es schon ein CAT6a oder CAT7 sein, am besten doppelt abgeschirmt. Mit den alten CAT5 oder CAT5E nicht abgeschirmt wird das nichts werden.


    Wenn Kabel ok, dann testen:

    1. Notebook am 10GbE Anschluss am Router. Hier gibt es eine Webseite die die Internetgeschwindigkeit misst.

    https://www.speedtest.net/de

    Allerdings weiß ich jetzt nicht ob die auch bis 10Gb kommt. Meine Test sind ja auf viel niedrigerem Niveau. :( Ansonsten im Internet entsprechende Seite suchen.


    2. QNAP <-> Notebook

    Kabel direkt zwischen Notebook und QNAP verbinden. Allerdings musst Du dann die IP-Adressen bei beiden Geräten manuell eingeben. Dann kannst Du die Geschwindigkeit mit einem Kopiervorgang mit einer großen Datei - ein paar GB - testen, am besten ein Film - keine gezippten Dateien oder Installationsprogramme.


    3. QNAP am 10GbE Anschluss am Router

    Wenn Du eine Seite gefunden hast die 10Gb Internetgeschwindigkeit testen kann, kannst Du auf der QNAP die Browser Station installieren. Dann hast Du auch auf der QNAP einen Browser.

  • es gibt keine "freien" Speedtest-Server in DE für große Geschwindigkeiten, alle auf max 1Gb begrenzt.

    Wir haben in der Firma auch ein mehrere Gb-Internetzugang (mehr als 2-3Gb/s für EINE Verbindung ist nicht möglich). Der Provider garantiert die maximale Leistung nur bei Nutzung vieler Verbindungen, auf keinem Fall wird das mit einer Verbindung garantiert. Der Provider hat nur bis zu seiner Infrastruktur einen Einfluss auf die Geschwindigkeit, was die ganzen Router der Anderen erlauben oder begrenzen ist nicht vorhersehbar. Kurz: im Internet kann und wird dir Niemand irgendwas garantieren.

  • 4Gbit ist doch ein realistischer Wert, denn die MTU ist ja mit 1376 oder ähnlichem unterwegs.

    Das sind also gigantische Mengen an Paketen die verarbeitet werden müssen.


    Da braucht man schon eine ordentliche Netzwerkkarte die offloading kann.


    Dann muss der Router das auch verarbeiten können, da fällt mir nix aus dem Privatbereich ein, was die Power hätte.

    Amtliche Geräte für ein 10Gbit WAN kosten richtig was.


    Latenz spielt hier auch eine Rolle, denn bei einer TCP Verbindung will er ja die Packete auch noch bestätigt haben.

    Da ist LAN (<1ms) zu WAN (>5-20ms) schon ein großer Unterschied.

    Vor allem wenn die Anwendung nicht für WAN Latenzen ausgelegt ist, wirkt sich das extrem negativ auf die Anwendung aus.



    Zudem will man so ein NAS ja auch nicht einfach so in Internet hängen.

    Firewall mit VPN oder reverse Proxy ist bei 10Gbit auch schon wieder Herausforderung.

  • Ich habe die QM2-2P10G1T Karte



    Für 35.- Euro würde ich den Anschluss auch nehmen. Dafür muss man dann aber wohl in Zürich im Zentrum oder so wohnen. :)

    Für große Datenmengen ist eine so schnelle Datenleitung sicher nicht zu verachten.

    ja ich muss auch sagen für diesen Preis konnte ich nicht nein sagen. Bei anderen Anbietern kostet es so um 90 und dann "nur" mit 1Gbit. Ich werde bei meinen Anschluss auch nie an die 10Gbit kommen dessen bin ich mir bewusst, aber 4Gbit find ich schon mal nicht schlecht.



    Wie sieht es mit dem verwendetem Kabel aus? Bei 10Gb sollte es schon ein CAT6a oder CAT7 sein, am besten doppelt abgeschirmt. Mit den alten CAT5 oder CAT5E nicht abgeschirmt wird das nichts werden.

    Es ist ein 6a.


    1. Notebook am 10GbE Anschluss am Router. Hier gibt es eine Webseite die die Internetgeschwindigkeit misst.

    https://www.speedtest.net/de

    Hier komme ich auf die 4.Gbit allerdings mit dem Test von cnlab (https://www.cnlab.ch/speedtest) bei spendetest komme ich auf 3,6 Gbit

    es gibt keine "freien" Speedtest-Server in DE für große Geschwindigkeiten

    natürlich gibt es diesen, du kannst bei spendetest.net den Server wechseln, der meines Anbieters unterstützt Test mit 10Gbit

    Router das auch verarbeiten können, da fällt mir nix aus dem Privatbereich ein

    Ich hoffe ja mein Router vom Anbieter sollte dies können,

    2. QNAP <-> Notebook

    Kabel direkt zwischen Notebook und QNAP verbinden. Allerdings musst Du dann die IP-Adressen bei beiden Geräten manuell eingeben. Dann kannst Du die Geschwindigkeit mit einem Kopiervorgang mit einer großen Datei - ein paar GB - testen, am besten ein Film - keine gezippten Dateien oder Installationsprogramme.

    muss ich morgen Abend ausprobieren, dauert etwas länger bis ich das geschafft habe.


    3. QNAP am 10GbE Anschluss am Router

    Wenn Du eine Seite gefunden hast die 10Gb Internetgeschwindigkeit testen kann, kannst Du auf der QNAP die Browser Station installieren. Dann hast Du auch auf der QNAP einen Browser.

    Das hatte ich ausprobiert, hier bekomme ich Geschwindigkeiten von Down 80 mbps und upload so um die 15, ich weiss nicht was hier los ist und warum dies über die Browser Station nicht klappt. Allgemein ist hier die Browser Station sehr langsam und reagiert zäh.



    Auch in meiner Virtuellen Umgebung (Windows 7) komme ich auf keine Werte über 500mbps.


    lg Chris

  • Was ist das denn für ein Router, Hersteller Modell?


    Schaue doch mal nach was der laut Datenblatte kann, denn bei einer MTU von 1492 gehen ca. 840000 Pakete pro Sekunden durch die Leitung und bei einer MTU von 1376 das das ca. 910000 Pakete pro Sekunde.


    Daher die Frage, ob die Kiste das auch wirklich routen kann, inkl. NAT und Firewalling.


    Da fehlt dann aber noch der ganze Quatsch der im WAN dazu kommt, also hier kannst du noch mal 10-20 % Overhead drauf packen.

    Sprich, 1-2 Millionen Packete muss die Kiste wenigstens können und das im Layer 3 als Forwarding Leistung.

    Von einer richtigen Firewall die dabei in der Lage ist tief in die Packete rein zu schauen, fangen wir am bestern gar nicht erst an.

  • Also ich habe bei dem Router eine MTU von Max 9000 die ich einstellen kann wenn ich es so richtig sehe.


    Aber ich versteh nicht worauf du hinaus willst. Ich habe ja gesagt das die Geschwindigkeit funktioniert via Laptop und Modem/Router. Nur das ich auf meinen Qnap die Gesxhwindigkeit bei weitem nicht erreiche. (Siehe oben)


    Für mich klingt dein ( Crazyhorse ) so als meintest du das es generell nicht funktionieren kann / könnte.


    Auf mein Qnap bezogen, kann es nicht der Router sein aus meiner Sicht wenn er die Daten verarbeiten kann wenn ein Windows Gerät dahinter ist.

    Lg

  • Ich habe nur versucht dir zu erklären, warum von den 10Gbit nur 4 bei dir am PC ankommen.

    Das die QNAP noch mal deutlich langsamer ist, ist noch mal eine andere Geschichte.


    Die MTU mit 9k bezieht sich auf das LAN.

    Ich bezweifle das diese MTU Größe im WAN funktioniert.

    Wenn dir das nichts sagt, lese dich hier bitte kurz ein und teste ed in der CMD selber, welche MTU im Internet ohne Fragmentierung funktioniert.

  • Für mich sieht es auch danach aus, als ob die Zusatzkarte - QM2-2P10G1T mit 10GBase-T - oder das NAS das Problem ist.


    Was Du noch auf die Schnelle versuchen kannst ist, anstelle des Anschluss der Zusatzkarte den normalen 1GbE Anschluss es NAS zu verwenden. Mal messen was dabei raus kommt.

    Ich kann mir jedoch gut vorstellen, dass über die Browser Station nicht mehr geht. Die ist vermutlich nicht für so hohe Geschwindigkeiten / Durchsatzraten ausgelegt.

    Insgesamt kann ich mir hier auch vorstellen - beim Win7 VM Client wie auch bei der Browser Station - das die CPU der limitierende Faktor ist. Mal die CPU des NAS beim Testen im Auge behalten.


    Grundsätzlich hast Du natürlich das Problem, dass Du im Moment wohl sehr wenige QNAP-User antreffen wirst die einen 10Gb Internetanschluss haben. Ist also alles ein wenig Neuland.


    Edit:

    Am meisten würden erst mal Tests im eigenen LAN aussagen bzw. von QNAP zu PC.

  • Wenn dir das nichts sagt, lese dich hier bitte kurz ein und teste ed in der CMD selber, welche MTU im Internet ohne Fragmentierung funktioniert.

    Das mache ich gleich lese mich mal ein. Ah okay danke, warum nur 4gbit ankommen darüber wundere ich mich gar nicht sondern bin sehr zufrieden.

  • 35.- Euro für ein 10Gb Internetanschluss. Da laus mich doch der Affee. Ich zahle 54.- Euro für meine 40 Mbit Leitung, auch auf Glas.

    Willkommen im Neuland...

    Hauptsache immer schön bunt.

  • Mavalok2

    Hi. Also auch die Geschwindigkeit zwischen pc und NAS ist nicht wirklich berauschend. Liegt circa bei 60mb/s.


    Habt ihr noch Ideen?

  • btw: laut deinem Profil passen in ein TS-253B 4 HDD rein ;) , sollte wohl 453B sein.

    Die Frage ist, ist 60MB/s nicht schnell? Richtung PC->NAS, da ist ein Raid5 "dazwischen", es müssen 4 HDDs gleichzeitig beschrieben werden. Raid5 ist deutlich langsamer als Einzeldisks. Und die HDDs "nur" WDred mit 5400rpm?????

    NAS -> PC, welche HDD ist im PC, die muss das auch erstmal schaffen.

    Und zum SSD-Cache, da liest man auch viele negative Einflüsse, zumal SSD = NVMe oder SATA die Frage ist (auch wenn das auf der 453B eh egal ist, da von der Hardware begrenzt.

    Du könntest auch mal den Performance-Monitor bemühen, um zu sehen wie CPU / HDD-IO / SSD-Cache Nutzung ausschaut.

  • Höchstwerte im Performance Monitor wenn ich eine Datei auf das NAS kopiere:

    Lesen: 24/s

    Schreiben: 998/s

    Latenz: 50ms


    Beim Nas joergm6 kann ich nicht sagen ob die HW es schafft oder nicht, daher frag ich ja hier, beim Laptop mit NVMe SSD schafft er es. Habe ja oben schon gesagt das ich die 4Gbit mit Laptop schaffe.

    Ich habe es ausgebessert es ist eine TS 653B. Sorry


    Mein SSD Cache ist NVMe. Ja man liest negatives aber auch positives. Ich sehe es eigentlich nicht das die Hardware begrenzt um hier keine höheren Schreib und Lesewerte zu erhalten. (Klar vielleicht keine 10Gbit) aber mehr als jetzt sollte möglich sein.

  • Also, die QM2-2P10G1T habe ich selbst in einer TS-453Be im Einsatz und kann von daher berichten, sie läuft völlig einwandfrei und stellt die 10Gbit auch wirklich zur Verfügung. Wobei der Chip darauf wohl auch nicht der schlechteste ist, sobald ich nicht gerade eine high-End 10GBe Karte in den PC einbaue, brauche ich Jumbo-Pakets - das ändert sich wie gesagt erst mit sehr teuren 10GBe-Karten. Von daher scheint die Karte von QNAP doch relativ hochwertig zu sein (denn diese schafft, entsprechende Karte im PC vorausgesetzt, die 10GBe auch ohne Jumbo-Pakets). Unabhängig davon sind 60MB/sec nen Witz - die NAS kann deutlich mehr. Von daher wäre meine Suche jetzt tatsächlich auch erst einmal eher im Bereich der NAS - hast Du mal geprüft, ob Du Dir evtl. einen Schädling eingefangen hast?



    Gruß,


    Lauri

  • Im Performance Monitor kann man sich auch die MB/s anzeigen lassen (auch je HDD), auch die Cache-Performance/Nutzung soll man sehen können (ich nutze es nicht). Mit IOs habe ich keine Erfahrungen, was welche Werte bedeuten. 50ms Latenz klingt viel.

    Wie ist die Performance, wenn du innerhalb des NAS Daten kopierst, das muss ja erstmal performant funktionieren. Wenn das ok ist, kann es nur am LAN liegen.

    Laurenzis : welche Performance erreichst du denn mit deinen 10Gb, das könnte für chriscres ein Anhaltspunkt sein.