VPN in Linux Station

  • Hallo zusammen,

    seit heute habe ich die Linux Station mit Ubuntu 16.04 im Einsatz. Alles klappt soweit gut.

    Einzig die VPN Verbindung via ExpressVPN (expressvpn.com) klappt leider nicht.

    Der Verbindungsaufbau bricht regelmäßig ab.

    Die Netzwerkkonfiguration der NAS habe ich mir angeschaut, konnte aber soweit keinen Fehler erkennen. Könnt ihr mir bei der Fehleranalyse unter die Arme greifen? Ich habe keine Idee wo ich am besten anfange.


    Besten Dank vorab!

    Nach einigen Recherchen bin ich zu der Erkenntnis gekommen, dass die Linux Station eine IP Adresse innerhalb eines von der Container Station erstellten Netzes erhält. Statt der im Heimnetz verwendet 192.168.xxx.xxx wird eine IP aus dem Bereich 10.0.3.x verwendet. Bei Verwendung von Containern innerhalb der Container Station kann das Problem mit Portweiterleitungen gelöst werden, da die Linux Station allerdings nicht im der Container Station geführt wird lässt sich das Problem aktuell offenbar nicht beheben.

  • Hi


    Ich habe auch genau dieses Problem mit den IP adressen im falschen Netzwerkadressbereich.:

    Ip Adresse - Linux Station


    Ich wundere mich, ob das vielleicht mit einem der letzten updates zu tun hat. Denn es hat mal ganz normal geklpappt.


    Das wäre natürlich fatal, weill dann ja die Linux Station nach jedem update unbrauchbar werden würde, weil die Services darauf nicht mehr über eine IP Adresse verfügbar wären.


    Ziemlich riskant für den professionellen Einsatz.


    Und eine Lösung gibt es scheinbar auch nicht?

  • Ich habe mich damit abgefunden dass es aktuell offenbar nicht geht, und habe daher nicht weiter nach Lösungen gesucht.

  • Es hat sicherlich mit den Einstellungen in dem virtuellen Switch zu tun, denn bei mir funktioniert das Ganze auch nach dem letzten Update noch hervorragend: die Linux Station bekommt immer die gleiche IP aus meinem Heimnetz (192.168.1.105). Anbei mal ein Screenshot meiner virtual Switch Einstellungen, man beachte, das der Linux Station scheinbar zwei IP Adressen zugeordnet werden können, in meinem Fall einmal 192.168.1.105 und einmal 10.0.5.1. Im Zweifel würde ich die Einstellungen des virtuellen Switches nochmal komplett zurücksetzen und "von vorn" anfangen.


  • Ist deine Linux Station denn über die IP Adresse deines Heimnetzes (192.168.1.105) erreichbar? Genau das ist sie bei mir nämlich nicht.