Ubuntu 18.04. -NVidia Treiber kann nicht genutzt werden, nur Nouveau display driver

  • Guten Morgen,
    seit Wochen versuche ich immer wieder mal (nachdem irgendetwas upgedatet wurde) in meiner LinuxStation beim 18.04. Ubuntu den NVidia Treiber zu aktivieren. Nach dem Neustart bleibt alles schwarz und ich bekomme die Meldung:

    Code
    1. Linux Station General Operations [Linux Station] Failed to enable remote desktop connection. Linux system: Ubuntu 18.04.

    Danach muss ich meine Grafikkarte (Geforce GTX 1050 TI - laut Angabe von QNAP kompatibel mit meiner TS 677, 32 GB) einer anderen Source zuweisen, dann kann ich Linux wieder starten und den Nouveau Treiber wieder aktivieren. Danach läuft Ubuntu wieder.

    Heute morgen nach einem "fetten Update" des NVidia Treibers habe ich es wieder vergeblich versucht. Anschließend habe ich sogar eine Neuinstallation von Ubuntu 18.04 durchgeführt -> derselbe Fehler.
    Beim Ubuntu 16.04. funktioniert alles wunderbar! Bin übrigens kein Linux Profi, bitte berücksichtigen.
    Hat da jemand eine Idee oder Tipp? Muss ich noch ein paar Updates abwarten? Läuft das bei Euch?
    Bevor ich den Support bemühe, wollte ich hier mal nachfragen, hier gibt es schneller eine Reaktion ;)
    Dankeschön, liebe Grüße

    nogrup

  • Also außer dass die Energieeinstellungen des NVidia Treibers viel besser sein sollten, spricht defintiv dagegen, dass ich Kodi damit auf meinem Fernseher über HDMI nicht anschauen kann. Das ruckelt wie Sau.

  • Kann durchaus möglich sein das du den nouveau Treiber erst blacklisten muss, da er sonst mit dem nvidia treiber kollidiert.

  • Hhmmmhhh, kann ich mir nicht so recht vorstellen. In 16.04 braucht es das ja auch nicht. Außerdem befürchte ich, dass ich mir dann bei einem weiteren Fehlersuche die Möglichkeit verbaue die Installation zu retten indem ich den Nouveau Treiber wieder aktiviere. Ich bin auf der Konsole nicht so gut.

    Danke trotzdem auch für weitere Versuche mir zu helfen. Läuft es denn bei jemandem mit einer ähnlichen Konstellation wie meiner?

    Euch allen einen schönen Sonntag, Grüße

    Nogrup

  • habe ts-873 mit nvidia 1050ti. ubuntu 16.04 (wie jetzt auch 18.04) ging auch zeitweise aufgrund von updates nicht. das wird -meine vermutung- noch 1-2 monate dauern und durch ein update gelöst werden. schick ein ticket an helpdesk, vllt gehts dann schneller :)


    ich selbst bin zu faul dafür.. hab mich schon extra hier im forum angemeldet um dir antworten zu können :)


    hier noch ein protestschreiben welches ich hier posten möchte:

    we appeal to the president of qnap.

    the people with nvidia gc urge you! we waited long to use our beloved steam on your machines. this is sad as some lazy developers are unknowingly supporting the dark forces at work in the universe.

    qnap customers realize that you guys don't get the job done right. your actions will lead to the collapse of qnap in the near future.


    Einmal editiert, zuletzt von tola ()

  • Danke tola für Deine Mühe mit Anmelden und Deinen Kommentar. Ja, das ist auch meine Vermutung dass es dann irgendwann funktionieren wird. Gestern gab es wieder ein NVidia Update, hat aber auch nichts gebracht.
    Und ja, ich bin ebenfalls zu faul ein Ticket aufzumachen. Gottlob läuft ja auch 16.04. bei mir wirklich super!
    Man ist halt ungeduldig und unzufrieden wenn irgendwas nicht geht, auch wenn es, weil man eine Alternative hat, nicht wirklich "schlimm" ist.

  • heute gab vormittag gab es ein qts update bei mir. hat aber nichts gebracht.

    ich find es schon eher schlimm das ubuntu 18 erst so spät kommt und es dann wieder mal nicht funktioniert. es gibt ja schon fast ubuntu 20 mitlerweile :)

    will das gerät als computer am fernseher benutzen besonders für steam. der "uralt" nvidia treiber bei ubuntu 18 is gerade noch akzeptabel....

    bei dem 873 kann ich graka beschleunigung leider nicht für die virtualization station nutzen