QTS 5.1.7.2770

  • something new...

    Mod: Nicht deklariertes Zitat ohne Quellenangabe ... korrigiert! :handbuch::arrow: Forenregeln beachten und Die Zitat Funktion des Forums richtig nutzen

    Security Updates
    • Applied multiple security updates to further enhance system security.


    Enhancement SAMBA
    • When logging in via SMB, multiple login failures that occur within three seconds of each other are now recorded as a single login failure if they involve the same user account, source IP address, and computer name.
    Storage & Snapshots
    • When users try to enable encryption on a shared folder, the system now checks and alerts users if there are file names exceeding 143 characters or file paths exceeding 2048 characters.


    Fixed Issues
    • Fixed an issue where after disconnecting a virtual switch and then connecting another cable to the same LAN, the NAS could not communicate with another device through the LAN.
    • Fixed an issue where users could not connect the NAS to a Wi-Fi router if the Wi-Fi password contained certain special characters.
    • Resolved an issue where users could not configure a proxy server if they logged in with an account containing certain special characters in the username.
    • Improved the login page UI to ensure all elements are visible on the screen on different platforms and browsers.
    • Resolved an issue in QVPN Service where under certain circumstances, trying to enable any VPN service would fail and incorrectly trigger an IP conflict log message.
    • Resolved an unusual issue where users might fail to restore files from a snapshot in Storage & Snapshots if they opened the application via File Station.
    • Fixed an issue where under certain conditions if 2-step verification was enabled for the "admin" account, a system reset via the hardware reset button would fail to disable 2-step verification for the account after the reset.
    • Fixed an issue where a user account with multibyte characters in their username could not set port trunking in Network & Virtual Switch.
    • In Network & Virtual Switch, users can now specify an IP address with leading zeroes in each group of the address notation if the result represents the same address without the leading zeroes (for example, users can now specify 127.000.000.001, which is equivalent to 127.0.0.1).
    • Resolved an issue in File Station where under certain conditions a "Move" task would stop responding.
    • Improved I/O performance when accessing files via SMB by reducing the number of logs generated.
    • Fixed an issue where when logged in as a domain user on a Windows device connected to a domain controller NAS, executing a command that contained a service principal name (SPN) would fail if the SPN included spaces.
    • Fixed a rare issue where under certain circumstances users might encounter an authentication error when using Windows Server 2019 as a domain controller to access a folder on a NAS connected as a domain member.
    • Resolved an issue where a connected external storage device would fail to appear in Control Panel or Storage & Snapshots if the device's model name contained certain special characters.
    • Fixed an issue where users could not sort files in the Recycle Bin if it was opened via the desktop shortcut.
    • Fixed an issue where modifying a file via SMB could change the file creation time.
    • Resolved an issue where copying a file from a oplocks-enabled shared folder to a Windows client via SMB could interrupt an ongoing copying process of the same file to a different Windows client.
    • Fixed a typo in the "Edit Properties" window of HybridMount shared folders in Control Panel.
    • Fixed an issue where some users could not successfully import a custom root certificate for certifying the SSL certificate of a server.
    • Fixed an issue on SAS JBOD enclosures where replacing disks would fail to rebuild a degraded RAID group under certain circumstances.
    • Resolved an issue in Resource Monitor > Storage Resource > Disk Activity, where the page would display an error even though only some data was unavailable.
    • Resolved an issue where deleting NAS files via SMB could fail under certain conditions.
    • Fixed the security issue CVE-2023-38545. For details, see https://www.qnap.com/en/security-advisories/
    • Fixed an issue where the model name for certain NIC models was not correctly displayed in Network & Virtual Switch.
    • Fixed an issue where copying many files via SMB could sometimes take a longer time than expected.
    • Fixed an issue in File Station where when a video file appeared in a search result, users could not use "Play with CAYIN MediaSign Player" to play the video.
    • Resolved an issue in iSCSI & Fibre Channel where when adding or editing an iSCSI ACL policy, sorting the LUN list would cause uneditable LUNs to become editable.
    • Fixed an issue where after reinitializing the NAS with the option to shut down after reinitialization, the NAS would restart instead.
    • Resolved an issue in HybridMount folders mounted via SMB, where it would take a long time for the folder contents to appear when accessing from a computer via SMB.
    • Addressed an issue in Notification Center where when creating or editing an alert notification rule, configuring the setting "Notify me when the number of log entries generated per minute exceeds this threshold" would cause unexpected issues.
    • Fixed an issue in File Station > More > File Transfer, where deselecting the setting "Always merge all file transfer processes into one task" failed to disable the setting.


    Other Changes Control Panel
    • The system now checks whether a new QNAP Software Terms of Use is available before performing a firmware update. Administrators must agree to the new terms to proceed with the firmware update.
  • schwimmaaa

    Hat den Titel des Themas von „QTS 5.1.7“ zu „QTS 5.1.7.2770“ geändert.
  • Lange Liste von beseitigten Fehlern.


    Da mein Test-NAS mit der Betaversion von QTS 5.2.xx läuft, werde ich noch einige Tage mit dem Update warten. :sleeping: :sleeping:

  • Habs mal auf meinem Testsystem TS-451+ installiert.

    Läuft soweit, jedoch dauerte der Boot-Prozess inkl. VS fast 40 mins.

  • jedoch dauerte der Boot-Prozess inkl. VS fast 40 mins.

    Das ist bei mir schon immer sehr unterschiedlich auch mit gleicher FW-Version. Fraglich ist dann auch: Der Boot-Vorgang oder der komplette Neustart? Bei mir sind es eben oft bestimmte Apps, die schon mal sehr lange für das Beenden brauchen.

  • NaJa, solange das noch nicht mal als "alternative" FW angezeigt wird, werd ich das auch nicht installieren

    Gibt da wohl auch wieder einen Rollout für die unterschiedlichen Geräte, um den Server nicht zu überlasten... Wie war das noch beim Auto: Hubraum ist durch nichts zu ersetzen, ausser durch noch mehr Hubraum :)

  • Den Fehler kenne ich noch nicht. :huh:

  • MD5 hab ich nicht getestet. Hab aber ein zweites Mal bei QNAP runtergeladen. Der Fehler ist derselbe. Hoffentlich liegts nicht an der 5.1.6.


    Edit: MD-5 Hashsumme ist gleich.

    Einmal editiert, zuletzt von q.tip ()

  • Du hast heruntergeladen als zip und dann manuell installiert, ohne vorher zu entpacken?

  • Gezipt und entpackt - Siehe Bild in #7.


    Edit: kann das daran liegen, dass ich noch eine (https)-Freigabe durch Filestation offen habe? (Ich sollte gepeitscht werden ;)...)

    Einmal editiert, zuletzt von q.tip ()

  • q.tip

    Wieso kommt die Fehlermeldung vom App Center? Kann es sein, dass Du versehentlich die Firmware im App Center, dort wo Apps manuell installiert werden können, installieren wolltest, anstelle im System bei der Firmware Aktualisierung?

  • Genau das hab ich auch gerade gemerkt 8| ! Wie komme ich bloß auf die Idee, über das App Center eine Firmware aufspielen zu wollen? :S Sorry für das Wellenmachen!


    Installation über "Firmware installieren" funktioniert natürlich. ?(


    Trotzdem: Mavalok2 - Vielen Dank!!!

  • Habe die wegen den Sicherheitspatches hier auf den Kisten installiert.

    Mal sehen, HD Backups sind ja gerade erst mit der 5.1.5.2679 erfolgt, da eine HD mit der 5.1.6 nicht erkannt wurde.

    Das werde ich morgen ggf. noch mal testen.


    Vielleicht ist das mit der 5.1.7.2770 ja mit korrigiert worden.

  • Neu: nach dem Update kommt ein Fenster zum Bestätigen der Nutzungsbedingungen ?(

    Einmal editiert, zuletzt von NaStrada ()

  • QNAP hat offenbar das Zeichensatz/Bold Problem beim Anklicken von "Speicher & Snapshots" auf dem QNAP-Desktop behoben. Bisher (< 5.1.7) hatte ein Klick hierauf die gesamten Icon-Beschriftungen des Desktops auf "Bold" umgestellt - zumindest bei mir (Edge Browser).

  • Beide TS-253A laufen ohne Auffälligkeiten.



    Mal sehen, ob die HBS3 Sicherung läuft. Hier habe ich noch nicht aktualisiert.