Zugriff auf Wordpress im Intranet via LAN2

  • Guten Tag liebes Forum :)

    Ich hoffe hier hat jemand eine Ahnung wo mein Fehler liegt und kann mir weiterhelfen.
    Ich habe auf einem TS-453BU einen Domain-Controller, diverse SharedFolders und Wordpress für einen lokalen Zugriff eingerichtet.


    LAN1 und LAN2 sind in unterschiedlichen Netzen: LAN1 192.168.1.200, LAN2 192.168.8.100 und auch an unterschiedlichen Switches, bzw Routern


    Auf LAN-Port 1 werden Rechner angeschlossen die in der Domäne sind.
    Auf LAN-Port 2 sollen sich Rechner verbinden können, die nicht in die Domäne kommen aber Zugriff auf Wordpress haben sollen.


    Bin ich im LAN1-Netzwerk kann ich unter http://192.168.1.200/WordPress/ die von mir erstellte Seite errreichen.

    Im Netzwerk an LAN2 ist mir das weder unter http://192.168.1.200/WordPress/ noch unter http://192.168.8.100/WordPress/ möglich
    Service-Binding ist akitiviert und außer Management-Zugängen sind alle Services für LAN2 aktiv.

  • Wenn bei beiden Subnetzen als Sub-Netzmaske die 255.255.255.0 eingetragen ist, dann ist es schon mal richtig, das kein Rechner aus LAN1 ins LAN2 kann und umgekehrt.

    Ich kenne Wordpress nicht, aber wie wird Wordpress mitgeteilt, das es auf zwei IP Adressen ansprechbar ist?


    Gruss

  • Manche Programme lauschen ja durchaus "automatisch" auf mehreren IPs, wie z.B. der Twonky auf QNAP.

    Vermutlich tut Wordpress eben genau dies nicht, das könnte map mit netstat -nlp prüfen.

    Wäre dann, wie FSC830 denke ich gemeint hat, aber eine Sache von Wordpress, wie man dem weismacht auf welchen IPs es lauschen soll.

  • Muß da in diesem Konstrukt nicht noch eine Instanz sein, welche zwischen den Netzen routet?

  • Soll ja eben nicht geroutet werden ..so wie ich das verstehe sollen beide Netze getrennt bleiben ..nur Wordpress soll übergreifend verfügbar sein

  • Ist ja dann eher so eine Apache-Klamotte.

    Und wie der TE WP installiert hat wissen wir nicht.

    Bei dem eingebauten Apache wirds vermutlich nicht so einfach sein.

    Insbesondere das ganze Boot,- und Updatefest zu machen.

    Wesentlich leichter und flexibler ist eine VM.

  • Richtig. Eigentlich (würde ich steif und fest behaupten) sollten die Dienste per default aber auf allen Interfaces laufen. Dies ließe sich dann (eigentlich) mit der Servicebindung unterbinden, sodass die Dienste nur auf bestimmten Interfaces lauschen. Eigentlich muss die Servicebindung also auch gar nicht aktiv sein.

  • Per Default lauschen die Dienste an allen IPs.

    Zumindest die welche ich bisher betreue.

    Und wenn man die listen-Direktive für Apache oder SQL setzt, bindet man den Dienst eben an jene IP welche angegeben ist.

    Analog zu den Ports. Aber das regelt man meist doch mit vHosts.

  • Moin, vielen Dank euch Allen schonmal für eure Antworten! :)

    Mir würde es schon reichen, wenn WordPress nur auf dem LAN2 erreichbar wäre.


    An dem Port kann sich jeder anmelden, der liegt in einem Netz mit Wifi-APs, daher soll das auch vom LAN1 getrennt bleiben.



    Ich lese mich jetzt erstmal in die von Tiermutter verlinkte Seite ein, bin halt was diese ganze Thematik angeht noch blutiger Anfänger :rolleyes:

  • Führe doch erstmal netstat -nlp über SSH aus, vielleicht sieht man daran schon was.

    Poste bitte auch mal einen Screenshot von den Einstellungen bei der Servicebindung.

  • :) kommt sofort... Ich wusste nicht, was du von dem netstat-Ergebnissen brauchst, habe also sämtliche Screenshots rangehängt.

    Dateien

    • netstat1.JPG

      (100,82 kB, 7 Mal heruntergeladen, zuletzt: )
    • netstat2.JPG

      (65,78 kB, 5 Mal heruntergeladen, zuletzt: )
    • netstat3.JPG

      (99,03 kB, 4 Mal heruntergeladen, zuletzt: )
    • netstat4.JPG

      (73,61 kB, 3 Mal heruntergeladen, zuletzt: )
    • netstat5.JPG

      (131,07 kB, 3 Mal heruntergeladen, zuletzt: )
    • netstat6.JPG

      (186,86 kB, 3 Mal heruntergeladen, zuletzt: )
    • netstat7.JPG

      (71,66 kB, 4 Mal heruntergeladen, zuletzt: )
    • servicebinding.JPG

      (108,61 kB, 4 Mal heruntergeladen, zuletzt: )
  • Von der Servicebindung sollte das eigentlich passen, den Rest hättest Du Dir scheinbar schenken können, ich verstehe es nämlich nicht :D

    Für mich sieht es eher so aus, als würde der Webserver / Apache nur auf IPv6 laufen, damit wäre er aber auch nicht über LAN1 per v4 erreichbar...


    Wenn niemand eine Lösung hat oder in den Screenshots etwas sieht, was ich nicht sehe, würde ich mal den Support kontaktieren und mir schonmal Alternativen (zB Container/ VM) überlegen.

  • Mod: Nicht deklariertes Zitat ohne Quellenangabe ... korrigiert! :handbuch::arrow: Forenregeln und Die Zitat Funktion des Forums richtig nutzen

    Von der Servicebindung sollte das eigentlich passen, den Rest hättest Du Dir scheinbar schenken können, ich verstehe es nämlich nicht :D

    ^^

    Vielen vielen Dank für deine Mühen!


    Ich versuche es wohl mal über den Support. VM wäre natürlich auch ne Option, aber wäre ärgerlich wenn das für so eine "Kleinigkeit" nötig ist.

  • Hi, ein Tipp: Nächstes mal bitte mit Blumen. ;)


    Konkret:

    netstat -tulpen

    Dann ist die Ausgabe übersichtlicher und beschränkt sich nur auf Listen/TCP/...


    Abgesehen davon ist netstat veraltet und man nimmt stattdessen ss (hab nicht probiert ob dieses Befehl auf QNAP verfügbar ist).


    Ich habe mir trotzdem alles angeschaut. Es existiert ein LISTEN-Eintrag für HTTP unter IPv6. D.h. es dürfte passen da IPv4 auf IPv6 gemappt wird. Mal ne blöde Idee: Kannst Du die Website per IPv6 Adresse aufrufen?