Platten-Upgrade: Hot swap, mache ich es richtig?

  • Das Plattenvolumen meines TS-469 Pro-NAS kam an seine Grenzen; bestückt mit 3 Seagate-Platten (NAS HDD) à 3 TB als Raid 5. Ich habe mir daher 4 neue Platten Seagate IronWolf NAS á 6 TB gekauft (knapp unter 800 €) und erstmal eine neue Platte ohne Formatierung in den noch leeren Slot gesteckt. Es hat über 24 Stunden gebraucht, bis die Platte migriert war. Ist das so normal? Ich hatte das noch nie gemacht. Ich bin Anwender und kein IT-Profi (wenn auch in IT-Sachen nicht ganz unerfahren).


    Ich habe Laufwerk 1 gestern schon entnommen und heute, nach dem die Migration von Laufwerk 4 abgeschlossen war, eine unformatierte neue Platte in Schacht 1 eingeschoben.


    Das NAS meldete mir:

    Volume 1 neuerstellen. Volume 1 abgeschlossen.

    und knapp 18 Minuten später später:

    RAID-Kapazität erweitern. Volume 1 abgeschlossen.

    (weitere Meldungen im Screenshot)


    Im Speichermanager zeigt mir das NAS für Schacht 1 aber nach wie vor die bereits ausgetauschte alte Festplatte an (ST3000VN000-1H4167) mit 2,7 TB an. So ganz korrekt kann das ja nicht sein.


    Habe ich etwas falsch gemacht? Bevor ich die anderen beiden Platten austausche, hätte ich gern Gewissheit.


    Martin

    Dateien

    • nasmeldungen.png

      (137,61 kB, 10 Mal heruntergeladen, zuletzt: )
  • guck mal ins Handbuch, da ist beschrieben wie man die Kapazitaet erweitert (dabei auch beachten das dein altes NAS nicht über 16TB erweitern kann also 4 Platten mit 6TB in RAID5 wird nicht gehen)

  • Ist schon prima: erst machen, dann fragen 8).

    Und gleich dazu sagen, das man(n) sich nicht auskennt.


    Ein TS 469 hat schon HAL Firmware, da sollte das Volume auch über 16 TB zu erweitern sein.


    Der normale Weg wäre im Storage Manager "Disk einzeln ersetzen" wählen, dann eine Disk auswählen, ziehen und die neue Disk stecken.

    Der Rebuild dauert tatsächlich über 24h, zumindest bei diesen Plattengrößen. Wenn alle Platten ersetzt sind, dann kann man das Volume erweitern.


    Solange kannst Du von den größeren Platten keine Mehrkapazität nutzen.


    Gruß


    Nachtrag: so wie Du mit dem NAS umgehst (Platte 1 ziehen während die Erweiterung läuft), das grenzt schon an grobe Fahrlässigkeit.

    Beim Raid5 darf genau eine Platte ausfallen. Ein Rebuild bzw. die Raiderweiterung ist Stress für die Platten. Dabei noch die Last freiwillig erhöhen...

    Ein Backup ist hoffentlich vorhanden.

    Einmal editiert, zuletzt von FSC830 ()

  • Die Zeit für den rebuild hängt auch von der Einstellung ab, Default, Hintergrund oder Sync zuerst.


    Erstes nutz etwa 75% des maxspeeds, zweites 50% und letztes 100%.


    Letztes geht damit am schnellten, jedoch sollte dann nicht parallel aufs NAS Zugegriffen werden und Dienste wie Plex usw. sollten nicht arbeiten.


    Dann ist das im besten Fall auch ein einziger großer sequenzieller Lesevorgang für die HDs und die rattern sich nicht tot.


    Denn fällt dann eine HD aus, hast du nur noch das hoffentlich vorhandene aktuelle Backup.

  • Ein TS 469 hat schon HAL Firmware, da sollte das Volume auch über 16 TB zu erweitern sein.

    Mein Fehler, das NAS klingt nach CAT1 aber ist CAT2, vollkommen richtig

  • Danke für den Hinweis auf das Handbuch! Ein anständiges NAS hat natürlich Platz dafür, aber ich bin einfach nicht auf die Idee gekommen, danach zu schauen.


    Ich sehe auch bei neueren Modellen Begrenzungen auf z.B. 14 GB. Da bin ich das Upgrade wohl etwas zu unüberlegt angegangen. Mit solchen Hürden habe ich nicht gerechnet. :-((

    Wenigstens kann ich inzwischen wieder auf meine Daten zugreifen und die Belegung wird jetzt nicht mehr mit 90 %, sondern 50 % angezeigt. Trotzdem ist es nicht befriedigend, wenn ich mit 2x 6 TB + 2x 3 TB nicht wenigstens 16 TB habe, sondern (wie mir angezeigt wird) 8 TB.


    Die weit aus meisten Computerprobleme erledigen sich wie von selbst, wenn man den Rechner neu startet. Mal schauen, wie es aussieht, nachdem ich das NAS neu gestartet habe...


    Nach dem Reboot: Raid-Gruppe wird aktualisiert. Die angegebene Zeit (19 Stunden) ist schon nach ein paar Minuten auf 11:53 h zusammen geschrumpft. Ich schaue morgen mal.


    Das Backup wurde ein paar mal angesprochen. Backups sind wohl das, was die viele (mit ungutem Gefühl) vernachlässigen. Da muss ich mich einreihen.


    Ich habe zwar Vorsorge getroffen und ein zweites NAS angeschafft, das ein anderem anderen Ort steht und gut über DSL angebunden ist, aber ich habe das gegenseitige Spiegeln von Daten noch immer nicht eingerichtet. So ist das mit langen ToDo-Listen. Ich werde bei Gelegenheit darauf zurück kommen und mich erst bei der netten Community hier erkundigen bevor ich loslege; zunächst gilt es ja auch aus einer Fülle von Möglichkeiten die am besten geeignete Technik auszuwählen.

    Dateien

    • afterreboot.png

      (25,15 kB, 2 Mal heruntergeladen, zuletzt: )

    4 Mal editiert, zuletzt von Martin Lemke ()

  • Er hat aber bisher 2x6 und 2x3, da ist nichts mit Volume vergrößern.

    Erst wenn alle 4 ersetzt sind.


    Gruss


    P.S. Da hilft auch kein Neustart ;).

  • Aktueller Stand:

    - Host Disk 1 failed

    - Rebuilding skipped


    Konsequenz:

    - Disk 1 unplugged

    - NAS Host: Festplatte wurde erkannt

    - Volume neu erstellen; Volume 1 startete 2020-02-07 07:09:01

    - RAID-Gruppe Aktualisierung

    RAID-Gruppe 0

    63.78 MB/s (Standard)


    Preisfrage: Was ist wahrscheinlicher?

    a) Ich habe die Festplatte durch hot unplugging (bei vollem Lauf) beschädigt

    b) Firma Reichelt hat mir eine defekte Platte geliefert


    Ich vermute a) und werde sie damit besser nicht zurück schicken – Betrug kommt für mich nicht in Betracht, schließlich gibt es bei Seagate eine Qualtitätskontrolle und ich kenne so etwas wie Anstand. Ich möchte auch nicht die Fehler anderer auslöffeln; so muss es auch umgekehrt gelten.


    Pech kommt noch hinzu: Die Platte ist teurer geworden. Eine kostet bei Reichelt nicht mehr 199 €, sondern jetzt 207 €; bei Saturn ist sie noch für 199 zu bekommen, aber man muss sich zum Bestellen datenmäßig nackig machen (Telefonnummer) – bei Reichelt habe ich die Wahl.

    Einmal editiert, zuletzt von Martin Lemke ()

  • Das ist für mich ein DOA, wenn die beim ersten Lauf drauf geht.

    SATA ist hotplugfähig.

    Was dabei drauf geht sind wenn die Daten, die im Buffer sind dann verloren.


    Das hat mit Betrug nix zu tun.


    HDs haben Anfangs eine erhöhte Ausfallrate, dann sinkt die um am ende der geplanten Lebensdauer wieder zu steigen.

    Siehe Badewannenkurve.


    Dann ist noch der Transport ein Faktor, die halten zwar einige g Impulse aus, aber das hat enge Grenzen. Falsche Verpackung und ein rabiater Mitarbeiter beim Versand = DOA.

  • Die Platten steckten fixiert in einer Styroporverpackung und die in einem geräumigen Karton mit Packpapierpolstern. Allerdings fehlte auf dem Karton ein Hinweis auf die Empfindlichkeit des Inhalts. Aber warum sollte da eine von vier Platten kaputt gehen? Rein rechtlich muss ich den Karton öffnen, sobald ich ihn bekomme und den Inhalt überprüfen – aber äußerlich war alles OK.


    Die Aktualisierung dauert noch ca. 6 h.

  • Kannst dich jetzt wegen dem Schaden an den Händler wenden oder an den Hersteller zwecks Garantie.

  • Da war der Kopf aber schon längst geparkt.

    Wenn nicht hättest du ein ziccccccccchhhh gehört, extrem metallisch, das vergisst man nicht, wenn man es 1 mal erlebt hat.


    Wenn das nicht der Fall war, und du keine übermäßig hektischen Bewegungen gemacht hast, ist das Lager der Spindel noch ok.


    Laptop HDs hat man ja auch rum getragen wenn die liefen, der Sturzschutz ist nur bei extremen Beschleunigungen aktiv geworden und hat hier die Köpfe gnadenlos geparkt.

  • OK, ich schicke die Platte ein.


    Nachdem das 3. neue Laufwerk integriert war, habe ich das letzte 3 TB-Laufwerk (Nr. 2) entfernt. Damit sind jetzt 3 Platten á 6 TB im Gerät und ich frage mich, warum mir eine Gesamtkapazität von 8 TB angezeigt wird und nicht etwa 20. Muss ich im Speichermanager noch irgend eine Aktion durchführen?

    Dateien

    2 Mal editiert, zuletzt von Martin Lemke () aus folgendem Grund: Anscheinend kann ich kein weiteres Posting hinzufügen, also muss ich mein letztes erweitern