RealVNC und Linux Station Keine Verbindung

Keine passende Antwort gefunden? Dann frag uns doch direkt, kurz registrieren und los gehts!

  • RealVNC und Linux Station Keine Verbindung

    Hallo zusammen,

    ich habe ein Problem. Ich habe mir RealVNC auf meinem Windows 10 Rechner installiert und wollte nun über diesen auf die Linux Station zugreifen. Ich bekomme aber keine Verbindung hin. Wenn ich den Link in QTS aufrufe geht es einwandfrei, nur in ReaVNC nicht. RealVNC ist in der aktuellsten Version. RealVNC meckert irgendwas von "Ungültiger Endpunkt: Port wurde nicht ordnungsgemäß angegeben" dabei habe ich ja gar nichts verändert. Müsste also Port 5900 sein. Aber auch wenn ich diesen Angebe, funktioniert es nicht. Jemand ne Idee?
  • Hi,

    ich glaube das hat etwas mit den Switchen zu tun, ich bin mir nur noch nicht sicher.

    Ich komme auch nicht mehr von "außen" auf meine LinuxStation. Ich habe den Teamviewer installiert und auch mit diesem erreiche ich die LinuxStation nicht.

    Mir ist aufgefallen, das ich zwei "Netze" in der Linux Station habe.

    Ich denke einmal deine DMZ und eine die nach "draußen" ist.

    Nur wie bekomme ich zu LinuxStation eine Verbindung von außen hin?!

    Vielleicht hat ja jemand eine Idee.
  • Ich greife über den RealVNC Viewer auf meine Linux station zu. Bei mir funktioniert das mit der vom Router zugewiesenen IP und ohne Portangabe. Problem ist nur, dass er dann ein Passwort haben möchte. Dieses Musst du dir leider erst über eine SSH oder die Weboberfläche aus der Datei "/tmp/.qnap/vncpassword" in der Linuxstation holen.
    Damit klappt es zumindest bei mir ohne Probleme. Was ich noch nicht wieß, ist ob das Passwort immer gleich bleibt...das Internet ist der Meinung, es würde sich ändern...
  • RubberDuck1983 schrieb:

    Ich klicke ja auf den Link, der direkt bei LInuxStation angezeigt wird, ich möchte ja von EXTERN drauf zugreifen.
    Ja und genau darum nimmst du eben nicht den Link, der bei der Linux Station angezeigt wird, sondern die IP Adresse die von Router zugewiesen wird.

    steve-o schrieb:

    Was ich noch nicht wieß, ist ob das Passwort immer gleich bleibt...das Internet ist der Meinung, es würde sich ändern...
    Ich, als Teil dieses Internets, meine auch das es sich nach jedem Neustart der Linux Station ändert, denn wenn man sich den entsprechenden Quellcode, der das Passwort generiert, anschaut

    Quellcode

    1. ExecStartPre=/bin/bash -c "[ -f /tmp/.qnap/vncpassword ] || openssl rand -base64 8 > /tmp/.qnap/vncpassword
    ist es klar, dass es sich ändern muss. Wie in dem verlinkten Artikel, oder auch hier im Forum, schon ab und zu mal besprochen, reicht es aber diese Zeile anzupassen um das generieren zu vermeiden und ein "festes" Passwort zu setzen.
  • Hallo,

    kurzes Update.....bei mir geht es jetzt. Komischerweise habe ich gar nichts gemacht. Ok. Windows 10 hat sämtliche Updates gemacht und bin nun auf diesem Fall Creater Stand....Seit diesem Update geht es, ohne das ich was gemacht habe. Vielleicht wurde irgendwas aktualisiert?!
    Scheint bei mir wohl ein Fehler seitens Windows / RealVNC zu sein, nicht QNAP.

    P.s. Anpingen konnte ich die Station immer....nur nicht per VNC zugreifen...Vielleicht hilft das jemand....