Wie man mit ein paar schlechten Blöcken eine NAS "TILT"

  • Ein kleiner Erfahrungsbericht. :-/


    Ich habe seit gestern "by chance" eine "verdächtige" WD30EFRX zur "Untersuchung" hier liegen.



    Am PC / Sata


    Windows Datenträgerverwaltung
    Platte kann nicht partitioniert und formatiert werden, Windows meldet Scheitern wegen Read I/O error


    WD Diagnostics
    Vom WD Diagnostics Tool unter Windows wird sie erkannt und SMART OK gemeldet, sämtliche SMART-Einzelwerte sind unauffällig
    Der WD SMART Kurztest meldet keine Fehler, Platte OK


    HDTunePro
    Read Benchmark kann nicht gestartet werden, HDTune meldet READ I/O error. Alle SMART Werte ebenfalls unauffällig und "grün"
    Quick Error Scan findet reihenweise schlechte Blocks ab LBA 0, insgesamt ca. 50 schon auf den ersten 3GB
    Platte also augenscheinlich in grösserem Umfang geschädigt



    Ich entschloss mich zu einem vollständigen BadBlockScan.
    Um den PC damit nicht zu belasten (womöglich einen halben oder gar ganzen Tag), ist der Plan, diesen in der NAS durchzuführen.
    Scan am PC abgebrochen.



    An einer TS-559pro mit FW 3.7.2 und belegten Slots 1,4,5 im Einzeldiskbetrieb


    Platte eingebaut in Slot 3, NAS gestartet:
    Hängt bei "Loading Drivers" - und Ende. Wieder abgeschaltet, HDD3 raus.


    NAS gestartet und ohne diese HDD3 hochgefahren: OK


    Diese HDD3 per Hotplug eingebaut:
    Wird erkannt, HDD-Lämpchen grün, Datenträgermanagement-Anzeige: OK, SMART-Schnelltest: OK, SMART-Werte: OK


    Dann formatieren in ext4:
    Scheitert. Uhrkreis dreht sich eine Weile auf 0%, dann verschwundibus und Status ist wieder: Not Initialized.
    Gut, dann eben nicht.


    BadBlockScan:
    Lässt sich starten, zeigt nach wenigen Augenblicken 4 schlechte Blöcke, nach einigen Minuten keine weitere Veränderung.


    Wechsel in SMART-Screen der WebGUI: scheitert.
    Eine Weile drehender Uhrkreis, dann weisse Inhaltsfläche.
    Verzeichnisstruktur auf der linken Seite ist noch vorhanden


    Wechsel in Systemprotokollseite der WebGUI: scheitert.
    Same Game, siehe oben.


    Weboberfläche friert nun ein. Aus dem benachbarten Kellerraum piepst es: NAS hat sich selbst neugestartet.
    Neustart scheitert aber: Hängt bei "Loading Drivers". Das hatten wir oben schon mal.


    Weitere Hotplug-Versuche scheitern. Nach dem Hotplug (HDD-Lämpchen Grün!) lässt sich der Datenträgermanagement-Screen erst gar nicht mehr aufrufen.
    NAS startet wieder neu... ...und so fort.


    ==> Game over and out.



    Warum mache ich solch einen "Blödsinn" und berichte ihn ?


    Weil ich es ganz interessant fand, wie ein Platte mit genügend schlechten Blocks eine ansonsten robuste Atom-NAS mit robuster Firmware und robuster Konfiguration (Einzeldiskbetrieb) komplett "aus dem Tritt" bringen kann.


    Weil hier wieder einmal ein Paradebeispiel vorliegt, was "GUT" - SMART-Werte allein im Einzelfall über den Zustand einer Platte möglicherweise aussagen können: NICHTS.


    Weil ich die Symptome, die meine NAS hier zeigte, so und in ähnlicher Form schon oft hier im Forum gelesen habe, meist mit unbekannter Ursache und mit allem unter Verdacht, nur nicht der HDD. Die können wir jetzt also stellenweise vielleicht schon früher verschärft verdächtigen...



    Oder wie sacht auch Loddar jerne: Again what learned, soh de day was not umsonst. :mrgreen:


    Euch einen schönen Feierabend und nur gesunde Festplatten,
    GLG GBD

  • Zitat von "GorillaBD"

    Warum mache ich solch einen "Blödsinn" und berichte ihn ?


    Weil -

    Zitat

    Again what learned, soh de day was not umsonst.


    und hoffentlich durch deinen prima Bericht wieder 1000 technisch interessierte user ein aaaahaa-Erlebnis haben :thumb:


    Danke -
    Michael

  • Zitat von "GorillaBD"

    Weil hier wieder einmal ein Paradebeispiel vorliegt, was SMART-Werte allein im Einzelfall über den Zustand einer Platte möglicherweise aussagen können: NICHTS.


    Hier muss ich mal ein Mini-Veto einlegen.
    Schlechte SMART-Werte sagen schon was aus - nämlich, dass die Platte bald ihren Geist aufgibt. Es müsste also eher heissen gute SMART Werte sagen nicht viel aus. ;)


    Was mir aber noch dazu einfällt. Es könnte ja auch durchaus sein, dass bei deiner Platte die Datenträger vollkommen intakt sind und der SMART damit recht hat, jedoch der SATA-Kontroller oder der Pufferspeicher auf der Platte nen Schlag weg hat, was zu ähnlichen Ergebnissen führen kann. Die fehlerhaften Blöcke würden dann an jeder x-beliebigen Stelle angezeigt werden, ohne dass sie dort existieren.

  • Ich freue mich über Euer Feedback. :)


    Mike, danke für den Hinweis zum "Gut"-SMART, ich habe das im Bericht entsprechend editiert.


    Das mit der Controllerdefektvermutung klingt mir plausibel. Wäre der Controller in Ordnung, sollte der Zugriffsversuch nicht die NAS gleich aus dem Tritt bringen, eher sollten erfolglose Zugriffsversuche im SMART gelistet werden oder sogar ein Block-Remapping durchgeführt werden. Ich werde der HDD jetzt mal mit PC-Tools auf die Pelle rücken, ob sich Dein Verdacht damit bestätigen lassen sollte.


    Thx und Greets
    GBD


    --- EDIT ---


    Also, der Controller dürfte abgeraucht sein. Ein Oberflächen-Quicktest zeigt jetzt in JEDEM getesteten Sektor schlechte Blocks. Der Total-Erase (Nullen) startet nicht richtig, um dann im Verify plötzlich ALLE Sektoren als BAD zu kennzeichnen - nach etwa 2 Minuten. Remapped wurde bei den Schreib-/Lesetesten auch nichts. Die Platte hat mal grade 170 Betriebssstunden und macht keinerlei verdächtige Geräusche, möglicherweise hängt auch der Kopf, den habe ich noch nicht gehört. In jedem Fall geht da nix mehr, auch keine weitere Diagnose.

  • Tja,... ab in Richtung Hersteller ,.... oder

  • Ist nicht meine Platte... ...aber klar, ja. Ich hatte das Teil nur interessehalber hier.


    Soweit, jetzt mal die Controllerplatine einer intakten WD30EFRX in diese hier zu tauschen, geht mein "Forscherdrang" jedenfalls nicht. :mrgreen:

  • Zitat von "GorillaBD"

    ...Soweit, jetzt mal die Controllerplatine einer intakten WD30EFRX in diese hier zu tauschen, geht mein "Forscherdrang" jedenfalls nicht. :mrgreen:


    Ach komm - jetzt überwinde einfach Deinen "inneren Schweinehund" :engel:
    Die Neugierde wird siegen :mrgreen:


    Beste Grüße


    Sascha