Was ist "dovecat" und warum frisst es so viel Arbeitsspeicher?

  • Hallo liebe Community,


    seit dem vorletzten Firmware-Update meiner TS-453A (aktuell ist die 4.4.3.1439 installiert) habe ich Probleme mit einem Prozess namens "dovecat", der für eine hohe Prozessorlast sorgt und den Arbeitsspeicher mehr als auslastet. Im Internet finde ich nur Hinweise auf einen Prozess namens "dovecot" (also mit einem "o").

    Weiß jemand, was für ein Prozess das ist und wie man ihn los wird? Er läuft unter den "Systemprozessen" und ist dort zwei mal aufgeführt:

    pasted-from-clipboard.png


    Wäre super, wenn mir jemand weiterhelfen könnte. So ist die NAS unbenutzbar und ich habe Angst, mir eine Malware eingefangen zu haben. Der Netzwerktraffic ist allerdings nicht erhöht und Antivirus sowie Malware Remover haben bei ihren Scans nichts gefunden...

  • Ist das NAS aus dem Internet erreichbar?

    Wenn ja würde ich darauf tippen, dass Du Dir einen Cryptotrojaner eingefangen hast und der jetzt fleißig Bitcoin, Monero, Ethereum etc. schürft.

  • Ist das NAS aus dem Internet erreichbar?

    Ja, wegen der Photostation ist es aus dem Netz erreichbar. Sehe auch gerade, daß es viele fehlgeschlagene Anmeldeversuche zwischen dem 27.09. und 30.09. gegeben hat. Das blöde ist: erfolgreiche Anmeldungen werden im Systemprotokoll nicht gespeichert.

    Würde mich aber wundern, wenn einer das (rein zufällige) Passwort geknackt und auch die Zweifaktor-Authentifizierung überwunden hätte.


    Aber wenn dem so ist, hilft wohl nur der Rücksprung auf eine alte Sicherung, oder?


    Edit 21:25 Uhr:

    Habe im amerikanischen QNAP-Forum einen Eintrag gefunden, der das selbe Problem beschreibt. Abhilfe schaffte hier wohl ein altes Backup.

    Werde aber eher den anderen Tipps folgen, das NAS komplett neu aufsetzen und es vom WAN trennen.

    Eventuell dann eine VPN-Verbindung einrichten. Mal sehen...

    Einmal editiert, zuletzt von PrivateJoker ()

  • Würde mich aber wundern, wenn einer das (rein zufällige) Passwort geknackt und auch die Zweifaktor-Authentifizierung überwunden hätte.

    Wenn's eine (bekannte) Schwachstelle gibt, muss er dein PW gar nicht kennen/überwinden, dann gibt's einen Hintereingang!


    Aber wenn dem so ist, hilft wohl nur der Rücksprung auf eine alte Sicherung, oder?

    Nö, keine Rücksicherung, neu Aufsetzen und vorher ordentlich säubern und noch vorher die Lücke finden und schließen. Sonst ist es eigentlich egal.


    Das NAS sollte einfach NIE aus dem Internet erreichbar sein, wenn, dann nur über VPN.

  • Nö, keine Rücksicherung, neu Aufsetzen und vorher ordentlich säubern und noch vorher die Lücke finden und schließen. Sonst ist es eigentlich egal.

    Na dann habe ich ja schon eine Beschäftigung für das Wochenende :(

    Die Frage ist nur, wie ich die Lücke finden sollte. Das muss ich wohl QNAP überlassen. Mal sehen, ob es in den nächsten Bulletins etwas dazu zu lesen gibt.

  • Wie schon im Englischen Forum geschrieben ..keine QTS Teile dem WAN ausetzen ... ist ja net das erste mal das diverse "Stations" als Einfallstore genutzt wurden

  • Falls das nicht klar sein sollte:

    RedDiabolo meinte mit Lücke schliessen das Abstellen der Portweiterleitung von Deinem Router zum NAS. Die Lücke in PhotoStation oder QTS kannst Du wohl kaum finden, nur auf das letzte Level updaten.

  • Wie schon im Englischen Forum geschrieben ..keine QTS Teile dem WAN ausetzen ... ist ja net das erste mal das diverse "Stations" als Einfallstore genutzt wurden

    Spannend. Ist das Zufall oder bist Du der dolbyman aus dem QNAP-Forum? :)


    Habe die Platten jetzt per USB-SATA-Adapter an den PC gehängt und die logischen Laufwerke gelöscht. Ich würde jetzt annehmen, daß die Platten damit als "jungfräulich" gelten und das NAS sie bei der (Neu-)Einrichtung formatiert. Oder sollte man - wie im QNAP-Forum geschrieben - nochmal formatieren?


    Wobei das ja bedeuten würde, daß ich ein wie auch immer geartetes Dateisystem anlegen müsste, um überhaupt formatieren zu können :/

  • Spannend. Ist das Zufall oder bist Du der dolbyman aus dem QNAP-Forum?

    Der gleiche in beiden Foren.


    Habe die Platten jetzt per USB-SATA-Adapter an den PC gehängt und die logischen Laufwerke gelöscht. Ich würde jetzt annehmen, daß die Platten damit als "jungfräulich" gelten und das NAS sie bei der (Neu-)Einrichtung formatiert.

    Das geht auch, normalerweise ist ein "clean" via diskpart vollkommen ausreichend

  • Ja... vor allem die Empfehlung man solle Security Counselor und die Firewall installieren finde ich sehr fragwürdig.


    Die Firewall ist noch beta, viele dürften kaum wissen was sie damit tun und der Counselor wirft nur mit Vorschlägen um sich.

    Wenn das NAS doch eh dem Internet ausgesetzt ist damit Zugriff von dort besteht, dann helfen die beiden Apps auch nüschts... aber der Vorschlag das NAS nicht aus dem Internet erreichbar zu machen fehlt fürs Erste...

  • Da steht eine Firewall.

    Und damit ist das so allgemein gehalten, das man auch interpretieren könnte.

    Setze das NAS nicht dem Internet direkt aus.


    Der Hinweis auf VPN fehlt lediglich.