Problem mit Zugriff Owncloud und OwncloudX mit Lets Encrypt Zertfikat

  • Hallo Freunde,


    seit einiger Zeit greife ich nur noch per https auf Owncloud (8.0.4) zu, soweit läuft das auch gut. Per Lets Encrypt mit einer URL aus myqnapcloud.com, also "https://XXX.myqnapcoud.com:8081/owncloud".


    Nun habe ich dazu OwncloudX installiert, das auf Port 4490 läuft. Also das Portforwarding im Router von extern 4490 und intern 4490 erweitert.

    Leider klappt der Zugriff nicht auf "https://XXX.myqnapcoud.com:4490", es gibt immer nur die Fehlermeldung im Firefox:


    Code
    1. "Beim Verbinden mit XXX.myqnapcloud.com:4490 trat ein Fehler auf. SSL hat einen Eintrag erhalten, der die maximal erlaubte Länge überschritten hat. Fehlercode: SSL_ERROR_RX_RECORD_TOO_LONG"


    Allerdings klappt der Zugriff mit der internen IP-Adresse ohne Verschlüsselung.


    Hab ich da evtl. was übersehen? Vielleicht hat das schon jemand selbst gehabt.


    Ich danke im Vorwege.


    Mfg,

    meinerseins

  • Ich schließe mich mal der Frage an, denn ich bekomme keine Verschlüsselung der OwnCLoudX Installation auf meinem QNAP hin. Leider habe ich auch im Web und bei Google nichts gefunden, was für mich bisher hilfreich war.

  • Schließe mich ebenfalls an.

    Ich habe owncloudx einfach per App Center installiert und mit mariaDB in Betrieb genommen.

    Owncloudx funktioniert mit http ohne Probleme.


    Die Weboberfläche des NAS selbst kann ich ohne Probleme auch per https aufrufen und nutzen.


    Bei owncloudX weiss ich nicht einmal, wo ich anfangen soll zu suchen: Containerstation? owncloud? QTS? Webserver?


    Ich habe schonmal einen postscanner gegen das NAS laufen lassen, aber der hat nicht einmal den Standardport 4490 gefunden....


    Leider benötige ich SSL zwingend, weil ich mit einem iOS device auf den Kalender zugreifen möchte.

    Rein netzintern reicht mir vollkommen aus, von externem Zugriff rede ich gar nicht..

  • hallo,

    ich habe ebenfalls das gleiche problem. sobald ich über die myQNAPcloud und nicht mit der lokalen ip auf die owncloud X zugreifen möchte, erscheint ein hinweis, dass ich die domain erst in die white list eintragen muss. wenn ich das in den einstellungen mache, bringt das leider nicht den gewünschten erfolg. habt ihr schon eine lösung gefunden?

  • Das klingt so,als würde es bei Dir lokal funktionieren, nur über das Internet nicht?

    Falls ich das richtig verstanden habe: wie greifst Du per SSL auf owncloud zu?

  • hallo, ganz genau. lokal ist es kein problem. aber sobald ich von außen zugreifen möchte, wird verlangt dass ich die domain über welche ich zugreife erst registriere. es gibt in den einstellungen die möglichkeit, "add domain" aber egal was ich hier registriere, es funktioniert nicht.


    bzgl SSL verlangt er von mir eine "Zertifikatsauthentifizierung" siehe Bild. versuche es gerade ohne ssl hinzubekommen ;)

  • welchen Link benutzt Du, um lokal per SSL auf owncloud zuzugreifen?

  • Da ich hier einen Zusammenhang mit der Tatsache sehe, dass de https-Zugriff auf dei OwnCloud per default nicht vorgesehen ist, will ich dafür keinen neuen extra Thread aufmachen.

    irgendwie durchschaue ich aber den Zusammenhang noch nicht:
    Teile der OwncloudX laufen in DOCKER Containern.

    der Port 4490 wird in den Docker mit Port 80 umgeleitet.
    Das könnte auch auf Port 443 erfolgen, womit https realisiert wäre, d.h. man braucht keinen Reverse Proxy.

    1. Problem: wie kriegt man die erforderlichen Zertifikate innerhalb des Docker eingebunden.

    2. Problem: Zertifikate auf dem Server sind geeignet, dem Client zu bestätigen, dass der Server der "richtige" ist, aber wenn ich sicher stellen will, dass NUR bestimmte Clients überhaupt mit dem Server kommunizieren, dann benötigen wir eigentlich ein Client Zertifikat. Das ist aber aufwändig und läßt sich viel einfacher mit OpenVPN abbilden. Reicht es wirklich das verwendete Passwort zu verschlüsseln?


    3. Viele Posts beziehen sich schon auf aktuellere Versionen von OwncloudX. Wo kommen die her?

    M.

  • es gibt in den einstellungen die möglichkeit, "add domain" aber egal was ich hier registriere, es funktioniert nicht.

    Hallo Flo, ich habe die Domain in der config.php über ssh eingefügt. Für mich war das die sicherste Methode, jedoch alles ohne Verschlüsselung. Ich würde es an deiner Stelle auch so machen.

  • MatthiasJ :

    Das mit dem Docker finde ich besonders merkwürdig. Wenn owncloudX tatsächlich in einem Container läuft, warum wird das in der Container Station kein Container angezeigt?

    Denn nur so könnte man ja da überhaupt eine Konfiguration vornehmen.

    Oder ist das bei Dir anders und Du siehst einen Container?


    Gruß

    Martin

  • Hallo Flo, ich habe die Domain in der config.php über ssh eingefügt. Für mich war das die sicherste Methode, jedoch alles ohne Verschlüsselung. Ich würde es an deiner Stelle auch so machen.

    hallo janste, vielen dank für deine antwort. habe nur ein problem: über ssh kann ich im pfad cd share/HDA_DATA/ leider nichts finden. die datei scheint leer zu sein

  • Hallo Flo, du musst im Verzeichnis /Cachedev1_Data/.qpkg/owncloudv10/config oder so ähnlich schauen. Das Verzeichnis .qpkg ist auch ein verstecktes Verzeichnis.

  • MOK24  
    Ja, irgendwie kommt mir das auch alles sehr merkwürdig vor.
    Einen Docker Container sehe ich nicht.
    über SSH kann ich auch nichts laufendendes finden, aber
    netstat verbindet den Port mit Docker


    tcp 0 0 :::4490 :::* LISTEN 31645/dockerd


    im Startscript steht (verkürzt)

    Code
    1. QPKG_NAME="owncloudv10"
    2. QPKG_ROOT=/sbin/getcfg $QPKG_NAME Install_Path -f ${CONF}
    3. $CONTAINER_ROOT/bin/system-docker-compose -f $QPKG_ROOT/docker-compose.yml up -d

    Da ich aber (noch) gar keine Erfahrung mit Docker habe, und nur weiß, dass man damit einzelne Dienste kapseln kann stecke ich fest, bis ich Zeit habe das Konzept genauer zu untersuchen.
    Falls jemand schon mehr herausgefunden/verstanden hat wäre eine Erklärung toll.

    :handbuch::?:

  • Hallo Flo, du musst im Verzeichnis /Cachedev1_Data/.qpkg/owncloudv10/config oder so ähnlich schauen. Das Verzeichnis .qpkg ist auch ein verstecktes Verzeichnis.

    hallo janste, vielen dank auch hierfür. gefunden habe ich alles. jetzt "leider" noch eine letzte frage: wie schaffe ich es die config.php datei zu öffnen bzw. wie kann ich sie bearbeiten? habe herumgetüftelt wie ein wahnsinniger...

  • Hallo zusammen,


    ich stehe leider immer noch auf dem Schlauch.

    Ich habe ocx über das App Center von qnap installiert und komme auch problemlos innerhalb meines Netzes drauf. Nur von außerhalb nicht...

    Ich habe auch das Letsencrypt Zerifikat und erhalte einfach keinen Zugriff auf ocx


    Kennt jemand einen Installationsquide für Dummies für den Zugriff auf oc von unterwegs mit Letsencrypt und aus dem qnap app store?

  • Aber du kommst erst einmal ohne Verschlüsselung auf die Owncloud oder hängt es da auch schon?

  • äääääähm, leider nicht direkt.

    Über die IP intern funktioniert es.

    Wenn ich aber owncloud über xxx.myqnapcloud.com:4490 aufrufe (mit /owncloud funzt es leider nicht) kommt da aktuell der Hinweis auf eine nicht vertrauenswürdige Domain, obwohl ich obige hinzugefügt habe.:/

  • Kann das am Port liegen? Lets encrypt ist glaub ich sehr kritisch, wenn du non standard Ports nimmst.


    Hast du bei dem Hinweis mal einfych weiter gemacht? Also den Zertifikatserror ignoriert?

  • Also zum einen läuft die Owncloud bei mir auch nicht über eine sichere Verbindung. Ich greife dort ungeschützt über port 80 auch von außen drauf zu. Es kann sein, dass du aber eingestellt hast, dass du nur sichere Verbindungen aus dem Web zulässt, was dann eine Anfrage über http statt https nicht zulässt. Du bekommst auch einen Hinweis, dass die Ownloud nicht über eine gesicherte Verbindung geöffnet werden kann von außen, wenn du die App aus dem App-Center installierst.

  • rein über http ist mir das irgendwie zu unsicher. auch wenn sich vermutlich niemand für meine Photos interessiert ;-)


    Wisst ihr, ob das mit einem kostenpflichtigen Zertifikat besser funktioniert?


    Weiter klicken finde ich nicht:


    Code
    1. Du greifst von einer nicht vertrauenswürdigen Domain auf den Server zu.
    2. Please contact your administrator. If you are an administrator of this instance, configure the "trusted_domains" setting in config/config.php.
    3. An example configuration is provided in config/config.sample.php or at the documentation.