Beiträge von MatthiasJ

    Moin,
    über ein docker-compose.yml wurde eine Docker APP erzeugt. Irgendwas läuft da aber über die Kommando-Zeile anders als bei Nutzung des UI.

    Die erzeugte Docker APP "meineApp-123" hat zwei Container "meineApp-123_APP_1" und "meineApp-123_DB_1"

    Weder über die Actions von "APP" noch der Unter-Container läßt sich das Gebilde kontrollieren. Es kommt nur

    Code
    1. `Application not found: meineAPP-123`

    Wie kann ich über das UI eine APP anlegen, wenn in dem yml auf Dateien zugegriffen wird, die über ein TGZ herunter geladen wurden?


    M.

    Kling einfach, wenn man weiß was man tut...
    geht es etwas genauer?
    Mit "Container Dienste" meinst Du bestimmt nicht die "ContainerStation"?!
    Container also neu anlegen mit Hilfe der Skripte...

    docker-compose up -d


    M.


    Update: auch wenn ich keinen Plan hab was ich gemacht hab, das o.g. Kommando hat die Docker APP mit beiden Containern wieder hergestellt.


    In dem einen läuft eine MariaDB10, ich denke, deren Datenbank sollte man mal in eine externe Datei verschieben...

    M.

    Hi,
    seit ein paar Tagen streikt ein Docker Container. Beim Start kommt nur die Meldung

    Code
    1. "Application not found: ..."

    System: TS453BT3-8GB, V4.5.3.1741

    Was war vorher?
    Die QNAP reagierte nicht mehr am Sensorfeld.
    Die QNAP wurde daher hart herunter gefahren.
    Nach dem Hochfahren läßt sich der Container nicht mehr starten.

    Inzwischen erledigt:
    alle Apps (auch Container Station) aktualisiert aber OS noch immer auf 4.5.3.1741
    /share/CE-CACHEDEV1/Container/container-station-data zusätzlich als TGZ im admin-home gesichert.


    Was habt ihr für Vorschläge, wie ich jetzt weiter vorgehen sollte?

    Erst die QNAP auf einen aktuellen Stand bringen?
    oder
    Erst den Container wieder fit machen? (hier benötige ich Unterstützung, weil mir nicht klar ist, warum "Application not found" kommt.

    Danke.
    M.

    Dieser spanische Beitrag geht offensichtlich den Weg über ein temporäres RAID1:
    https://www.qnapclub.es/showthread.php?tid=3139

    Mal sehen, wie gut die automatische Übersetzung ist...
    https://www-qnapclub-es.transl…s&_x_tr_tl=de&_x_tr_hl=de


    Aber meine Empfehlung ist zweite HDD mit 6TB kaufen.Die eine auf Raid1 erweitern, warten....lange warten..., dann die erste austauschen, erneut warten!!!

    Hi,

    wie du bisher gearbeitet hast und was du da vor hast ist ziemlich sch...! warum?
    Weil genau um ein solches Problem zu vermeiden RAID dient.
    Gehe ich richtig in der Annahme, dass Du kein externes Backup hast?

    Für das Folgende sollte noch mal jemand, der länger mit QNAPs arbeitet was sagen!

    Die Frage ist wie instabil die alte Platte schon ist. Ich würde die vorhandene Platte mit Hilfe der 6TB-Platte in ein RAID 1 umwandeln. sobald der sync abgeschlossen ist, die 3TB raus, (komplett ausnullen und in den MÜLL!!!! die ist auch nicht mehr als Datenengrab geeignet - lohnt einfach nicht) und gegen eine 2. 6TB-Platte tauschen. jetzt hast Du ein ordentliches RAID 1-System mit 2 Platten. Über das externe Backup solltest Du dir aber schon Gedanken machen, weil "RAID ist kein Backup!"

    Alternative:

    2. Platte als 2. DatenVolume einbinden, und die APPs auf dieses Volume migrieren
    danach alle Shares und Folder der ersten Platte ebenfalls auf dieses 2. Volume verschieben.
    Jetzt sollten (!?!) alles Apps mit Einstellungen und die DAten sicher auf der 2. HDD liegen.

    Hintergund (wenn ich alles richtig verstanden habe):
    egal wie viele Platten Du einbaust, QNAP legt die System-Informationen immer auf allen Platten in einem RAID1 an. Fällt eine Platte aus, wird das System automatisch von einer anderen Platte gestartet.

    Irgendwo habe ich sogar einen Hinweis gelesen, dass QNAP auch eine einzelne Platte immer als RAID1 konfiguriert, halt mit nur einer Platte. Nur wenn man das RAID einmal auf 2 Platten erweitert hat, gibt es keinen Weg mehr zurück (oder ich hab ihn noch nicht gefunden) zu einem1-Platten RAID1. Über die Shell kann man zwar auch das RAID manipulieren, aber die Änderungen vertragen sich nicht unbedingt mit den UI. Zudem sollte man dazu das MD-System gut verstehen.

    M.

    Hier geht es ja um nix, außer darum das System zu verstehen und ob es überhaupt möglich ist. Selbst große (echte) RAID-Systeme gehen beim Ersetzen einer HDD immer über den Degrade-Weg.

    Im Normalfall erstetzt man ja auch eine HDD erst, wenn die vorherige defekt ist. Dass eine Migration auf größere Platten genauso durchgeführt wird ist IMH nicht sinnvoll und läßt sich bestimmt sinnvoll anders lösen.

    Ja, kann sein, dass der Ansatz sich als nicjt realisierbar erweist, aber lernen kann man dabei einiges...

    M.

    Sorry, da war ich schon einen Schritt zu schnell:

    pasted-from-clipboard.png

    um die erste HDD SDA1 zu entfernen sollte man zuerst feststellen, ob welche Platten welchem device zugeordnet sind.

    das macht man am besten mit
    > hdparm -i /dev/sd?

    Und gleicht das mit den Informationen in der Oberfläche ab.

    mdadm /dev/md1 --fail /dev/sda3 --remove /dev/sda3

    setzt die gewünsche Platte jetzt als fehlerhaft. Die System RAIDs resychen sich sofort.

    mdadm --grow /dev/md1 --raid-devices=2

    macht aus dem degradeted 3-Laufwerks-Array wieder eines mit 2 Laufwerken. auch die anderen RAIDs haben keine Kenntnis mehr von der alten /dev/sda:


    im Moment bin ich noch nicht glücklich....
    Durch das "-f" wird die Platte auf failed gesetzt, läßt sich
    aber nicht sauber aus dem System entfernen.
    Auch ein failed zurückzunehmen scheint nicht trivial.

    Kurz mal zwei Zwischenbemerkungen:

    1) das ist alles nur ein Testsystem mit alten Platten

    2) Mein Wunsch ist ein Verfahren darzustellen, mit dem Platten ausgetauscht werden ohne dass man zwischendurch in einen "echten" degraded-Zustand kommt.

    nee, ein "1E" verteilt die Daten auf drei Platten wäre also ein 2/3

    Es geht darum ein Raid 1 mit drei identischen Platten zuhaben

    Ich hab die 3-Platte jetzt über die Oberfläche als Spare zu dem RAID hinzugefügt. Dadurch wird dann schonmal die typische QNAP-Struktur erzeugt.

    mit `cat /proc/mdstat kann man dann erkennen, dass die dritte Platte auf ihren "Einstatz" wartet.

    mdadm grow /dev/md1 --level=1 --raid-devices=3 wird die Partition aus dem Standby in Betrieb genommen und fängt an zu resynchen.

    Code
    1. >cat /proc/mdstat
    2. md1 : active raid1 sdc3[2] sdb3[0] sda3[1]
    3. 302616256 blocks super 1.0 [3/2] [UU_]
    4. [>....................] recovery = 0.2% (727872/302616256) finish=96.7min speed=51990K/sec


    Und am Ende:

    Code
    1. >cat /proc/mdstat
    2. md1 : active raid1 sdc3[2] sdb3[0] sda3[1]
    3. 302616256 blocks super 1.0 [3/3] [UUU]

    Moin,

    ich möchte ein RAID 1 mit 3 Platten erzeugen, aber nicht als 2/3 sondern als 1/3. D.h. auf jeder Platte ist das gleiche gespeichert.
    Wähle is "expand" entsteht ein 2/3 mit 2x der Kapazität, über "migrate" wird nur eine Umstellung auf RAID 5 ermöglicht.

    Ist das nur über mdadm machbar?

    M.


    Moin,
    nach der erfolgreichen Umstellung von einem TS453pro auf TS653D sind zwei weitere Platten im System verfügbar.
    Im vorhandenen RAID1 ist noch eine alte 1TB platte verbaut, die jetzt durch eine der leeren Platten erstetzt werden soll.
    Das ganze soll "smart" passieren, d.h. ohne dass ich "vor Ort" sein muss.

    Was passiert, wenn ich eine Platte logisch trenne? Es bleiben die Partitionen ja erhalten.
    Wie kann ich die "platt" machen und später anderweitig einbinden ohne dass die QNAP versucht, damit ein RAID zu erzeugen?
    Sollte ich die Änderungen besser über das Terminal machen mit den MD-Tools von Linux, damit die Platte aktiv (eingeschaltet) bleibt?


    Danke.
    M.

    Platten von Seagate gibt es für verschiedene Anforderungen. Die EXOS-Platten werden in als High Performance, Datengrab oder dazwischen angesiedelt. Sie haben unterschiedliche Clusterung, Geschwindigkeit, MTBF usw. und als Enterprise-Platte hat sie natürlich 5 Jahre Austausch-Garantie. Hat aber auch ihren Preis.

    Die Ironwolf ist eine sehr gute Mittelklasse Platte, hervorragend geeignet für RAID-Systeme im SMB und Home-Bereich.

    Mir persönlich fehlt die Unterstützung für SED-Platten. Self-Encrypting-Devices sind leider selten lieferbar, obwohl überall gelistet. Aber gerade in kleinen Organisationen lösen sie eine ganze Menge Probleme die durch DSGVO/GPPR aufkommen.

    Die Lautstärke einer HDD hängt von verschiedenen Parametern ab.
    Drehzahl (jault), Self Parking Heads (klackt), usw. Im Wohnzimmer will ich beides nicht.

    Zusammenfassend: ohne eine klare Ansage, welche Anforderungen erfüllt werden sollen, ist eine Empfehlung nicht sinnvoll.

    M.

    Aber genau DAS ist die Idee. Natürlich darf das "alte" NAS nicht im gleichen Netz eingebunden sein. Damit die sich syncen können bekommen sie beide ein weiteres Netzwerk natürlich mit unterschiedlichen IPs.
    Fällt das eine aus, kann man das zweite System einfach umhängen.

    Ein HA-Cluster ist dabei gar nicht angedacht. Halt nur "warm standby".

    Ein sauberes aufsetzen des zweiten Systems ist halt ne Menge Arbeit. Da laufen Container, ein DC, und noch weitere Dienste. Das alles identisch nach bauen?!

    Moin,

    in Kürze steht mir als Ablösung eines TS-453pro eine TS-653D zur Verfügung.
    Nach der Ablösung soll die alte 453 als hot standby laufen und über Nacht synchronisiert werden.
    Da das alte System ein RAID-1 ist und das neue dann RAID-5 werden soll kam mir folgende Idee:

    Im alten System ist ein RAID 1. Wenn ich in abgeschaltetem Zustand eine Platte ziehe, und eine der neuen Platten hinzufüge, müßte diese dann nach dem Einschalten als neue Platte erkannt werden und der Rebuild läuft an.

    Im neuen System baue ich die eben gezogene Platte aus dem alten System ein und eine weitere neue HDD. Jetzt müßte IMHO auch hier der Rebuild laufen.
    Nach dem Abschluss des Rebuild kann ich weitere Platten hinzufügen und auf RAID 5 oder 6 umstellen.

    Jetzt sollten zwei Systeme mit identischen Daten und Konfiguration vorhanden sein.

    Hab ich was übersehen (gleiche Build-Versionen versteht sich von selbst)?

    M.

    Hab heute einen Neustart gemacht.

    Ergebnis im APP-Center
    Es wird NUR meine "gekaufte" APP aus dem EU-store angezeigt, aber keine andere mehr,

    Der Pfad, der dabei aktiv ist: ".../api/user/repo.xml?api_tojken=..."

    ich hab den QNAP-Club jetzt zwei mal aufgenommen, jeweils mit einer derbeiden URLs (muss natürlich die IDs in der qpkg.conf wieder anpassen (s.o.)


    Update: klappt. Allerdings verschwindet die Ikone für die installierte APP (broken link).

    Kein Wunder: der Link zur Ikone verweist auf https://cdn.qnapclub.eu/storage/qpkg_artifacts/NextCloud_11.0.0_x86/qpkg_icon_80.gif?_dc=19.0.0