Aktivierung der QNAP-Fernbedienung RM-IR002 in der Linux Station

  • Habe ein echt seltsames Problem. Seither funktionierte die Fernbedienung einwandfrei. Was jetzt komisch ist, alles funktioniert bis auf die "Power" Taste. Hier war in der XML der Befehl "System.LogOff" hinterlegt und hat den Benutzer ausgeloggt. Hat jemand sowas schon gehabt? Ich bekomme es nicht mehr zum laufen...:(

  • Hallo zusammen,


    ich habe nach einem kompletten Neu aufsetzen der Linux Station + Kodi 17 endlich alles wieder am laufen. Nun gibt es ein Update der Linux Station (Linux Station 1.5.1792) mit folgendem Eintrag:
    KODI can be operated using QNAP remote controls (RM-IR002 and RM-IR004)


    was bedeutet das jetzt? Wenn ich das nun installiere, geht die Fernbedienung wohl wieder nicht, oder? Hat es zufällig schon jemand gemacht und kann berichten was dann genau geht / nicht mehr geht?


    Ich möchte nicht wieder so viele Stunden vor der Kiste hocken.....

  • Ich habe mich auch mal an der Einrichtung der Fernbedienung versucht und es hat auf Anhieb gut geklappt, daher vielen vielen Dank für die Anleitung.

    Das Problem ist offenbar eine andere Zuordnung der Geräte auf der TS-251.

    Kleine Anmerkung zu dem Zitat oben: es wäre cool, wenn bei der Einrichtung ermittelt wird, ob es sich um eine TS 251(+) handelt und dann die entsprechende Einstellung automatisch die richtige Datei genutzt wird. Ansatz dafür könnte das Vorgehen wie im pre-start sein:


    Shell-Script
    1. # audio
    2. PLATFORM=$(awk -F= '$1 == "DISPLAY_NAME" {print $2}' /etc/platform.conf)
    3. # audio - alsa
    4. rm -f ${LXC_ROOTFS_PATH}/etc/asound.conf
    5. if [ -n "$(echo $PLATFORM | grep 51)" ]; then
    6. cp -f ${BASE}/audio-conf/asound.conf.x51 ${LXC_ROOTFS_PATH}/etc/asound.conf

    nur statt der alsa config Dateien dann die lirc spezifischen Sachen.