NFS rsize wsize nur 8192 alles andere wird ignoriert

  • Hallo,
    ich habe heute mal probiert manuell das Laufwerk als hdd zu mounten und mit rzise und wzise zu spielen. Ich nutzen einen QNAP 469L. Als Box habe ich eine Gigablue UE+. Allerdings mountet die Box immer nur mit 8192. Mach ich etwas falsch?


    Dieser Befehl:

    Code
    1. mount -t nfs -o udp,rw,soft,nolock,timeo=5,rsize=32768,wsize=32768 192.168.123.252:/HDD_H2 /media/hdd


    ergibt:

    Code
    1. 192.168.123.252:/HDD_H2 on /media/hdd type nfs (rw,relatime,vers=3,rsize=8192,ws
    2. ize=8192,namlen=255,soft,nolock,proto=udp,port=2049,timeo=5,retrans=3,sec=sys,lo
    3. cal_lock=all,addr=192.168.123.252)


    Warum wird die Größe ignoriert?

    2 Mal editiert, zuletzt von GorillaBD () aus folgendem Grund: Code Block hinzugefügt! Siehe Forenregeln.

  • Danke für den Hinweis. Mich wundert nur, dass man in den Foren soviel über anderen Mountgrößen ließt. Angeblich soll es ja mit 32000 am besten laufen. Bei mit läuft es recht gut, ich habe nur bei RTL HD massive Ruckler im Timeshift. Obwohl dort die Datenrate nicht an die der ARD reicht. Wie habt ihr denn gemountet ebenfalls alle mit 8192, aber in TCP oder UDP? Konntet ihr sonst Verbesserungen mit Einstellungen hervorrufen?

  • Bei den derzeit aktuellen E2-Kisten (ab 400Mhz) spielen die Blockgrößen keine große Rolle mehr ;) . Letztlich kann man das Ganze zwischenzeitlich ziemlich schmerzfrei auch mit CIFS/SAMBA erledigen.....das frühere "Gefrickel" ist mehr oder weniger vorbei. Ob udp oder tcp bei NFS besser ist, kann nicht allgemein gültig beantwortet werden. Immer erst mit tcp probieren ;-).


    Bei Problemen liegt es in den allermeisten Fällen an
    - defekten Kabeln
    - WLAN oder DLAN im Spiel
    - wild gewordener Router/Switch (einfach mal resetten).

  • WLAN oder Powernet ist nicht im Spiel, alle Netzwerkdosen sind mit dem zentralen Netzwerkschrank über CAT7 verbunden. Als Switch setze ich einen HP Procurve 2610 ein, sollte also auch kein Problem darstellen. Der NAS schafft auch das Timeshift. (Was im Wohnzimmer aufgenommen wird, kann gleichzeitig im Schlafzimmer ohne ruckler geschaut werden). Die Gigablue hat ja einen 700MHz Prozessor, leider verbindet auch sie nur mit 8192 :| Hat denn hier im Forum jemand seine E2 Box mit mehr als 8192 gemountet?

  • Zitat von "fuchs1978"

    WLAN oder Powernet ist nicht im Spiel,

    Gut; dann kannst Du dieses Problem ausschließen.

    Zitat

    Als Switch setze ich einen HP Procurve 2610 ein, sollte also auch kein Problem darstellen.

    ...auch der kann sich mal verschlucken ;)


    Zitat

    Der NAS schafft auch das Timeshift. (Was im Wohnzimmer aufgenommen wird, kann gleichzeitig im Schlafzimmer ohne ruckler geschaut werden).

    Ich kenne kein halbwegs aktuelles NAS, das sich bei diesem Stunt nicht langweilt 8-) . Dafür kannst Du auch ne Zyxzel-Kiste nehmen....


    Zitat

    Die Gigablue hat ja einen 700MHz Prozessor, leider verbindet auch sie nur mit 8192 :|

    Den - wahrscheinlichsten - Grund dafür hatte ich doch schon gepostet.....

    Zitat

    Hat denn hier im Forum jemand seine E2 Box mit mehr als 8192 gemountet?


    Sicher; alle auf denen kein OE2 läuft kennen die Kastration auf 8k auch nicht. Ob Deine Giga firmwaretechnisch auch auf diesem OE2-Stand aufsetzt kann ich Dir nicht beantworten, da ich nur Dreams und VU+-boxen im Einsatz habe.


    Versuche einen CIFS-Mount und schaue ob´s dann besser geht - oder ändere bei Deinem NFS-Mount mal von UDP auf TCP (auch das hatte ich schon erwähnt). Die Blockgröße ist sicher nicht das Problem.


    Da Dein Ruckeln allerdings nach Deiner Aussage nur bei einem konkreten Sender auftritt, würde ich eher auf ein Problem mit der eingesetzten Software zur Benutzung der HD+-Karte tippen. Das ist allerdings ein Thema, das in diesem Forum sicher nicht diskutiert wird! Letztlich bist Du mit Deinem Problem in einem Gigablue-Forum richtig aufgehoben. Ein NAS-Problem ist nicht erkennbar.

  • Ich denke auch das es eher an der Box als dem Netzwerk liegt. Im Webif des Switches erzielt die Dreambox 800 ca. 80% der 100Mbit die Gigablue macht leider schon bei 30% schlapp :? Ich hoffe dass bald mal neue Treiber kommen. UDP, TCP, NFS oder CIFS ich habe gestern viel probiert, alles liegt im die 30%. Daher kann ich nur auf Treiber warten. Wieviel schaffen denn die VUs?

  • realer Datendurchsatz (jeweils NFS):


    DBox2: 8,1 Mbit/s (32k-udp)
    DM600 (E1): 40Mbit/s (32K-udp)
    DM500HD/DM7020HD/VU+Ultimo (alle E2): 89Mbit/s (8k-tcp) - Hinweis: das ist letztlich das, was max. durch eine 100Mbit-NIC geht
    VU+DUO2 (E2): 240Mbit/s (Hinweis: die hat eine Gbit-NIC)

  • Zitat von "Advocatus Diaboli"

    realer Datendurchsatz (jeweils NFS):
    VU+DUO2 (E2): 240Mbit/s (Hinweis: die hat eine Gbit-NIC)


    Könntest du diesen Test auch mal an einem 100MBit Port durchführen?


    Da die Gigablue nämlich wirklich sehr schlechte Netzwerkperformance hat, überleg ich auf VU umzusteigen. Ich habe allerdings nur einen 100Mbit Switch.

  • Zitat von "fuchs1978"


    Könntest du diesen Test auch mal an einem 100MBit Port durchführen?


    Wozu sollte das gut sein? 8-) Wenn Du eine "natürliche" Bremse einbaust, reduziert sich der Durchsatz automatisch auf deren Maximum. Du darfst also beim Einsatz einer 100Mbit-Komponente nicht mehr als ~rd.90Mbit/s erwarten.


    Einen Gbit-Switch bekommt man heutzutage für rd. 20 Euronen.....

  • Bei der Gigablue 800 UE plus sieht es so aus:


    Code
    1. time dd if=/dev/zero of=/hdd/tempfile bs=1M count=1024010240+0 records in10240+0 records out10737418240 bytes (10.0GB) copied, 3023.029430 seconds, 3.4MB/sreal 50m 23.10suser 0m 0.82ssys 11m 14.80s


    Code
    1. 192.168.123.252:/HDD_H2 on /media/hdd type nfs (rw,relatime,vers=3,rsize=8192,wsize=8192,namlen=255,soft,nolock,proto=tcp,port=2049,timeo=5,retrans=3,sec=sys,local_lock=all,addr=192.168.123.252)

    Einmal editiert, zuletzt von GorillaBD () aus folgendem Grund: Code Block hinzugefügt! Siehe Forenregeln.

  • unterirdisch :mrgreen:


    warum testest Du das Schreiben nach /hdd und nicht nach /media/hdd?


    Das sollte zum Kurztest reichen:

    Code
    1. time dd if=/dev/zero of=/media/hdd/tempfile512MB bs=1M count= 512
  • Deshalb ist auch eine VU Duo2 unterwegs und die demnächst bei Ebay erhältlich ;)


    --- EDIT ---


    Ich habe die Platten immer direkt als hdd gemountet

    Einmal editiert, zuletzt von GorillaBD () aus folgendem Grund: Doppelte Beiträge vermeiden, siehe Forenregeln!

  • Zitat von "fuchs1978"

    Ich habe die Platten immer direkt als hdd gemountet


    aha


    Zitat

    192.168.123.252:/HDD_H2 on /media/hdd (..)


    Man kann hier übrigens seine Postings eine gewisse Zeit editieren :tongue:

  • Zitat von "Advocatus Diaboli"

    aha


    Du hast recht, es ist doch nach media/hdd gemountet. Ich haben einen ln auf hdd gesetzt. :oops: Die Dreambox hatte das damals so, so habe ich es beibehalten.

    2 Mal editiert, zuletzt von GorillaBD () aus folgendem Grund: Volltextzitat gekürzt! Siehe Forenregeln!

  • fuchs1978
    Wir bitten Dich ausdrücklich um Beachtung unserer Forenregeln, hier zuletzt am Beispiel von Doppelpostings und ungekürzten Volltextzitaten. :!:
    Bislang mussten wir die Hälfte Deiner Einträge gemäss der Forenregeln editieren, dies ist im weiteren nicht mehr zumutbar.


    Danke und GLG
    GBD

  • Für die Arbeit die ich euch gemacht habe möchte ich mich entschuldigen. Ich hoffe ich erstelle die nächsten Beiträge nach den Regeln. :oops:


    Ich habe meine VU Duo2 erhalten. Die lastet laut HP Switch das Netzwerk zu 97% aus. Damit haben sich die Ruckler erledigt. Zu der Frage warum kein Gbit Switch. WIr haben hier mehere Gebäude die an einer GBit Backbone hänge. Daher müssen die Switche eine GBit Glasfaseranschluss haben. Ich setze HP Procurve ein, da kostet ein Gbit leider mehr als 10 EUR. Aber mit 97% bin ich erstmal zufrienden :D


    Code
    1. root@vuduo2:~# time dd if=/dev/zero of=/hdd/tempfile bs=1M count=2048
    2. 2048+0 records in
    3. 2048+0 records out
    4. real 3m 8.33s
    5. user 0m 0.02s
    6. sys 0m 12.11s