Owncloud über Fritzbox und https erreichbar

  • Hallo Liebe Forum User,


    ich möchte gerne die Owncloud über https und Fritzbox von außen erreichen.


    Owncloud Version 8

    NAS : Qnap Ts251, FW 4.3.6.0907


    Ich versuche im Moment über dynu.com das zu realisieren. Mache den Port 8081 auf und leite den auf die QNAP 8081.


    Schreibe ich dann aber https://meine.dynu.com:8081/owncloud passiert nichts.


    SSH in der QNAP ist aktiviert, ebefalls SSL in Owncloud. Lokal klappt alles wunderbar.


    Könnt Ihr mir hier unter die Arme greifen ?


    Danke

  • Die Frage wäre, ob Du als Protokoll in der FB auch HTTPS angegeben hast. Aber viel gravierender ist eigentlich, dass ich das ganze für keine gute Idee halte. Erstens ist Owncloud 8 brutal veraltet, das dürfte nicht lange dauern bis das irgendein Bot per Zufall geknackt hat. Ebenso sind die anderen Dienste Deines NAS im Netz, was hier schon oft genug zu Malwarebefall geführt hat. Die einzig ( zumindest nach derzeitigem Stand) einigermassen sichere Variante ist ein VPN Zugang, den die FB ja auch bereitstellen kann. Siehe auch:

    Zugriffsschutz für QNAP Beginner

  • Ist das eine schon lang laufende Owncloud oder neu aufgesetzt?


    Wenn neu aufgesetzt, würde ich die 10er installieren, die läuft in docker.... oder gleich mit containern ne eigene Lösung basteln...


    Dann finde ich nen Zugriff, einzig auf den Container persönlich ganz ok

  • Ne ist ne 8er und kann aber nochmal neu aufgesetzt werden.


    Das mit VPN ist schon vorhanden und funzt auch. Ich wollte nur ne kleine Plattform für PDF´s haben.


    Die 10er ist dafür besser. Ich meine mich zu erinnern das die Installation net soooo einfach ist ? Irre ich mich ?


    Wenn ja dann knall ich die 10er drauf.


    Auf der NAS Maschine is auch nix anderes drauf an daten und Apps. Soll nur als "kleines" PDF´s Tool wirken.

  • Naja, wenns dir reicht, isses ein Klick im Appstore..

  • Hmmm, muss die 10er net manuell installiert werden ?


    Die 8er habe ich aus dem Appstore.

    Uh, habs grad gesehen...is ja ne 10er drin..


    Dann ist das neu, war sonst immer der 8er..


    Wie wäre denn die Portweiterlietung für https der FritzBox

  • Okay die 10er wird zwar angeboten im AppCenter aber ich bekomme die nicht ans laufen.


    Datenbank eingestellt, Webverzeichniss eingestellt mit vollen Schreibrechten und hänge.

    Kein Admin kann angelegt werden und auch das Verzeichnis kann nicht erstellt bzw in dieses geschrieben werden.

    Wenn ich mir den Ordner anschaue in dem die APP liegt ist da aber auch nicht viel "drin" .


    Kann mir da jemand ein wenig unter die Tastatur greifen ?

  • Das ist doch ein Docker Image... Moment sobald ich am PC bin, schreib ich was zusammen

  • Ich dank dir schonmal im voraus, super

  • Erstmal ein fettes Danke für Deine Mühen,

    Alle Werte so angepasst wie es bei mir passen sollte und folgende Meldung kommt :

    Code
    1. ERROR: yaml.parser.ParserError: while parsing a block mapping
    2. in "/share/Container/owncloud/docker-compose.yml", line 1, column 1
    3. expected <block end>, but found '<block mapping start>'
    4. in "/share/Container/owncloud/docker-compose.yml", line 10, column 3
  • poste doch bitte mal deine docker-compose.yml

  • Und ist die Datei in Ordnung ?

  • schaut eigentlich gut aus.... hm...

  • ah, jetzt seh ichs..


    Rück mal db 2 Leerzeichen ein...

  • Es gibt immer ein paar Deppen wo es net klappt :-(


    Jetzt lief es halb durch und num kam folgendes :

  • änder mal den Port, der sagt dir, dass irgendwas anderes 4490 benutzt