Webserver - WebDAV funktioniert nicht mehr

  • Hi zusammen,


    WebDAV mit dem integrierten Apache funktioniert bei mir nicht mehr.
    Wenn ich zugreifen will bekomme ich den Fehler "405 - method not allowed"


    Benutzerrechte stimmen. Es liegt an der Konfiguration. Folgendes habe ich bereits versucht:


    • NAS neu gestartet
    • Web Server neu gestartet
    • Berechtigungen von "shared folder permission" auf "WebDAV permission"
    • Apache config auf default gesetzt
    • wenn ich den Secure Port auf 8082 setzte, startet der Webserver gar nicht mehr.
    • Bei allen anderen Ports (8083 zb) selbes Fehlerbild.
    • per http 80 besteht das selbe problem.


    Ich habe auch schon die default configs in das apache Verzeichnis kopiert.
    Wenn ich mir die config Dateien so anschaue stehen da andere ports drin, als die, die ich im Webinterface konfiguriere.
    Das Webserver log einzuschalten (per apache myconfig) hilft auch nicht viel es steht nichts sinnvolles drin.


    Gibt es eine Möglichkeit, den Webserver noch wirklich auf Anfang zu setzten, damit die config dateien wieder passen?
    Der Reset per Webinterface ist nicht ausreichend....


    Der Webserver selber funktioniert sonst normal (auch virtual Hosts) nur WebDAV nicht mehr.


    QTS 4.2.2 20161214

  • der QNAP Apache macht mich fertig :D
    Hab auch schon das komplette Verzeichnis /etc/apache gelöscht und dann die FW neu aufgespielt. Aber irgendwo hängt noch eine falsche Port Konfig drin...


    kann mir jemand den Gefallen tun und den Inhalt folgender 2 files posten:


    Code
    1. /etc/apache-dav-sys.conf/etc/config/apache/extra/apache-dav-ssl.conf

    wichtig sind mir dabei die konfigurierten Ports.
    Dazu noch welcher Port in der Webserver konfig für SSL eingreichtet ist


    Und wenn möglich eine Ausgabe von:


    Code
    1. lsof -PnL +M -i4 | grep :80


    Es scheint irgendwas mit meiner Konfig nicht zu stimmen, was aber auf einem funktionierenden System korrekt ist wüsste ich gern.


    danke!

  • Hi,


    habe genau das Gleiche Problem. Seit einigen Tage funktioniert WebDav nicht mehr und egal was ich im Webserver ändere ich komme nicht mehr drauf.
    TS-221
    Firmeware 4.2.2 Build 20161214


    Hast Du inzwischen schon eine Lösung finde können ? Ich habe den Support bereits versucht zu kontaktieren. Ohne Erfolg. Noch keine Antwort auf mein Ticket.

  • Lösung hab ich noch keine. Ich hab eine Vermutung, die kann ich aber nur prüfen, wenn mir jemand, bei dem WebDAV geht die oben genannten Dateien anhängt.


    Seid wann tritt das Problem bei dir auf? Ich kann es leider nicht sagen, seid wann das bei mir ist.
    post mal die Ausgabe von folgendem Befehl:


    Code
    1. lsof -PnL +M -i4 | grep :80
  • das sieht etwas anders aus als bei mir. Bei dir scheint der WebDAV gar nicht zu laufen.
    bei mir läuft WebDAV, daber auf falschen Ports.


    Auf welchem Port hast du WebDAV konfiguriert? 8081?
    Was kommt denn wenn du den WebS Server über putty neu startest:


    Code
    1. /etc/init.d/Qthttpd.sh restart
  • Hi


    bei mir sollte der Webserver auf Port 3500 laufen (http, https hab ich nicht an). Ich nun nun mal die Apache Konfig aus dem default_config Ordner nach /etc/
    kopiert (/etc/default_config/apache.conf in /etc/config/apache) und zusätzlich nach (/etc/default_config/apache.conf in /etc/config/) kopiert.


    Nun scheint es bei mir hier wieder zu laufen...

  • Hallo @ben_beton anbei meine Config Files:
    Webdav läuft bei mir auf 5000 (erst vor paar Tagen eingeschalten) macht ein Portwechsel Sinn?

    /etc/apache-dav-sys.conf


    Code
    1. cat apache-dav-sys.conf#ServerType standaloneServerRoot "/usr/local/apache"Mutex file:/var/lock/ defaultPidFile /var/lock/apache-dav.pid#ScoreBoardFile /usr/local/apache/logs/apache.scoreboardTimeout 300KeepAlive OnMaxKeepAliveRequests 100KeepAliveTimeout 15ThreadLimit 1ServerLimit 128StartServers 1MaxClients 128MinSpareThreads 1MaxSpareThreads 5ThreadsPerChild 1MaxRequestsPerChild 1000EnableSendfile OffListen 5000User adminGroup administratorsServerAdmin admin@NAS#ServerName NASTraceEnable offServerTokens Prod<Directory /> Options FollowSymLinks AllowOverride None Require all denied</Directory>UseCanonicalName OffHostnameLookups OffDefaultType noneInclude /etc/default_config/apache-default-modules.confErrorLog /dev/null## LogLevel: Control the number of messages logged to the error_log.# Possible values include: debug, info, notice, warn, error, crit,# alert, emerg.#LogLevel crit<IfModule log_config_module> LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined LogFormat "%h %l %u %t \"%r\" %>s %b" common LogFormat "%{Referer}i -> %U" referer LogFormat "%{User-agent}i" agent <IfModule logio_module> LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio </IfModule> # # If you prefer a logfile with access, agent, and referer information # (Combined Logfile Format) you can use the following directive. #</IfModule>ServerSignature On<IfModule ssl_module> SSLRandomSeed startup builtin SSLRandomSeed connect builtin</IfModule><IfModule mod_deflate.c> DeflateCompressionLevel 2 AddOutputFilterByType DEFLATE text/html text/plain text/xml AddOutputFilter DEFLATE js css BrowserMatch ^Mozilla/4 gzip-only-text/html BrowserMatch ^Mozilla/4\.[0678] no-gzip BrowserMatch \bMSIE\s7 !no-gzip !gzip-only-text/html</IfModule><IfModule reqtimeout_module> RequestReadTimeout header=20-40,MinRate=500 body=20,MinRate=500</IfModule>Include /etc/config/apache/extra/apache-dav-sys-ssl.confInclude /etc/config/apache/extra/apache-dav.conf[/etc] #



    lsof -PnL +M -i4 | grep :80

    Code
    1. # lsof -PnL +M -i4 | grep :80apache_pr 7162 admin 3u IPv4 42479 0t0 TCP *:8080 (LISTEN)uwsgi 8737 admin 7u IPv4 3983761 0t0 TCP *:8088 (LISTEN)uwsgi 8737 admin 8u IPv4 3983762 0t0 TCP *:8089 (LISTEN)uwsgi 9211 admin 7u IPv4 3983761 0t0 TCP *:8088 (LISTEN)uwsgi 9211 admin 8u IPv4 3983762 0t0 TCP *:8089 (LISTEN)apache 14125 httpdusr 3u IPv4 23451281 0t0 TCP *:80 (LISTEN)apache 14125 httpdusr 4u IPv4 23451290 0t0 TCP *:8081 (LISTEN)apache 14128 httpdusr 3u IPv4 23451281 0t0 TCP *:80 (LISTEN)apache 14128 httpdusr 4u IPv4 23451290 0t0 TCP *:8081 (LISTEN)apache 14129 httpdusr 3u IPv4 23451281 0t0 TCP *:80 (LISTEN)apache 14129 httpdusr 4u IPv4 23451290 0t0 TCP *:8081 (LISTEN)apache 14130 httpdusr 3u IPv4 23451281 0t0 TCP *:80 (LISTEN)apache 14130 httpdusr 4u IPv4 23451290 0t0 TCP *:8081 (LISTEN)apache_pr 17108 admin 3u IPv4 42479 0t0 TCP *:8080 (LISTEN)bcclient 21001 admin 3u IPv4 10330939 0t0 UDP 255.255.255.255:8097bcclient 21001 admin 4u IPv4 10330940 0t0 UDP 255.255.255.255:8097bcclient 21001 admin 5u IPv4 10330941 0t0 UDP 255.255.255.255:8097bcclient 21001 admin 6u IPv4 53682 0t0 UDP 255.255.255.255:8097apache_pr 27102 admin 3u IPv4 42479 0t0 TCP *:8080 (LISTEN)apache 31160 admin 3u IPv4 23451281 0t0 TCP *:80 (LISTEN)apache 31160 admin 4u IPv4 23451290 0t0 TCP *:8081 (LISTEN)

    /etc/config/apache/extra/apache-dav-ssl.conf

    Die Datei gibt es bei mir nicht Meine Dateiliste aus diesem Ordner:


  • danke @Psycho85 !


    habe jetzt herausgefunden warum in den apache config Dateien immer die falschen Ports stehen (andere wie im Webinterface)
    Die Ports werden aus der /etc/config/uLinux.conf ausgelesen und da standen die falschen Ports drin


    Lösung war nun folgendes:


    1. Webserver beenden /etc/init.d/Qthttpd.sh stop oder im Webinterface
    2. unter folgendem Abschnitt alles entfernen bis auf das:


    [QWEB]
    Enable = 0
    Port = 80

    3. dann im Webinterface Webserver wieder starten (nur HTTP 80
    4. Dann SSL aktivieren
    5. WebDAV aktiveren.


    jetzt stimmt auch die /etc/config/uLinux.conf wieder und die apache konfig Dateien natürlich auch.


    gruß

    5 Mal editiert, zuletzt von ben_beton ()

  • Hallo @ben_beton
    Ich habe die aktuelle QTS BETA also 4.3.2.xxx


    Webserver läuft bei mir wie folgt:
    Port 80
    https: Port 8081


    Webdav: 5000 httpsPort 5001

  • Hallo,


    ich habe den Thread mir jetzt komplett schon 5 mal durchgelesen und auch alle Punkte von euch überprüft aber es funktioniert bei mir leider immer noch nicht :(


    Modell: TS-220
    FW: 4.2.3


    Gerät frisch installiert letzte Woche.
    Webserver alleine auf 80 & 8081 läuft ohne Probleme. Aber wenn ich WebDav anschalte crasht es mit der Fehlermeldung " Fehler 2017/02/07 09:00:32 admin 192.168.1.100 --- [Web Server] Failed to start."
    Wenn ich Qthttp.d über ssh restarte erhalte ich die Fehlermeldung php-fpm fehlt aber startet trotzdem normal ohne weitere Meldung.


    Bin um jede Dankbar dass es wieder funktioniert. Hatte die letzten 3 Jahre es ohne Probleme nutzen können und nun das :(

  • seit wann besteht der Fehler, FW Update gemacht? Die Fehlermeldung die du per CLI bekommst sieht eher nach einem anderen Fehler aus.


    ggf. wäre eine extra thread sinnvoller.

  • Seit der Neuinstallation vom Gerät.


    Die FW Version war schon davor drauf. Soll ich einen Log oder irgendwas posten, das evtl hilft?


    Ich habe kA woran es liegt und Logs zum Starten vom Webserver finde ich auch nicht, wo es detaillierter beschrieben ist, was das Problem ist oder warum es sich nach dem Einschalten von Webdav, der Webserver sich komplett deaktiviert.


    Es ist zum Verzweifeln :(