Beiträge von FreddyFFM

    FreddyFFM hat eine neuen Artikel hinzugefügt:


    [entry]393[/entry]


    Hallo zusammen,


    ich habe trotz Unity-Media-Anschluss (nur DS-Lite) den externen Zugriff auf mein QNAP via nginx-reverse-Proxy auf einem VServer von netcup gelöst. Die Öberfläche kann ich problemlos öffnen auch der Dateisync scheint zu funktionieren. Bei der Virtualization Station sehe ich aber nur ein "Wird geladen..." und mein Reverse-proxy gibt ein

    Code
    1. "GET /qvs/ws/actions HTTP/1.1" 500"

    zurück. Bei einem Zugriff aus dem lokalen Netzwerk funktioniert es Problemlos. Jetzt würde ich gerne auf Ursachenforschung gehen, finde aber keine Log-Files zur Virtualization Station.
    Über eine Liste zu allen Log-Files würde ich mich freuen.


    Danke
    Freddy

    Danke für diesen Hinweis. So ähnlich habe ich es jetzt gemacht.


    Ich habe einen VHOST mit HTTPS eingerichtet, über die httpd-ssl-vhosts-user.conf die Proxy-Module geladen und den Proxy aktiviert (die Datei wird durch QNAP nach Neustart nicht überschrieben). Die FritzBox tunnelt den Port 443 auf den VirtualHost.



    Ein Zugriff auf die Admin-Oberfläche, die sonst auch über /cgi-bin aufrufbar ist, scheint damit nicht möglich. Wer aber die CGI-Dateien kennt, kann sie sich anzeigen lassen. Dieses versuche ich aktuell zu unterbinden.
    Verbesserungsvorschläge gerne willkommen ;-)

    Hallo zusammen,


    folgendes Szenario: die QNAP steht in einem internen Netzwerk hinter einer FritzBox. Aktiv sind QSync und Surveillance. Um u.a. die App VMobile mit der Surveillance-Station verbinden zu können, benötige ich Zugang zu https://meindyndns:sslport/surveillance. Der Port ist in der FritzBox entsprechend weitergeleitet und der Zugriff funktioniert. Damit geht aber leider auch einher, dass jeder Zugriff auf das Admin-Interface oder die anderen "Stations" bekommt. Dieses möchte ich gerne unterbinden. Dazu habe ich bereits diverse Foren durchforstet und auch folgenden Ansatz (http://forum.qnap.com/viewtopic.php?t=94551) gefunden, der bei mit aber nicht funktioniert. Da ich kein Experte für die Apache-Konfig bin, weiß ich auch nicht, was ich anderes einstellen kann. Gibt es jemand, der mit die richtige Konfig nennen kann, so dass für alles unter https://meindyndns:sslport/ nur der Zugriff auf dem internen Netz (192.168.178.0) funktioniert, außer bei https://meindyndns:sslport/surveillance?


    Vielen Dank und Grüße
    Freddy