[QPKG] Config Overview

  • [NAS Typ:] bedingt alle
    [Firmware:] (ab 3.1.0)
    [Getestet:] ja, mit TS-109, TS-239, TS-439
    [Sonstige Modifikationen:] keine
    [Autor:] Eraser-EMC2- / Stefan


    Unterstützte Geräte:
    TS-109, TS-209, TS-409, TS-409U
    TS-110, TS-119, TS-210, TS-219, TS-219P, TS-410, TS-419P, TS-419U
    TS-239, TS-239PROII, TS-259, TS-439, TS-439PROII, TS-459, TS-509, TS-559, TS-639, TS-639PROII, TS-659, TS-809, TS-809U, TS-859, SS-439, SS-839


    Für manche NAS-Besitzer ist es nicht so einfach, bei Problemen einen Inhalt mancher Konfigurationsdateien mit im Beitrag zu posten,
    da evtl. nicht das entsprechende Wissen vorhanden ist.


    Dazu habe ich dieses QPKG erstellt.
    Es stellt eine Webseite über den Port des WebGUIs mit einigen Inhalten von Konfigurationsdateien zur Verfügung.




    Einen Link zu dieser Übersichtsseite findet ihr im QPKG-Infofenster des QPKGs :







    Vorsicht:
    Auf diese Seite kommt man ohne Eingabe eines Passwortes.
    Man kann es wie jeden QPKG-Dienst deaktivieren, dabei wird die Seite offline gestellt.

  • Läuft auf meiner TS-239 mit 3.3.0 nicht.


    Unter /etc/rcS.d wird zwar der Link zur Startdatei angelegt, allerdings existiert das Ziel des Links /etc/init.d/config.sh nicht. Weiterhin finde ich keine Dateien unterhalb des Admin-HTTP-Servers bzw. unterhalb des Apache-Webservers (cgi-bin/config existiert nicht)


    Jan

  • Welcher Pfad wird in dem Info-Fenster angezeigt , evtl. none/.qpkg/Show_Config ?
    ich hatte 2 fehlende Pfadangaben, die bei mir beim Test nicht auffällig waren.
    ich habe das QPKG aktualisiert.
    Bitte erneut herunterladen und drüberinstallieren.


    Stefan

  • hi,
    ich habe es runtergelden, entpackt, und auf einer ts119 über qpkg installiert.
    ein klick auf das packet öffnet einfenster, dort ist ein link "web frontend". wenn ich darauf klicke erhalte ich die fehlermeldung : siehe anhang


    gruß franz2

  • Hallo Franz,


    mittlerweile hatte ich das QPKG wegen einem Fehler aktualisiert,
    hast du noch die Version 1.1 heruntergeldaen gehabt ?
    Wenn ja, dann lade die V1.2 herunter.


    Danke.

  • Hallo Frank,


    außer in den Deinstallationsroutinen hatte ich keinen Fehler gefunden.
    Daher hätte ich zur Zeit nur den Vorschlag das QPKG kurz deaktivieren und darauf wieder aktivieren.
    Damit werden die Symlinks zu den Ordner der WebGUI neu erstellt,
    der erst den Zugriff auf die QPKG-Oberfläche erlaubt.


    Stefan

  • Hi Stefan,
    die TS-410 kannst Du auch als getestet angeben :!:


    Ich hab das Prgm. bei mir drauf und es läuft perfekt. :thumb:


    Wenn es noch passwortgeschützt laufen würde, währe es ideal.
    Vielen Dank....Peter

  • Ich wollte Show_Config auch mal installieren.
    Tja - Installation fehlgeschlagen -
    Show_Config V1.2.1 installation failed. Model mismatch.
    Sollte das auf meinem Pro II nicht laufen können sollen tun dürfen täten ?


    Gruss
    Michael

  • Hallo,


    ich habe den NAS-Typ mit in die Liste aufgenommen, ich hoffe, das die interen Bezeichnung des NAS auch "TS-239ProII" ist.


    Ich kann es leider nicht kontrollieren.


    Stefan

  • Zitat von "Eraser-EMC2-"


    ich habe den NAS-Typ mit in die Liste aufgenommen, ich hoffe, das die interen Bezeichnung des NAS auch "TS-239ProII" ist.
    Ich kann es leider nicht kontrollieren.
    Stefan


    Das geht ja schneller als Kinder machen -
    Funktioniert - danke :thumb:
    Gruss
    Michael

  • Hallo,


    habe mir grad dieses Tool installiert. Dabei ist mir aufgefallen, dass der Symlink für die config.sh nicht in /etc/init.d angelegt wird. Nach einer Suche nach config.sh wurde ich in /sbin fündig.


    In der qinstall.sh steht dann auch

    Code
    1. #create user and group for running the QPKG application (Optional)create_req_symlinks(){ #create symbolic links for CGI files in httpd (8080) ${CMD_LN} -sf "${QPKG_DIR}/${QPKG_SERVICE_PROGRAM}" "${SYS_SBIN_DIR}/${QPKG_SERVICE_PROGRAM}"


    Nun meine Frage, muss das so sein??


    In der config.sh steht unter reinit

    Code
    1. "reinit") ${CMD_LN} -sf "${QPKG_DIR}/${QPKG_SERVICE_PROGRAM}" "${SYS_INIT_DIR}/${QPKG_SERVICE_PROGRAM}" ${CMD_LN} -sf "${SYS_INIT_DIR}/${QPKG_SERVICE_PROGRAM}" "${SYS_rcS_DIR}/QS${QPKG_RC_NUM}${QPKG_NAME}" ${CMD_LN} -sf "${SYS_INIT_DIR}/${QPKG_SERVICE_PROGRAM}" "${SYS_rcK_DIR}/QK${QPKG_RC_NUM}${QPKG_NAME}"

    was dann nach Ausführung von

    Code
    1. ./config.sh reinit

    auch den Symlink in /etc/init.d anlegt


    Ansonsten ist es eine super Sache. Man hat schnell einen kleinen Überbick über sein System. :thumb:

  • Dankeschön!

    Zitat von "Eraser-EMC2-"

    Danke für den Hinweis. :thumb:


    Büddeee. :D


    Edit: Du kannst eine original Q800 und eine zum TS-459 Pro II umgeflashte Q800 auch als getestet betrachten :mrgreen: