TVS871-i3, RAID5, 10 GBit - Weniger Transferrate als erwartet - irgendwelche Tips

  • Hallo zusammen ich habe hier folgendes System:


    - TVS871 mit aktuellster FW, Prozessor i3

    - 10 GBit LAN an einem Netgear Switch

    - 4 x WD Red Plus 6TB im RAID 5

    - Volume mit Verschlüsselung, 8k/Inode


    Gegenstelle:
    - Windows 2019 Server AMD EPYC mit 10 GBit LAN

    - MTU auf allen Karten 1500


    Ich kopiere große Daten - jeweils >10Gig via SMB vom Server auf die NAS.

    Die Daten kommen von einem Hardware-RAID im Server das - wenn ich Daten zwischen 2 RAIDS des Servers kopiere auf knapp 500MByte/s kommt.


    Transferrate sind knapp knapp 200MB/s schreibend auf die NASIch hätte da ehrlich gesagt etwas mehr erwartet.


    Latenz des Volumes liegt im 400ms Bereich.

    CPU liegt bei ca. 20%

    IOWait teiweise 20% und mehr.


    Sind das normale Werte oder müsste da mehr gehen?

    S.

  • firefox_i

    Hat den Titel des Themas von „Weniger Transferrate als erwartet - irgendwelche Tips“ zu „TVS871-i3, RAID5, 10 GBit - Weniger Transferrate als erwartet - irgendwelche Tips“ geändert.
  • Welche maximale Geschwindigkeit erreicht denn das TVS871 bei einem Schreibvorgang vom PC zum NAS?

  • SIehe oben: ca. 200MB/s

  • Also ist die Schreibrate des TVS871 der limitierende Faktor. Dann tipp ich mal stark auf die Verschlüsselung als Flaschenhals.

  • Moment, wie kommst du drauf., die 200MB ist das, was ich übers Netz aktuell an Schreibrate sehe.
    Du fragtest ja nach der Schreibrate PC aufs NAS, und das hab ich als "übers Netz" verstanden

    Oder hab ich Dich missverstanden?
    Meinst Du die reine Schreibrate der NAS auf das RAID?

    Also die Benchmarks die ich innerhalb der NAS testen kann oder was meinst Du ?


    Wie soll ich die maximale Schreibrate PC--> NAS ermitteln?


    S.

    Einmal editiert, zuletzt von firefox_i ()

  • ... und ggf. auch mal ohne Switch dazwischen, also mit direkter Verbindung...

  • Hmm okay. das sind diese 200MByte die ich als "Transferrate" bezeichne.
    Das ist das was mir tatsächlich beim Kopieren angezeigt wird.

    Dass ich mit drehenden Platten natürlich nicht die theoretischen grob 1000MByte(s erreiche ist mir klar.
    Aber "nur" 200MByte/s ist da ja deutlich weit weg und bei großen Dateien (wie gesagt >10GByte) auf ein noch leeres Volume kann ich auch von linearen Schreibvorgängenausgehen oder?

    Bei einem RAID mit 4 Platten entsprechen 200MB/S ja im Endeffekt etwa 70MB/s je Platte und das ist weit weg von dem, was die WD RED Plus eigentlich können sollten.

    Nachtrag:
    Es ist der einzig laufende Transfer auf die NAS.


    S.


    Mod: Unnötiges Volltext-/Direktzitat entfernt! :handbuch::arrow: Forenregeln beachten und Die Zitat Funktion des Forums richtig nutzen


    tiermutter Ohne Switch muss ich erst vor Ort gehen (ist net ganz so einfach, weil die extern steht udn auch der Server dort steht).
    Der Switch hat eine Kappa von - theoretischen - 56GBit/s
    Kann ich aber gern testen.

    S.

    Einmal editiert, zuletzt von firefox_i () aus folgendem Grund: Ein Beitrag von firefox_i mit diesem Beitrag zusammengefügt.

  • Kann ich aber gern testen.

    Naja Ausschlussverfahren halt... alles mal weglassen was geht und auch mal von anderen Rechnern/ Geräten testen, falls möglich, da könnte das Problem ja auch liegen.

  • Wie schon gesagt - die Verschlüsselung. Kannst du die mal testweise deaktivieren?

  • Ich hab nur einen Rechner mit 10GBit Port....deshalb wird das schwierig mit anderen Rechnern zu testen ;)

    Ich bleib dran


    Mod: Unnötiges Volltext-/Direktzitat entfernt! :handbuch::arrow: Forenregeln beachten und Die Zitat Funktion des Forums richtig nutzen


    q.tip Hab eben ne unverschlüsselte Volume angelegt,

    Ähnliches Bild....immer so um die 200-210MByte/s rum.

    Mal ne blöde Frage:
    die TVS871 bindet die aber schon mit SATA III an oder ?

    Ich mein 200MByte schreiben ist net schlecht aber mehr wäre auch ganz nett.
    Erwartet hätte ich da so 400 rum....vielleicht kann ja mal jemand anderes, mit 10GBe und nem RAID5 mit 4 Platten sagen was da so geht.

    Einmal editiert, zuletzt von firefox_i () aus folgendem Grund: Ein Beitrag von firefox_i mit diesem Beitrag zusammengefügt.

  • Die Datenquelle des PC ist hoffentlich eine SSD mit einer Leseleistung von mindestens 500 MB/s? :/

  • Mod: Unnötiges Volltext-/Direktzitat entfernt! :handbuch::arrow: Forenregeln beachten und Die Zitat Funktion des Forums richtig nutzen


    Ist ein RAID auf einem Broadcom 9361-8i.

    Ich hab jetzt mal einige GB Testdaten auf eine NVME PCIe4 SSD 980 Pro geschoben.

    Scheint jetzt beim Schreiben an die 300MB/s ran zu kommen.

    Scheinbar war da tatsächlich die Quelle zu langsam ?!?!

    Mal schauen. ichstell später mal auf MTU9000 um, aber das sollte eigentlich nichts ändern hoffe ich.

    Das einizige was ich mir vorstellen könnte:
    Auf dem Server der die Daten auf die NAS schiebt laufen noch 4 weitere VMs.
    Wenn die jetzt permament auch Traffic machen, dann geht die Netzperformance runter, weil ja alle Pakete durch die eine LAN Leitung durch müssen.

    Würde es zumindest erklären.


    Wie gesagt: ich wäre mit 300MB/s durchaus zufrieden.
    Will nur ausschließen, dass irgenwo ein Bottleneck ist, das sich korrigieren ließe.

    Ich mach heut abend mal einen synthetischen Test bei dem ich alle VMs ausmache und nur vom Host aus Daten an die NAS schicke udn auch mal MTU auf 9k stelle.

    S.

  • Einfach mal von einem Windows-PC eine große Datei zum NAS schicken und die Geschwindigkeit ablesen.

    Die Messmethode hat schon mal den Fehler, dass sich zu der Zeit, die das Schreiben auf dem NAS benötigt, die Zeit zum Lesen auf dem PC addiert. Damit ist der Wert prinzipiell geringer als die tatsächliche Schreibgeschwindigkeit.


    Besser sind spezielle Geschwindigkeitstestprogramme (Blackmagic Speedtest wird oft empfohlen), die Die NAS-Geschwindigkeiten messen, ohne währenddessen auf den PC zuzugreifen.


    Zur Ermittlung der reinen Netzgeschwindigkeit ohne Plattenzugriffe ist iperf3 (gibt es für Qnap als Package auf qnapclub.eu) das Mittel der Wahl.


    Hier kommt Raid 5 zum Einsatz.

    Meine Erfahrung damit ist:

    Beim Schreiben ist ein Raid 5 relativ langsam, da die Datenblöcke auf alle Platten verteilt und Prüfsummen gebildet werden müssen. Ich komme da auf kurzfristig 400MByte/s, was dann auf 250MByte/s zurückfällt (da ist dann wohl ein Cache voll).

    Beim Lesen ist ein Raid 5 hingegen flott. Da erreiche ich auch mit herkömmlichen Festplatten bis zu 800MByte/s.

  • Schau mal was das RAID so hergibt


    qcli_storage -t force=1


    und/oder ob eine der Platten irgendwie zu lahm ist


    qcli_storage -T force=1


    Hier mal ein Ergebniss von nem TBS-453DX


  • So bitte


    Sieht doch ganz okay aus für WD Red Plus.

    Wenn ich die 400MB/s erreichen würde wäre ich echt zufrieden ;)

    Was ich überraschend finde:

    Das langsamste Volume ist das unverschlüsselte ?!?!?

    Alles Thick Volumes

    Irgendjemand nen heißen Tip ?

    S.

  • Mod: Unnötiges Volltext-/Direktzitat entfernt! :handbuch::arrow: Forenregeln beachten und Die Zitat Funktion des Forums richtig nutzen


    Nein die SSDs sind ein normales Volume auf dem VM Daten liegen


    Mich wunder mich etwas über die stakr unterschiedlichen Durchsätze der Volumes, obwohl alle auf dem selben Pool liegen und alle verschlüsselt sind....

  • OK .. die hohe Pool ID irritierte mich.


    Benchmark auf den SSD Pool/Volumen ist auch nur so mager ?

  • Mod: Unnötiges Direktzitat entfernt! :handbuch::arrow: Forenregeln beachten und Die Zitat Funktion des Forums richtig nutzen


    Du meinst Transferrate lt. Windows Explorer beim Schreiben auf das SSD VOlume?


    Da komm ich auf leichts chwankende Werte zwischen 420 und 550MB/s


    Prozessorlastauf der NAS: 40-45%


    Sorry dass ich immer zitiere, auf was sich meine Antwort bezieht.
    Ist hier offenbar nicht gern gesehen.

    Sorry nochmal. in anderen Foren wird diese Art des zitierens gefordert, dass man immer sofort sieht,auf was sich meine Antwort bezieht, auch wenn es sich auf einen Kommenta direkt davor bezieht.

    Einmal editiert, zuletzt von firefox_i () aus folgendem Grund: Ein Beitrag von firefox_i mit diesem Beitrag zusammengefügt.