Docker Container läßt sich nicht starten

  • Hi,
    seit ein paar Tagen streikt ein Docker Container. Beim Start kommt nur die Meldung

    Code
    1. "Application not found: ..."

    System: TS453BT3-8GB, V4.5.3.1741

    Was war vorher?
    Die QNAP reagierte nicht mehr am Sensorfeld.
    Die QNAP wurde daher hart herunter gefahren.
    Nach dem Hochfahren läßt sich der Container nicht mehr starten.

    Inzwischen erledigt:
    alle Apps (auch Container Station) aktualisiert aber OS noch immer auf 4.5.3.1741
    /share/CE-CACHEDEV1/Container/container-station-data zusätzlich als TGZ im admin-home gesichert.


    Was habt ihr für Vorschläge, wie ich jetzt weiter vorgehen sollte?

    Erst die QNAP auf einen aktuellen Stand bringen?
    oder
    Erst den Container wieder fit machen? (hier benötige ich Unterstützung, weil mir nicht klar ist, warum "Application not found" kommt.

    Danke.
    M.

  • Ich hatte mal sowas. Weiß aber nicht mer die Details.
    Aber Container Dienste "drüber" bzw neu installieren damit diese wieder aktiv sind und gefunden werden.


    Danach solltest du ja die Container bzw Images wieder importieren können

  • Kling einfach, wenn man weiß was man tut...
    geht es etwas genauer?
    Mit "Container Dienste" meinst Du bestimmt nicht die "ContainerStation"?!
    Container also neu anlegen mit Hilfe der Skripte...

    docker-compose up -d


    M.


    Update: auch wenn ich keinen Plan hab was ich gemacht hab, das o.g. Kommando hat die Docker APP mit beiden Containern wieder hergestellt.


    In dem einen läuft eine MariaDB10, ich denke, deren Datenbank sollte man mal in eine externe Datei verschieben...

    M.

    2 Mal editiert, zuletzt von MatthiasJ () aus folgendem Grund: Update