QNAP 453D - Schwankende Schreibgeschwindigkeit

  • Hallo zusammen,


    da ich öfters größere Videodateien (30-50GB) von meinem lokalen PC auf mein NAS kopiere, habe ich mein Netzwerk auf 2,5Gbit aufgerüstet. Leider habe ich extreme Geschwindigkeitsschwankungen beim Kopieren von Dateien. Im Durchschnitt habe ich nur eine Geschwindigkeit von 140MB/s die für 2,5Gbit natürlich etwas enttäuschend sind.


    Meine Hardware:

    -NAS: QNAP 453D (QTS 5.0.0.1853)-

    4x12TB WD White (QNAP Leistungstest: ~195MB/s je Festplatte)

    RAID 5 - Thick-Volume

    Juboframe: 4K


    - Switch: QNAP QSW-1100 -


    - PC: Realtek RTL8125B 2.5GB-

    Firmware: 10.053 (November/21)

    Juboframe: 4K

    SSD: Samsung 970 evo (NVME)


    Das Lesen der Dateien auf dem NAS funktioniert mit voller Geschwindigkeit (274MB/s). Ich gehe daher davon aus, dass die LAN-Kabel keinen defekt haben sollten.

    Erst wenn ich Dateien von meinem PC auf das NAS kopiere bricht die Datenrate extrem ein.


    benchmark1.JPG1.jpg2.jpg


    Da jede Platte selbst schon eine Schreibgeschwindigkeit von ca. 190MB/s hat, sollte im RAID5 der 2,5Gbit Anschluss eigentlich ausgenutzt werden können. Was könnte also für die Drosselung verantwortlich sein und mit welchen Maßnahmen lässt dich das beheben? :/

    Einmal editiert, zuletzt von sebastian1 ()

  • Bist du dir sicher das dies nicht an den WD Whites (sind das die die aus einem WD MyBooks ausgebaut werden?) liegt ? Das sind auf jeden Fall keine NAS Platten und in den Kompatibilitätslisten findet man diese auch nicht.

    Kann auch viele andere Gründe haben war nur mein erster Gedanke.

  • Ich hatte mit Realtek 2.5 GbE und Jumboframes auch schon merkwürdige Ergebnisse. Vielleicht mal ohne probieren.

  • Danke für die Hinweise. Die Ursache liegt aber wahrscheinlich woanders. :rolleyes:


    Heute habe ich unterschiedliche Jumbo-Frames ausprobiert und keine nennenswerte Verschlechterung oder Verbesserung feststellen können.

    Interessanterweise ist die Schreibleistung des NAS heute nochmal etwas gesunken.


    bench2.JPG


    Ich vermute, dass ein Problem mit der RAID5 Konfiguration vorliegt. Ich habe noch ein Screenshot gefunden als ich mein NAS vor einem Jahr eingerichtet habe. Damals bin ich mit 1Gbit-LAN+USB Festplatte auf 350MB/s gekommen. Mit einer schnelleren Festplatte wäre wahrscheinlich auch eine noch höhere Datenrate möglich gewesen.


    photo_2020-08-05_15-32-25.jpg


    Die Geschwindigkeit nimmt natürlich mit einem höheren Füllstand der Festplatten ab, aber ein Reduzierung der Geschwindigkeit auf ein Bruchteil der ursprünglichen Leistung bei 60% Füllstand (78% Volumen) sind nicht realistisch. Auch bei gleichzeitigen Schreibvorgängen von LAN + USB lassen sich keine höhere Schreibgeschwindigkeiten als über ~130MB/s erreichen.


    Vollständige SMART-Test der Festplatten ergaben keine Auffälligkeiten. Als nächstes werde ich die RAID-Bereinigung starten. Bei 4x12Tb wird das nun leider 2-3 Tage dauern.

  • Dann sind die HDs aber wirklich langsam, ,meine 4 * 10TB Exos sind damit in 18h durch.

  • Die Raid-Bereinigung lief mit ca.180MB/s. Offenbar ist eine Festplatte defekt, weshalb sich die Schreibgeschwindigkeit merklich verringert hatte.


    Fehler.JPG


    Bisher hatte ich so ein Fehler noch nie gehabt. Was wäre nun das richtige vorgehen?


    1. Nas ausschalten

    2. Festplatte prüfen? Wenn ja mit welchem Tool?

    3. Funktionierende Festplatte einbauen und Rebuild starten

  • So, ich konnte nun noch ein paar Tests durchführen.


    Auch wenn das WD-Prüftool mir keinen Fehler angezeigt hat, habe ich die vom NAS ausgeworfene Festplatte nun durch eine Seagate Exo ersetz.

    Der ReSync hat glücklicherweise fehlerfrei funktioniert.


    Die Schreibgeschwindigkeit hat sich durch diese Maßnahme aber leider immer noch nicht verbessert. X/

    Außerdem ist mir aufgefallen, dass beim Schreibvorgang die Latenz auf dem 2. Datenträger extrem hoch ist.

    Unbenannt 2.jpg


    Ist dies bei einem Raid 5 normal oder könnte auch die zweite Festpatte ebenfalls einen Fehler haben?

    Beim integrierten Leistungstest kann leider nur die Lesegeschwindigkeit getestet werden. Gibt es Tools mit denen die Schreibgeschwindkeit der einzelnen Festplatten untersucht werden kann?

  • Du kannst doch einen umfassenden Test des Datenträgers anstoßen, aber der dauert je nach Größe sehr lange, ich schätze bei 12 TB zwischen 10 und 16 Stunden. ggf hilft der dir weiter

  • Soweit ich gelesen habe, sind die WD white weitgehend gleich zu den einfachen WD Red, d.h. es dürften SMR Festplatten sein, die sich im RAID 5 nicht eignen, noch dazu bei höheren Schreibraten.


    Mein Rat wäre also, kaufe Dir vernünftige, supportete HDDs.

  • Hmm, in dem Reddit-Artikel, auf den ich mich beziehe war erwähnt, dass die HDDs evtl. Probleme mit dem SATA-Interface haben, da sie ja für die WD eigenen NAS speziell gebaut wurden.

    Läuft da alles?