NAS mit Chrom nicht erreichbar (Blockiert) aber mit Safari geht es

  • Hallo zusammen,


    auf meinem MAC kann ich mein NAS mittels Chrom nicht mehr erreichen, da die Seite blockiert wird (siehe Screenshot):

    Safari läuft ohne Problem. Hat jemand einen TIpp, was ich da anpassenmuss?


    Gru0 Doktor

  • Die Adresse ist ja leider Zensiert...intern oder extern?



    Wenn intern, einfach mal via http vs https probieren.


    Wenn extern, dann den direkten Zugriff dringend überdenken

  • Schaue mal nach dem Zertifikat, das ist ungültig.

    Entweder veraltete Cipher, zu lange Laufzeit oder abgelaufen.

  • Was ist denn bei den bisherigen Hinweisen rausgekommen?

  • Welche Hinweise? Habe doch alles Infos geposted...dachte ich zumindestens...

  • Nunja, offen ist soweit ich sehe:

    Schaue mal nach dem Zertifikat, das ist ungültig.

    Entweder veraltete Cipher, zu lange Laufzeit oder abgelaufen.


    Was passiert wenn du das machst was in der Meldung steht?

  • Zertifikat ist ja bis 2029 gültig. Ob es kein veralteter Cipher hat oder nicht: Keine Ahnung.


    Ich kann bei der Meldung nichts machen. Der Screenshot zeigt nur eine Info..keine Chance diese zu "ignorieren".

  • Man kann z.B. mit Wireshark mitschneiden was hier genau aufgerufen wird, welche Chipher angeboten wird usw.


    Ohne diese Infos kann man die halt nicht helfen.

    Aber im Firefox z.B. kann man eine Seite in der Ausnahmenliste hinterlege und dann auch mit veralteten Chipers, abgelaufenen Zertifikaten trotzdem drauf zugreifen.

    Wenn hier nur ein Webdienst läuft und man muss da drauf um das Cert zu tauschen, muss man das halt in diese Liste eintragen.

  • Welche Chrome Version wird denn benutzt? Ich habe Version 93.0.4577.82 (Offizieller Build) (64-Bit)

    und kann problemlos auf QTS 4.3.4 und QTS 5.0 (final) NAS zugreifen.

    Allerdings habe ich Win 10 als OS, bei Mac bin ich außen vor.


    Gruss

  • Man kann natürlich auch einfach mal den Fehlercode NET::ERR_CERT_INVALID zusammen mit Chrome und MacOS googeln, bingen, duckduckgoen oder welchesuchmaschineauchimmern und so auf die Stackoverflow-Seite:

    https://stackoverflow.com/ques…nvalid-in-chrome-on-macos

    stoßen.

    Dort findet man dann bei der höchstbewerteten Antwort die Info, dass das Problem tatsächlich Mac-spezifisch ist.

    In der MacOS-Version von Chrome scheint es (mangels Mac kann ich das nicht verifizieren) die Funktion "Trotzdem laden" nicht zum Anklicken zu geben.

    Stattdessen soll man irgendwo in die Fehlerseite klicken und dann thisisunsafe eintippen.

    Eine besonders bizarre Variante der ohnehin schon merkwürdigen Linie, dass verschlüsselte Seiten mit Zertifikatfehler gefährlicher seien als komplett unverschlüsselte. :rolleyes:

  • Ich habe es getestet...es klappt wirklich, wenn ich auf der Fehlerseite das "thisisunsafe" eintippe. Sehr merkwürdig.

  • Na dann sehe zu, dass du ein Zertifikat erstellst, welche die Vorgaben von Apple erfüllt, damit es gleich ohne diese Umgehung akzeptiert wird.


    Zitat

    Apple: Kürzere Laufzeiten für SSL/TLS-Zertifikate

    20.03.2020

    Apple hat angekündigt, dass SSL/TLS-Zertifikate ab 1. September 2020 nur noch maximal 13 Monate gültig sein dürfen.

    Verbindungen zu Servern von iPhones, iPads und Macs, die sich nicht an diese Vorgabe halten, schlagen künftig fehl. Netzwerk- und App-Versagen sind die Folgen. Auerdem werden Webseiten auf Apple-Geräten nicht geladen.

    Quelle:

    https://www.brandshelter.com/d…-fuer-ssl-tls-zertifikate

  • Naja..verstehe ich nicht ganz:

    Chrom gibt den dargestellten Fehler.

    Safari funktioniert.


    Müsste es dann nicht eher umgekehrt sein?