QNAP RAID 5 rebuild schief gelaufen

  • Hallo,

    muß vorwegschicken dass ich kein NAS / IT Profi bin und ganz neu hier bin! Habe seit langem ein TS-419PII mit 4x 3TB HDDs im RAID 5.

    Gestern passierte mir folgendes und so ein ähnliches Problem habe ich hier durch Internet Suche gefunden - aber leider keinen Hinweis wie zu lösen und QNAP nicht mehr hilft da die TS419P-II EOL usw..

    Verwende die QNAP nur als Fotospeicher; wollte gestern die HDD3 austauschen da warnings bei reallocated_sector_ct auftauchten und die Platten schon älter sind.

    Vorhandene Ersatz HDD eingebaut und RAID rebuild startete; leider starb mir über Nacht während des Vorgangs die HDD2.


    Nun hab ich die alte HDD3 wieder eingebaut um zu versuchen noch was zu retten, aber GUI zeigt jz folgendes:

    pasted-from-clipboard.png


    Auf die konsole komm ich schon hin, aber ich kenn mich absolut nicht mit den Befehlen auf Linus Ebene aus (mdadm ...) um den raid verbund irgendwie zu aktivieren und dann erneut einen rebuild mit einer weiteren HDD zu starten.


    cat /proc/mdstat zeigt:


    Hat hier irgendwer eine gute Idee für mich?


    LG Reinhard

  • Am besten auf (hoffentlich vorhandene) externe Backups zurückzugreifen und das NAS von vorne aufsetzen .. ansonsten geht die Kiste zum Datenwiederhersteller (das kostet)

  • Raid 5 kann genau einen HD Ausfall abfangen, fällt eine zweite aus sind die Daten weg.


    Aber dafür ist ja ein Backup vorhanden.

    Neue HDs rein, Raid neu aufbauen und Daten vom Backup zurück sichern.