RAID-1 Rebuild dauert 14 Tage

  • Hallo zusammen,


    wegen Speicherplatzmangel bin ich gerade dabei, bei meinem TS-251+ RAID-1 QTS 4.4.3.1439 die HDDs auszutauschen. Von 2x Seagate Iron Wolf 8 TB (ST8000VN0022) (79% voll) auf 2x Seagate Iron Wolf Pro 18 TB (ST18000NE000). Weder alte noch neue HDDs haben irgendeinen defekt. Habe mich dabei genau an die Anleitung gehalten. Hotswap im Betrieb, Replace Disks One by One, Alte Disk1 abgesteckt, auf den Ton gewartet, neue eingesteckt sobald die Meldung kam. Wird richtig erkannt (auf der offiziellen Liste ist die neue halt nicht, IHM geht bei der neuen erst ab 4-Bay NAS Modellen) Rebuilding startet. Bleibt ewig bei 0,0%, min speed per console angehoben, rebuilding der reserved partition in 10 Minuten durch, statt 1,5 Stunden. Jetzt startet endlich das rebuilding von RAID-1. Läuft momentan schon einen Tag lang mit einer Geschwindigkeit von 5 MB/S. Der Trick mit min speed anheben funktioniert hier leider nicht mehr. CPU, RAM und HDD Auslastung ist gleich null. Resync Priorität auf high stellen bewirkt auch gar nichts. Lt. Berechnung würde so das Rebuild momentan 14 Tage dauern. Dann das ganze auch noch mal 2 + dann auch noch RAID-1 Größe erhöhen. Helpdesk-Ticket habe ich bereits erstellt.


    Habe hierzu noch mehrere Fragen:

    Hat jemand von euch ein Idee wie man hier die Rebuild-Geschwindigkeit anheben kann. Hätte bei diesen Größen mit ein 1-2 Tagen pro HDD gerechnet, aber definitiv nicht mit 2 Wochen. Un wenn nicht ... welche Alternativen gibt es?

    Kann ich jetzt während das rebuild läuft den NAS ohne Probleme abschalten. Ich könnte auch die alte 8 TB Platte wieder einbauen und dann probieren extern per USB zu sichern inkl. Einstellungen ... 5,8 TB herumkopieren dauert so schon lang genug.

    Gibt es vielleicht eine Möglichkeit die alte HDD richtig auf die neue zu klonen? Direkt aus QTS oder mit etwas anderem. USB 3.0 to SATA Adpater inkl. eigenes Netzteil hätte ich. Und ist hier External Raid device irgendwie nützlich.

    Dateien

    • screen.jpg

      (120,61 kB, 10 Mal heruntergeladen, zuletzt: )

    Einmal editiert, zuletzt von truthy ()

  • Keine Ahnung wie performant dein TS-251 ist. Zumindest erscheint mir so eine Rebuilddauer nicht soooo abwegig, wenngleich es sich im Bereich von einigen Tagen bewegen müsste.


    Mein, zugegeben äußerst schwaches, TS-412 brauchte für den letzten Rebuild des RAID5, bei 4 x 4TB, ungefähr eine Woche. Jeweils etwas über einen Tag pro Platte und am Ende noch gut 1-2 Tage für das Vergrößern des Volumens, nachdem endlich alle 4 Platten neu aufgebaut waren ...

  • Mein Rebuild mit 3TB Platten dauert ca. 20-30h, insofern könnte das mit 18TB tatsächlich etwas länger dauern :rolleyes:.


    Und nein, ein "vernünftiger" Weg mit einem Clone Programm ist mir nicht bekannt. Es hat zwar mal jemand hier in dieser Richtung was gepostet (such mal nach Beiträgen von PaulBaumann ), aber das machst Du auf eigenes Risiko und am besten mit einem aktuellen Backup.


    Gruss

  • Danke für die Antworten. Einige Tage wären ja OK, aber mehr als 2 Wochen. Und dann auch noch mal 2. Wie erwähnt gibt es so gut wie keine Auslastung. Quadcore-CPU: Intel(R) Celeron(R) CPU J1900 @ 1.99GHz - RAM: 8 GB SO-DIMM DDR3L (2 x 4GB) - HW-Specs


    Soll das heißen, das ist "normal", dass die HDDs die locker 50-250 MB/S schaffen, beim RAID-1 rebuild nur mit 5 MB/S laufen. Habe dazu noch folgendens gefunden: Link


    Update ... momentane Geschwindigkeit ist zb jetzt gerade 230 MB/S. Springt dann nach einiger Zeit auf 50 MB/S. Ich warte jetzt mal ab, vielleicht sind ja diese Angaben alle falsch und es geht doch erheblich schneller.

    Dateien

    • screen2.jpg

      (201,46 kB, 10 Mal heruntergeladen, zuletzt: )
  • Sind die 18TB bei der HD mit SMR oder CMR realisiert worden?


    Wobei das auch bei SMR schnell gehen sollte, da es das erste beschreiben ist und dieses rein sequenziell erfolgt.


    Es sei denn, du hast Random IO Zugriffe, wegen Systemlog, Apps oder anderem was im Hintergrund läuft (Docker, VM, DB, usw.).

    In dem Fall kacken SMR HDs total ab und 5MB/s sind dann sogar im schlimmsten Fall das was die Dinger gerade noch schaffen.

  • Mit CMR. Aber es scheint das Thema hat sich erledigt.


    Rebuild ist jetzt fertig: Die Dauer lt. Syslog war 34h 20 min.


    Kurios ist, dass es ca. 24h lang bei 5 MB/S blieb und erst dann schneller wurde.

  • Ich glaube der Zugriff auf die GUI beeinflusst die Geschwindigkeit auch massiv, zumindest habe ich dieses Gefühl von ein paar Rebuilds oder anderen "größeren" Schreiboperationen im Hinterkopf...

    Seitdem vermeide ich den Zugriff auf die GUI bei solchen Aktionen und erspare mir den ständigen Blick auf den Fortschritt.

  • Crazyhorse

    Nein, lt putty/console watch cat /proc/mdstat waren es wirklich solange dauerhaft nur 5 MB/S. Wenn ich halbwegs richtig gerechnet habe, komme ich für 5,8 TB auf durchschnittlich ~ 50 MB/S für Disk 1.


    Momentan läuft das rebuild für Disk 2 von Anfang an mit wesentlich höherer Geschwindigkeit. Update folgt wie lange das dann wirklich gedauert hat.

    tiermutter

    Ja das ist mir auch aufgefallen. Insbesondere wenn Storage und Snapshots geöffnet ist, geht die Geschwindigkeit in den Keller. Melde mich jetzt nicht mehr an solange bis das fertig ist.


    Update: Rebuild von Disk 2 hat jetzt nur 9h 15m gedauert ~ 180 MB/s. Disk 1 dauerte 34h 20 min ~ 50 MB/S.

    Erweitern hat 15h 36m gedauert.

    3 Mal editiert, zuletzt von truthy ()