Logisches Laufwerk wird als ausgeworfen angezeigt

  • So, unglaublich aber wahr, hatte gestern wieder das gleiche Problem wie vor 2 Jahren. Ein Laufwerk wurde als ausgeworfen angezeigt und ließ sich nicht mehr mounten. Reboot brachte auch nichts

    Manchmal braucht man doch tatsächlich die eigene Anleitung wieder und ist froh wenn man das dokumentiert hat. Leider kann ich in den alten Thread meine Ergänzungen nicht mehr eintragen, also hier nochmal etwas genauer.


    Zustand

    Das Laufwerk lässt sich nicht mehr von Hand mounten und wird im Speichermanager als ausgeworfen angezeigt.

    Da hilft dann auch kein reboot, das bleibt leider so.


    Wer trotzdem das Mounten versuchen will kann man das in ssh folgendermaßen machen (gilt für Single Volumes nicht für Raid's)

    mount /dev/sdb3 /share/HDB_DATA

    dies ist der Befehl für das Mounten von Laufwerk 2 Partition 3 auf den üblichen Sharepoint. Für Laufwerk 1 wäre das Device /dev/sda3 und das muss dann auf /share/HDA_DATA usw.


    Das hat nicht funktioniert auch ein normaler Start von e2fsck ging nicht, brachte aber die Superblock Fehlermeldung


    also mit

    mke2fs -n /dev/sdb3 wird der Speicherort des superblock backup angezeigt (die Nummern unten, es gibt mehere Orte für das Backup)

    dann mit

    e2fsck -b superblock /dev/sdb3 das Backup des Superblocks auf Laufwerk 2 Partition 3 zurückschreiben (statt superblock eine der angezeigten Nummern eintragen)


    Achtung das dauert wirklich lang, nicht nervös werden. Am Besten was anderes machen.


    dann habe ich mit

    e2fsck /dev/device das Laufwerk überprüfen lassen (dauert wieder)

    Bei mir hat es wieder ohne Datenverlust funktioniert. Garantie gibt es aber sicher nicht.



    dann entweder ein reboot oder das Laufwerk mit z.B.


    mount /dev/sdb3 /share/HDB_DATA (Beispiel für Laufwerk 2) wieder einhängen


    Vielleicht braucht's ja jemand