Zeitverhalten Web Server

  • Mir ist da etwas aufgefallen was ich mir noch nicht erklären kann, evtl. weiß es hier jemand. Nun

    Vorgeschichte: ich habe auf einem NAS (v4.3.4.irgendwas) einen Webserver mit mehreren virtual hosts am Laufen.

    Am PC habe ich die entsprechende Seite im Browser auf, auf einem anderen Monitor habe ich die Datei im Editor.

    Ich kann so die Datei editieren, speichern und auf dem anderen Monitor die Auswirkungen sehen (nach Neuaufruf).

    Soweit, so gut.

    Aber bis die Änderung sichtbar, bzw. die geänderte Datei aufrufbar ist, dauert es manchmal 1 Minute oder länger!?

    Das bin ich so von einem "echten" Linux Host mit Apache nicht gewohnt.

    Speichern und im Browser klicken, da waren die Änderungen immer sofort sichtbar, so eine Verzögerung ist mir noch nie untergekommen.

    Es scheint fast so, als ob der Indianer auf dem NAS in Intervallen das Webroot einliest und aktualisiert.

    Das ist Browserunabhängig (FF, Edge, Chrome und Opera getestet).

    Auch absolut neue Seiten sind betroffen, also auch keine Cache Sache.

    Die Seiten sind plain HTML mit PHP, also nichts wildes, kein Java oder ähnliches.

    Hat da jemand ähnliches festgestellt?


    Gruss

  • Das ist nur eine Einstellung. Muss ich nachher mal nachgucken. Ich meine man konnte das in der php.ini machen. (oder der config vom Apache?) Jedenfalls einfach nur ein Wert für den Aktualisierungsintervall, den man runter setzen kann.

  • Das wäre prima, die php.ini und die diversen .conf bin ich durch, aber da ist mir kein Parameter/Wert aufgefallen, der auf dieses Verhalten deuten würde.

    Zumal die Zeit bis zur Aktualisierung nicht konstant ist.

    Manchmal sind es nur wenige Sekunden, meist aber 1 Minute oder länger.

    Daher mein Eindruck das dort ein Intervall abläuft und man manchmal mehr oder weniger zufällig kurz vor dem Ende etwas aktualisiert, so das diese Änderung (fast) sofort übernommen wird, weil das nächste Intervall gerade gestartet ist.

    Ich habe das auch noch mal auf einer meiner VMs getestet (SLES11), da habe ich das Verhalten definitv nicht.


    Gruss

  • Wenn ich mich richtig erinnere sind es die Parameter


    Code
    1. [opcache]
    2. opcache.memory_consumption = 128
    3. opcache.interned_strings_buffer = 8
    4. opcache.max_accelerated_files = 4000
    5. opcache.revalidate_freq = 60
    6. opcache.fast_shutdown = 1
  • opcache.revalidate_freq = 60

    Danke jahude , genau der war es.

    Ich hätte das php.manual etwas genauer durchsuchen müssen.

    Warum den QNAP aber default auf 60s einstellt erschließt sich mir nicht wirklich.

    Auf meinen Suse Rechner finde ich nichts derartiges in der php.ini :/.


    Gruss