HybridBackupSync synchronisiert nicht mehr

  • Also ganz ehrlich: Für mich ist QNAP so gut wie gestorben. Die Firmware-Updates sind Mist, HBSfunktioniert nicht und plötzlich kann ich die USB-Festplatten der Sicherung nicht mehr an normalen Computern betreiben.


    Ich hatte mich schon so tierisch geärgert, dass es keine PC-Software gab (außer diesem kleinen Java-Programm), mit der man verschlüsselte Daten aus der Cloudsicherung entschlüsseln konnte.


    Ich denke, dass QNAP hier ein ganz klare Kante fährt und uns Kunden das Arbeiten mit anderer Hardware abgewöhnen möchte.


    Das ist einfach nur Mist. Da der Support von Qnap auch nicht berauschend ist, werde ich mir wohl wieder einen eigenen Server bauen und mit "Unraid" oder ähnlichem betreiben.


    Schlimmer als jetzt kann es jedenfalls nicht werden. Danke an alle, die sich hier Mühe geben, vor allem den Mist von QNAP abzufangen. Ich steige aus, bevor das nächste Firmware-Update vielleicht noch einen Crypto-Locker enthält :-(

    Mathias

  • Welche Firmware und HBS Version hast Du denn nun im Einsatz?

    und plötzlich kann ich die USB-Festplatten der Sicherung nicht mehr an normalen Computern betreiben.

    Hast Du möglicherweise die Festplatte am NAS mit dem EXT4 Filesystem formatiert? Dies kann ein Windows-PC nicht ohne weiters lesen.

    Das ist einfach nur Mist.

    Ganz klar, ärgerlich wenn etwas nicht funktioniert wie es soll. Aber ein NAS ist schon noch etwas komplexer als ein Smartphone. Hier sind die NAS Hersteller noch nicht so weit, wenn sie es denn je sein werden. Ich habe mir die Hochglanz-Prospekte von QNAP nie angesehen. Aber hier scheint die PR-Abteilung etwas übereifrig zu sein und das Bedienen eines NAS leichter darzustellen als es in Wirklichkeit ist. Dies haben jetzt schon unzählige so berichtet.

    Bei jedem Firmware- und App-Update besteht die Gefahr, dass etwas schief gehen kann, nicht nur bei QNAP. Je komplexer das System desto wahrscheinlicher. Kleines Beispiel: Habe 3 TS-231+. Auf zweien ging das Update von QTS 4.2.x auf 4.3.x ohne Probleme, beim Dritten und wichtigsten dafür um so mehr daneben. Da aber 2 NAS keine Probleme hatten ging ich mal davon aus, dass es nicht an der Firmware liegen kann. Da die Probleme nach und nach sichtbar wurden hat es mich volle 3 Tage gekostet allen Problem wieder hinzubiegen. Ob die Einstellungen falsch migriert wurden oder nie korrekt waren kann ich nicht überall schlüssig nachvollziehen. Letzten Endes hat das NAS mit der scheinbar verbugten Firmware dann doch funktioniert.

    Im Einzelfall ist es immer schwierig abzuschätzen wo der Fehler genau liegt. Natürlich ist mir klar, dass man von QNAP eigentlich erwarten würde - Update installieren und gut. Wenn die Einstellungen vorher funktioniert haben wieso tun sie es denn nicht danach.

  • Aber ein NAS ist schon noch etwas komplexer als ein Smartphone.

    Mod: :handbuch::arrow: Die Zitat Funktion des Forums richtig nutzen

    Was? Und ich habe mich schon gefragt, warum ich mit dem Ding nicht telefonieren kann ...

    Spaß beiseite:


    1. QNAP hat es bis heute nicht geschafft, ein Programm zur Verfügung zu stellen, mit dem ich verschlüsselte Daten aus der Cloud-Sicherung (HBS) auf meinem Rechner wieder entschlüsseln kann. Somit ist HBS als K-Fall-Sicherung nicht zu gebrauchen, da ich mir z.B. nach einem Brand nicht als erstes wieder eine QNAP holen kann um an meine Daten zu kommen. So etwas ist ein Ausschlusskriterium für eine NAS.


    2. Dass ich plötzlich keine Shares eines fremden NAS mehr für die Sync mit HBS erreiche, die problemlos im Netz zur Verfügung stehen und sogar mit der QNAP per WINSCP zu mounten sind ist nicht nachvollziehbar, passt aber zu dem proprietären Mist aus Punkt 1. Man will halt mehr QNAP verkaufen. Kommt so ein Hersteller allerdings in Schieflage oder wird "getrumpelt" (womit wir wieder beim Smartphone wären), kann ich mal eben neue Hardware kaufen. So etwas ist keine Option. Schon gar nicht in der heutigen Zeit.


    3. Ich habe angefangen mit diesen Kisten zu arbeiten, als Festplatten so groß waren wie ein kleiner Kühlschrank und Disketten aussahen wie ein Kuchenblech. Egal ob Win NT oder Suse, CentOS etc., ich habe sie alle kennen- und lieben/hassen gelernt. Natürlich mag ich es HEUTE, wenn entsprechend der Werbung alles per Mausklick funktioniert. Und besonders schön wäre es, wenn einfach alles läuft. OK, kleinere Probleme gibt es immer wieder. ABER, wenn der Hersteller mir diese reihenweise im Bereich Datensicherung/Recovery vor die Füße schleudert, weil er ein paar dieser Kisten mehr verkaufen möchte, dann läuft etwas mächtig falsch.


    Ich habe in all den Jahren nicht einmal erlebt, dass ein kritischer Teil einer Linux-Distri über Wochen oder Monate so einen Müll produziert hat. Binnen Tagen war ein Update da, welches lief. Außerdem hatte man immer mehrere Dienste zur Verfügung, gut dokumentiert und seit Jahren im Einsatz.


    4. Natürlich ist die Expansion nicht in EXT4 oder irgendwas anderem formatiert. Die zweite Festplatte läuft Gottseidank noch ganz normal. OK, mag jetzt ein Fehler auf der Seagate sein, schaue ich mir an. Aber wohl ist mir nicht, da von meiner 3-2-1 Sicherung jetzt nur noch eine einzige vorhanden ist. HMPF!


    Fazit: Ich versuche jetzt mal das neueste Firmware-Update von QNAP und aktualisiere alle Dienste und installiere noch den neuen Hybrid-Mount. Sollte das nicht in Kürze ein vernünftiges Ergebnis bringen, baue ich mir einen Server und betreibe ihn entweder mit UNRAID oder FREENAS oder irgend etwas ähnlichem. Die QNAP läuft jetzt gerade mal drei Jahre. Mein letzter Linux-Raid-Server (SCSI) ist von 2001 bis 2007 gelaufen, ohne irgendein Problem. Sogar die Bandsicherung lief ohne Murren.

    Nochmals Danke an Alle, die sich hier die Mühe machen und versuchen zu helfen. Viele Grüße


    Mathias


    PS: Noch 4.4.1.1064 und HBS 2.1.190709



    NACHTRAG: Externe Festplatte hat sich formatieren lassen, keine Fehler gemeldet, FS ist NTFS. Jetzt werden die Daten gerade neu gesichert.

    Einmal editiert, zuletzt von qnapsalliweb ()

  • qnapsalliweb

    Vielleicht bin ich schon zu lange dabei und schon zu abgestumpft. Das was Du schreibst stimmt schon, aber irgendwie habe ich inzwischen das Gefühl, dass dies doch bei jedem Hersteller so ist und völlig normal ist. Mein privater Fuhrpark besteht aus 5 PC's (Ubuntu, Windows, Mac), 3 NAS (QNAP, Syno), 3 Tablets (Apple, Huawei, Samsung) - wohlgemerkt für mich alleine, denn irgend ein Teil bockt doch immer und tut nicht was es soll. Aber vielleicht sind auch meine Ansprüche an was "perfekt funktionieren" bedeutet zu hoch gegriffen. OK, meine Konfigurationen sind vielleicht auch nicht gerade das was man als Standard bezeichnen würde. :) Basteln und ausprobieren gehört für mich einfach mit dazu. ;)


    Das selbe Spiel geht natürlich auch im Business-Umfeld, wobei da dies Summen doch um ein Vielfaches höher sind, aber die Probleme oft die selben, wenn auch mit anderen Herstellern. Ich habe grundsätzlich das Gefühl, dass früher irgendwie alles unproblematischer und stabiler lief. Aber vermutlich werde ich auch einfach nur alt. :/


    Mein QNAP Fazit:

    Inzwischen habe ich 8 QNAP NAS (OK, das 8. ist noch nicht fertig eingerichtet), 7 davon dienen als Netzwerkspeicher in Form eines Shares oder als Backup-Ziel => keine bis kaum Probleme, läuft und läuft, das älteste seit knapp 10 Jahren. 1 NAS dient als File-Server, DC und AD, GPO und GPP, FTP, etc. Das ist das Teil, welches bei mir immer wieder mal Ärger verursacht.

    Ein NAS ist ein NAS und kein Server. Schuster bleib bei Deinen Leisten, dann klappt es auch.

  • Letzter Stand: HBS3 findet die Shares wieder. Eine Synchronisation klappt trotzdem nicht, die Kiste bricht mit dem Fehlercode -22 ab.


    Ich werde morgen nochmal HBS deinstallieren und danach die Config-Dateien löschen bzw. umbenennen. Wenn dann nach einer Neuinstallation des HBS3 der gleiche Fehler auftritt, werde ich die Bemühungen einstellen und mir eine schöne Hardware für FREENAS zusammenstellen.


    Mavalok2  
    Falls Du eine 9te Qnap haben willst, meine landet definitiv in der Bucht. Nach drei Jahren kann ich nur versuchen, meinen Verlust klein zu halten.


    Mathias

  • Bei mir klappts wunderbar mit hbs3. Synchronisation mit meinem alten nas von qnap und eins von medion, externe usb 3.0 hdd und auch Google Drive.

  • Ich bin jetzt wohl ins gleiche Problem reingelaufen :(


    Allerdings im Zusammenhang mit dem Sync von meiner TS-453Be (HBS3) zum Backup NAS TS-112 (HBS 2.1.190909). Das lief lange Zeit einwandfrei, aber nach dem Update der HBS Versionen auf beiden NAS habe ich jetzt Probleme, daß er immer alles komplett neu syncen will :( :( :(


    Hat jemand die alten Versionen HBS 2.1.190709 für beide NAS???

    Muß ich die dann einfach drüber installieren und der ersetzt die dann automatisch (also auch bei der HBS3 auf der TS-453Be?

  • daß er immer alles komplett neu syncen will

    Könnte aber auch an den Einstellungen des Jobs liegen. Wenn im Backup-Job Datenprüfen oder so ähnlich aktiviert ist geht der Job deutlich länger. Wie kommst Du übrigens darauf, dass alle Daten komplett synchronisiert werden?

  • Ich habe an den Einstellungen nichts verändert...der Job lief Monatelang einwandfrei. Und jetzt fängt er GB weise Daten zu übertragen, obwohl sich nicht viel verändert hat.

    Meine Hauptvermutung liegt im Update der HBS Version auf der TS112 mit 2.1.190909. Seitdem ich auf der Version bin, haben die Probleme mit erst seltsamen Abbrüchen angefangen. Außerdem werden seit ein paar Tagen unter "incoming jobs" die eingehenden Transfers nicht mehr angzeigt. Das Logging hat auf einmal aufgehört, obwohl es noch ein paar Tage lief. Dann auf einmal ist das noch nichtmal mehr protokolliert. :(


    Ich würde deshalb als erstes mal nur auf der TS112 die alte Version HBS 2.1.190709 installieren wollen, wenn die mir jemand geben würde.