Verwendung Linux -Station mit HDMI Fernseher

  • Hallo Zusammen,


    ich habe folgendens Problem.

    Ich möchte an mein QNAP HS-453DX einen HDMI Fernseher anschließen. Wenn dieser angeschlossenen ist bekomme ich nach dem Start der Linux-Station ein Bild. Auf der Linux-Station soll unter anderem Kodi als Mediencenter dauerhaft laufen.


    Schalte ich jetzt den Fernseher aus, bekomme ich in der Linux-Station die Fehlermeldung "An- oder Abstecken eines HDMI Geräts erkannt, bitte starten Sie die Linux-Station neu". Schalte ich den Fernseher wieder an, bekomme ich nur ein schwarzes Bild (bzw. die Meldung auf dem FErnseher "kein Signal"). Muss ich wirklich jedesmal, wenn ich mit dem Fernseher auf die Linux-Station zugreife, diese vorher auf dem System deaktivieren und nach dem Anschalten des Fernsehers wieder anschalten? Irgendwie ist das äußerst umständlich zum Fernsehen/Filme schauen mich vorher auf das NAS einloggen zu müssen...und den Fernsehr will ich auch nicht dauerhaft "an" haben...


    Ist das bei euch auch so? Bzw. wie verwendet ihr die Linux-Station?


    Danke für Eure Hilfe!


    Tim

  • Ist das bei euch auch so? Bzw. wie verwendet ihr die Linux-Station?

    Bei mir ist an dem NAS ein Beamer angeschlossen und ich muss die Station nicht neustarten. Allerdings ist bei mir zwischen Beamer und NAS noch ein HDMI -> VGA Konverter dazwischen, weil der HDMI Eingang am Projektor defekt ist.
    Weiterhin verwende ich nicht die "originale" Linux Station, sondern einen eigenen LXC Container, der jedoch fast die gleiche Konfiguration wie die QNAP Linux Station besitzt.

  • Hi,


    ich verwende einen Streaming PC für solche Sachen - das ist um einiges unkomplizierter


    VG

    Friis

  • ich benutze ls mit ts-873 und 1050ti und kodi häufig am fernseher und habe die von dir genannte abschaltmeldung in der ls noch nie gesehen. kann sein weil mein fernseher 8-9 jahre alt ist und nur neuere geräte dieses signal überhaupt senden..

    oder vllt deswegen (siehe bild)

  • hm, der QNAP-Support erklärt mir, das wäre so gewollt... ich solle doch immer zuerst den Fernseher anschalten und danach die Linux-Station aktivieren. (sonst könnte diese ja auch gar nicht die richtige Auflösung detektieren). Irgendwie verstehe ich die Lösung nicht ganz. Ich habe doch ein NAS das dauerhaft läuft bzw. auch die Linux-Station will ich doch nicht ständig umständlich ein- und ausschalten, wenn ich den FErnsehre anschalte und mich mit dem HDMI-Ausgang verbinde...


    tuxflo :

    Hast Du eine Vorlage für den von Dir erwähnten LXC Container? Bzw. auch eine Anleitung, wie Du z.B. den HDMI-Anschluss durchreichst ? Bzw. wie gibst Du dann den Ton aus? Nicht über HDMI?


    tola : Danke, habe die Anzeige so nicht ganz gefunden, nur eine ähnliche unter Setting-Privacy (Ubunut 18.04). Aber die ist bei mir auch ausgeschaltet.


    GRuß,


    Tim

  • Wie genau die Durchreichung funktioniert kann ich dir auch nicht sagen, ich habe einfach die originale config Datei genommen und durch try & error so lange rumgebastelt bis es funktioniert hat. Hier meine beiden config Dateien:

    Die Dateien post-stop.sh pre-mount.sh und pre-start.sh sowie autodev.sh und qnap.json habe ich einfach so belassen und in das Verzeichnis des LXC Containers (in meinem Fall /var/lib/lxc/ubuntu-HDMI/ kopiert.


    Ton kommt bei mir zwar über HDMI, wird aber dann mit dem bereits erwähnten VGA Splitter in ein Cinch Signal umgewandelt. Für die Software sollte das aber keinen Unterschied machen. Ich habe aber auch schon ganz gute Erfahrungen mit USB Soundkarten gemacht (als ich den HDMI Konverter noch nicht hatte).

    Für eine ausführliche Anleitung fehlt mir leider derzeit die Zeit... :(