Daten aus "altem" Raid Volume auslesen

  • Hallo Community!


    ich habe mich selbst leider in eine unschöne Situation befördert.

    Ich habe ein TS-228 2-bay, habe lange Zeit nur eine Platte genutzt, und irgendwann auf ein RAID1 mit einer 4TB- und einer 2TB ausgeweitet. Dann wollte ich natürlich die 2TB gegen eine 4TB tauschen, um das RAID zu vergrößern, und in diesem Prozess habe ich mich übel verstrickt, weil ich es nicht hingekriegt habe das RAID Volume so zu erweitern dass ich die 4TB voll nutzen kann (aufgrund der kleineren Platte war es ein 2TB RAID)


    In dem Verlauf habe ich auf einer der 4TB Platten ein komplett neues RAID Volume aufgesetzt, und jetzt habe ich eine Platte mit einem neuen (leeren) RAID Volume und zwei Platten mit einem alten RAID auf dass ich nicht mehr zugreifen kann.

    Mein Plan war, die Daten von den anderen Platten einfach auf das neue RAID zu kopieren, aber ich hatte nicht damit gerechnet, dass das alte RAID auch als externes Medium nicht als einfacher Speicher erkannt wird, und ich so über die File Station nicht an die Daten komme.


    Wenn ich mit den alten Platten das NAS starte wird mir ein Fehler angezeigt, weil natürlich das aufgesetzte RAID Volume nicht übereinstimmt mit dem Volume auf den Platten.


    Kann ich irgendwie eine Platte mit dem "alten" RAID einstecken oder per USB anschließen und auf die Daten zugreifen, um sie in das neue RAID einzuspielen?


    Vielen Dank für jede Hilfe!!

  • Danke frosch2 für die schnelle Antwort


    Über Windows habe ich das ganze auch hingekriegt.

    z.B. mit ReclaiMe kann man die Daten auslesen und weg kopieren, oder mit dem EaseUs Recovery Programm.

    Dann habe ich aber das Problem dass ich knapp 2 tb Daten übers Netzwerk auf das NAS transportieren müsste.

    Mit ReclaiMe war ich nach einer Nacht bei 1%! Ich weiß nicht warum es so langsam ging, habe Gigabit LAN genutzt, aber ich habs abgebrochen. Vermutlich lag es an vielen kleinen Dateien.


    Ich denke wenn es so geht sollte es doch auch mit dem Linux auf der TS gehen oder?

  • Die Platte war in ein ordentliches externes 3.5'' Gehäuse mit externer Stromversorgung eingesetzt worden.

    Ist möglich aber ich würde vom Gefühl die Übertragung via Netzwerk als Flaschenhals ansehen.

  • Die Platte war in ein ordentliches externes 3.5'' Gehäuse mit externer Stromversorgung eingesetzt worden.

    USB 2 oder 3?

  • Über Gbit laufen locker 100MB/s, das sind fasst 6GB pro Minute.

    8 Stunden und das sind fast 3TB Daten verschoben.


    Das Netzwerk ist hier nicht das Problem, wenn es den Gbit ist, bei Fast erhernet wartest du aber um Faktor 10 länger.

  • Selbst bei USB2(Was ich hier wohl habe) müsste ich bis zu 40MB/s haben, also 144GB/h, macht grob 14 Std für 2 TB.

    Ich bleibe dabei, das sequenzielle Lesen oder schreiben von vielen vielen Kleindateien scheint mir das Problem zu sein. Immerhin wurden 500.000 Dateien gefunden.


    Gibt es keine Möglichkeit ein gelöschtes RAID Volume über die Konsole, z.B. mit dem mdadm, wiederzubekommen?


    Ich habe es bislang auch nicht geschafft eine der RAID Platten zu mounten und auf die Datenpartition zu bekommen.


    Ich kann schwer glauben dass das mit dem Linux-System nicht geht.

  • Selbst bei USB2(Was ich hier wohl habe) müsste ich bis zu 40MB/s haben

    In der Theorie, selbst hatte ich schon Controller, die 3-4 MB/s brachten.


    Mit Linux:

    - USB-FP anschließen

    - auf der Kosole fdisk -l nach der Partition mit den Daten suchen z.B. /dev/sdx3

    - Verzeichnis für das Mounten anlegen z.B. /shares/usb-fp mkdir /shares/usb-fp

    - sdx3 read only mounten mount -o ro /dev/sdx3 /shares/usb-fp

    - in das Verzeichnis wechseln cd /shares/usb-fp

    - mit ls kannst du nun die Verzeichnisse und Dateien auf Partiton anzeigen lassen


    Jetzt musst du entscheiden, was du wohin kopieren willst.

  • Mod: :handbuch::arrow: Die Zitat Funktion des Forums richtig nutzen

    Und das funktioniert anscheinend nicht mit RAID Disks, weil sich die "Partition" hier anders verhält.


    Gleiches hab ich probiert und nicht hinbekommen. Man bekommt die Fehlermeldung dass die Partition sich nicht mounten lässt weil sie kein bekanntes extX Format hat (habe ohne Formatierung und mit -t flag ext3 und ext4 probiert).



    EDIT:

    frosch2 danke dir nochmal, mit deinem Input hab ich mich nochmal durch google geforstet (Suchbegriff "mount RAID Disk")und neue Ansätze gefunden, die auf den mdadm hinauslaufen.

    z.B. hier im ubuntuusers Forum.


    Damit werde ich nochmal versuchen die Platte/n als RAID einzuhängen.



    Falls es noch andere Ideen gibt bin ich dankbar!

    Einmal editiert, zuletzt von lavolp3 ()

  • Ehrlich gesagt weiß ich das nicht.

    Ich habe es nicht eingestellt. Es war als Static Single Volume eingerichtet.

    Ist das schon LVM?

  • Ist das schon LVM?

    Kann ich dir leider nicht sagen.


    Gleiches hab ich probiert und nicht hinbekommen. Man bekommt die Fehlermeldung dass die Partition sich nicht mounten lässt weil sie kein bekanntes extX Format hat (habe ohne Formatierung und mit -t flag ext3 und ext4 probiert).

    Wäre nett gewesen, wenn du es vorher geschrieben hättest.

    Einmal editiert, zuletzt von frosch2 ()