Hybrid Backup Sync per Zeitplan

  • Hallo liebe Gemeinde,


    es ist wieder mal soweit. Ich brauche Ratschläge in Form der Schwarmintelligenz.

    Mein Hybrid Backup Sync ist so eingestellt, daß ein spezieller Ordner von der Quell-NAS per rsync auf eine andere NAS im gleichen Netzwerksegment gesichert wird.

    Diese Sicherung soll wöchentlich 1x am Dienstag um 04:00 Uhr gestartet werden.




    Das Ziel wird per Zeitplan gestartet und läuft auch. Nur Hybrid Backup Sync lässt das irgendwie kalt. Der Sicherungstermin wird einfach übersprungen.

    Letzte erfolgreiche Sicherung war am 30.4. Das steht auch so im Log:


    Code
    1. [30.04.2019 04:00:26] Job [Local->Remote_Job1] started.
    2. [30.04.2019 04:00:26] Synchronize files from a local folder to a remote folder.
    3. [30.04.2019 04:00:26] Server IP address: 10.1.1.13, port number 1.
    4. [30.04.2019 04:00:26] The SSL connection option is disabled.
    5. [30.04.2019 04:00:26] The number of folder pairs = 1.

    Außer dem Nichtstarten gibt es keinerlei Fehlermeldungen oder sonstige Ungereimtheiten.

    Code
    1. etc/config/crontab
    2. 4 3 * * 3 /etc/init.d/backup_conf.sh

    In der backup_conf.sh gibts lauter Code, den ich nicht lesen kann.

    Hat jemand sonst auch Probleme, Ratschläge, Tips zu dem Thema?


    Gruß Rednag

  • Aber gerne doch.

    Das ist der gesamte Code der besagten Datei:


  • Das Ziel wird per Zeitplan gestartet und läuft auch.

    Um welche Uhrzeit wird das Ziel gestartet? Kann es sein, dass das Ziel beim Start des Backups noch nicht bereit ist? Könnte mir schon vorstellen, dass der Start des NAS und bis der Rsync-Server bereit ist schon 1/2 Stunde vergehen kann.

  • rednag

    Der Code ist doch lesbar. Dass du die arbeitsweise nicht verstehst, ist was ganz Anderes.


    Ich dachte schon, dass die Datei evtl. defekt ist.

  • Check mal, ob der Job auf beiden NAS noch "richtig" konfiguriert ist, oder ob der "passivejob" auf deinem Ziel-NAS nicht mehr aktiv ist.

    Ich hatte so ein Problem mal, dass das andere NAS nicht mitbekommen hat, dass der Job beendet ist und zeigte den in der GUI tagelang als "running" an obwohl er nicht mehr lief. Jeder weitere Start war damit aber unmöglich ...


    Gehst mit WinSCP auf dein NAS und darin auf den Ordner /etc/config/qsync/.

    Darin findest du zwei configs qsyncjobdef.conf und qsyncpassivejob.conf.

    In der letzteren findest du die "passiven" Jobs der anderen NAS.


    Eventuell postest du die beiden Configs hier mal ...

  • Dass du die arbeitsweise nicht verstehst, ist was ganz Anderes.

    Das wollte ich damit ausdrücken. Augenscheinlich scheint die Datei in Ordnung zu sein.

    Um welche Uhrzeit wird das Ziel gestartet?

    Die BackupNAS wird Dienstags um 01:00 Uhr gestartet. Von 01 - 04 Uhr sollten die benötigten Dienste schon gestartet sein. :-)


    Gehst mit WinSCP auf dein NAS und darin auf den Ordner /etc/config/qsync/

    In dem besagten Ordner finde ich neben ein paar anderen nur die qsyncjobdef



    Der Inhalt ist aber ein wenig auskunftslos.


    Code
    1. [Job0]

    Mehr ist da nicht drin.

  • Was steht denn in der qsync.conf?

    Die ist bei mir (alter SM) nämlich nur 0 KB groß, dafür habe ich besagte andere zwei qsynjobdef Files.

  • Dann ist die put, die qsync.conf müsste eher so aussehen (Job mittels HBS erstellt, Inhalt nur bissl zensiert):



    Die qsyncjobdef.conf ist aber bei mir auch leer, scheint also normal zu sein. Also, wieder was gelernt: Die HBS Jobs stehen in der qsync.conf, die SM Jobs in der qsyncjobdef.conf


    RedDiabolo Warum nimmst du eigentlich immernoch das Alte Teil? Irgendwelche nachvollziehbaren Vorteile? oder nur Nostalgie?

  • RedDiabolo Warum nimmst du eigentlich immernoch das Alte Teil? Irgendwelche nachvollziehbaren Vorteile? oder nur Nostalgie?

    Boah, ist schon lange her, dass ich wieder umgestiegen bin, warum auch immer ;-)


    Irgendwie hatte ich da Probleme mit dem HBS, weiß aber nicht mehr ob es Performance oder Fehlermeldungen waren ... habe mich da stundenlang durchgewühlt und bin mit dem HBS nicht ganz klar gekommen. Das war zu einem Zeitpunkt wo es auch viele Tickets zum HBS gab und QNAP schon mal den Umstieg auf SM nahelegte ...


    Der SM ist irgenwie "knackiger", nur da, was WIRKLICH benötigt wird (nehme RTRR Jobs).


    Nachdem ich das Backup "reverse" mache, sich also das Ziel die Daten abholt und ich auf dem Backup NAS(en) auf alter FM bleibe (4.2.5) geht dort ohnehin nur SM, von daher nehme ich auf dem Quell-NAS auch dem SM ... passt besser zusammen.


    Die qsyncjobdef.conf ist aber bei mir auch leer, scheint also normal zu sein. Also, wieder was gelernt: Die HBS Jobs stehen in der qsync.conf, die SM Jobs in der qsyncjobdef.conf

    Danke für die Rückmeldung, dann weiß ich jetzt, dass ich bei HBS Fehlermeldungen nicht von der SM Konfiguration ausgehen kann und (muss) mich da wohl etwas zurückhalten :cup:bevor ich die Anwender noch mehr verwirre.