Problem bei Import von VM in Virtualisation Station 3

  • Guten Tag zusammen,

    vielleicht kann mir einer helfen oder Hinweise geben.

    Ich habe einen Windows 2008 Server Standard mit dem VM Ware Converter virtualisiert.
    Wenn ich nun in der Virtualisation Station 3 die *.vmx Datei einlese, werde ich daraufhin aufgefordert die 3 dazugehörigen *.vmdk Dateien hochzuladen.

    Diese 3 Dateien sind ca. 710 GB groß.
    Leider kommt bei der Auswahl der 3 Dateien die folgende Meldung:
    Nicht genügend Speicherplatz der VM verfügbar(1,51 TB)
    Anderen Speicherort auswählen, insgesamt benötigter Speicherplatz 7.71.TB.


    Was mache ich hier falsch?
    Die TS 677 habe ich mit 3 x 960 GB SSD bestückt und im RAID 5 als Statisches Volume konfiguriert.

    Ich bedanke mich schon jetzt für evtl. Hilfestellung und wünsche noch einen schönen Oster-Montag.

    Viele Grüße

    RAY !!

    Dateien

    • QNAP1.PNG

      (171,47 kB, 10 Mal heruntergeladen, zuletzt: )
    • QNAP2.PNG

      (48,63 kB, 5 Mal heruntergeladen, zuletzt: )
    • QNAP3.PNG

      (101,36 kB, 4 Mal heruntergeladen, zuletzt: )
  • Hallo,


    ich habe keine Lösung, aber ähnliches habe ich bei mir auch:


    Ich habe aus Virtual-Box einen Export erstellt mit 3,8 GB, auf der in VS3 wird das Laufwerk aktuell mit 11 GB angezeigt und auf dem Laufwerk dafür insgesamt 20 GB verwendet (USB-Stick auf dem nur diese virtuelle Maschine läuft, den Import habe ich erst vor 1 Woche gemacht, da wird das OS nicht so stark gewachsen sein)

  • wie groß waren die Platten im Server? Die Dateigröße ist ja irrelevant wenn beim Import daraus "thick provision" entstehen. Ich weis allerdings nicht, ob das so ist und/oder einstellbar ist. Nur so meine erste Idee.

  • Hallo Jo,

    siehe Screenshots.

    Im Übrigen hatte ich die TS 677 zuerst mit Raid 5 Thick provision konfiguriert.
    Da kam diese Fehlermeldung auch.
    Danach habe ich erst wie oben genannt konfiguriert.

    Dateien

    • QNAP4.PNG

      (12,47 kB, 5 Mal heruntergeladen, zuletzt: )
  • Der Fehler existiert schon länger, kopiere alle Files für den import auf das NAS, am besten auf die Platten wo später auch die Vm gespeichert ist (wenn genug Platz) jetzt machst du den Import von den Dateien auf dem Qnap Laufwerk und schon geht´s :qclub:


    Ich sehe gerade die Größe der VM Dateien bei dir, du kannst auch ein anderes Laufwerk benutzen es darf nur nicht vom PC aufs Qnap erfolgen dann kommt diese Fehlermeldung. Probiere mal eine USB Platte direkt am QNAP und von dort den Import


    Das 677 hat doch 4 Einschübe, ist der Slot frei oder hast du dort auch eine Platte drin ?

    2 Mal editiert, zuletzt von unos ()

  • Hallo Unos!

    Vielen herzlichen Dank für deine ausführlichen Ausführungen, ganz toll.
    Werde ich ausprobieren, gleich.
    Allerdings hatte ich ganz am Anfang schon alle Files auf der TS 677, als ich dann auf importieren ging, kam auch eine Meldung bzgl. zu knapper Speicherplatz. Das klang für mich einleuchtend, einmal die Files auf der NAS und dann nochmal importiert in das zukünftige VM-Verzeichnis. Dann wäre alles doppelt da.
    Deshalb habe ich alles wieder zurück auf einen PC im Netzwerk kopiert.

    Vielleicht habe ich da auch einen Denkfehler:
    Wenn ich die VM Workstation oder den Player auf einem PC nehme, kann ich ganz normal direkt auf das lokale Verzeichnis mit den Files verweisen, also habe ich die Daten nur genau 1x auf der Festplatte. Mach ich vielleicht beim Importieren in der Virtualisation Station 3 einen Fehler?

    Bis dann,

    vG
    RAY !!


    UPDATE!
    Ich habe nun die ersten beiden SSD-Platten mit jeweils 860 GB zu einem RAID 1 und als THICK- Provisioning konfiguriert.
    Die 3. SSD-Platte mit 860 GB habe ich als einzelnes Laufwerk konfiguriert.
    Auf diese habe ich dann die Files kopiert.

    Als ich dann die Files importieren wollte, kam erwartungsgemäß die Meldung bzgl. zu wenig Speicherplatz. War ja klar, ich hatte nur ca. 870 GB.
    Das System zeigte mir an, das es ca. 1,1 GB an Speicherplatz braucht.


    Darauf hin habe nun die ersten beiden SSD-Platten mit jeweils 860 GB zu einem
    RAID 1 konfiguriert, habe damit 1.7 TB Platz.
    Dann die Überraschung:
    Als ich dann die VM-Files importieren wollte, und zwar in den VM Ordner auf dem DataVol1 mit 1,7 TB Platz, kommt dann die erneut die Meldung bzgl. zu wenig Speicherplatz. Nun behauptet das System es benötigt mindestens 1,96 TB.


    Irgendwas stimmt doch hier nicht...
    Nun werde ich morgen eine externe USB Platte mit 1 TB kaufen und es von dort aus probieren.

    Allerdings habe ich da kein gutes Gefühl, nach den merkwürdigen Dingen heute.


    VG

    RAY !!

    Dateien

    • QNAP6.PNG

      (50,51 kB, 1 Mal heruntergeladen, zuletzt: )
    • QNAP7.PNG

      (79,89 kB, 1 Mal heruntergeladen, zuletzt: )

    Einmal editiert, zuletzt von cibit () aus folgendem Grund: Update!

  • Wollte ich eine VM importieren muss die doppelte Größe an Speicherplatz auf dem Volumen frei sein, kopiere ich von extern (PC) will Qnap den 4fachen Speicherplatz haben.

    Raid 1 ist doch ein Spiegel Raid und die Kapazität wird nicht gedoppelt, meintest du Raid 0 im update ?


    Ich denke wenn du die 3 Platten im Raid 5 erstellst sind 1920GB frei (wenn du sie voll benutzt) und dann von extern also USB Platte direkt am QNAP importierst das es klappt. (kann auch eine zusätzliche interne Platte sein)

    710GB war deine VM insgesamt groß ?

    3 Mal editiert, zuletzt von unos ()

  • Hallo Unos,


    die TS677 ist ja qusi noch jungfräulich, deshalb konnte ich mal ganz schnell immer wieder neue Speicherpools und Volumes einrichten.
    Nun habe ich gerade eben die 3 SSD in einem RAID0 eingerichet, ergibt zusammen 2,48 TB. Ohne Overprovisioning usw.
    Und siehe da, nun ist er am importieren.
    Ja, der uspr. Server ist ca. 710 GB groß.


    Alleine deine Ausführungen oben was den Import von PC oder direkter Festplatte betrifft macht einen schon ungläubig.

    Nun, ich werde mal sehen, wie es läuft und dann eben noch eine SSD einbauen. Für die Snapshot Features bin ich jedenfalls dankbar.

    Aber vielen herzlichen Dank für deine Hinweise!


    Vielen Grüße

    RAY !!

  • Ich hab die gleichen Erfahrungen gemacht als ich eine SSD einbaute um die VM´s auf die SSD auszulagern, damit diese schneller laufen. Ich bekam immer Fehlermeldungen wegen dem Speicherplatz und habe dann länger ausprobiert bis ich den Unterschied bemerkt habe. Warum das so ist kann nur QNAP beantworten, in meinen Augen ist das ein BUG bzw. Berechnungsfehler.


    Schön das es nun klappt :)