"Verbindungsfehler: Der Benutzer besitzt keine Zugriffsrechte für den freigegebenen Ordner" (Windows 10)

  • Liebe QNapper,


    ich nutze in meinem Heimnetzwerk eine TS-813X und hatte bisher nie große Probleme mit dem Gerät - bis heute und zwar mit meinem neuen Laptop auf dem ich Windows 10 installiert habe. Folgendes Problem - Ich habe im Heimnetzwerk 6 Geräte, mit denen ich auf meine QNAP zugreife, alle funktionieren, bis auf den Laptop:

    • Desktop PC (Windows 10 Enterprise, aktuelle Updates, WLAN, SMB) FUNKTIONIERT
    • iPhone XS Max (iOS mit Qfile, aktuelle Updates, WLAN) FUNKTIONIERT
    • iPad 3 Pro (iOS mit Qfile, aktuelle Updates, WLAN) FUNKTIONIERT
    • Raspberry Pi 3 und 3+ (OpenElec mit KODI, aktuelle Updates, WLAN, SMB + NFS) FUNKTIONIERT
    • Laptop (Windows 10 Enterprise, aktuelle Updates, WLAN, SMB) FUNKTIONIERT NICHT

    Mit allen Endgeräten logge ich mich mit den selben Logindaten auf die QNAP, beim Desktop PC habe ich ein Netzlaufwerk eingerichtet und alles arbeitet sauber. Nur der Laptop macht nicht, was er soll.


    Problembeschreibung

    Über den Qfinder Pro 6.6.5 kann ich die QNAP NAS im Netzwerk finden mit der IP 192.168.2.102 und dem Namen DG-NS-QNP. Über den Rechtsklick auf die NAS im Programm kann ich dann folgendes testen:

    • Admin Webseite aufrufen und mich einloggen (über Browser und IP 192.168.2.102, kann da auch mit FILESTATION5 arbeiten) FUNKTIONIERT
    • Im Datei Explorer öffnen (er öffnet \\192.168.2.1\ im Explorer... FUNKTIONIERT
    • ...wenn ich meinen Haupt-Unterordner "DATABASE" öffnen möchte (geht bei allen anderen 3 Geräten), fragt er mich nach einem Username und Passwort (ich trage ein, was ich auch an den anderen 3 Geräten nutze) und bekomme dann als Antwort ZUGRIFF VERWEIGERT und habe dann die Möglichkeit, das Passwort erneut einzugeben. Ich habe es alternativ mit einem anderen User versucht, den ich frisch angelegt habe, ohne Erfolg.
    • Netzlaufwerk verbinden (Es öffnet sich das Fenster "Netzwerkfreigabe wählen" und ich kann dort auch den Ordner "DATABASE" anklicken, im Anschluss fragt mich die Software nach Benutzername und Kennwort, ich gebe diese ein und bekomme als Fehlermelding "ANMELDUNGSFEHLER: Der Benutzer verfügt über keinerlei Zugriffsrechte auf den gemeinsam genutzten Ordner.", was absolut keinen Sinn macht, da ich mit exakt denselben Anmeldedaten über die anderen 3 Endgeräte Vollzugriff habe - exakt wie das auch auf der QNAP eingestellt wurde.

    Was habe ich schon versucht an Problemlösungen?

    Nachdem ich mich durch sämtliche Foren durchgewühlt habe, habe ich folgendes schon getestet um dem Problem Herr zu werden:

    • SMB1 Share über Windows 10 aktivieren KEINE VERBESSERUNG
    • Alle aktuellen Windows 10 Updates installieren KEINE VERBESSERUNG
    • Aktuelle Firmare für QNAP installieren KEINE VERBESSERUNG

    Ich habe hier leider absolut keine Ahnung mehr, was ich noch tun kann und hoffe, dass mir hier jemand weiterhelfen kann, ich bin absolut planlos.


    Vielen Dank für's Lesen und für eure Hilfe,

    Grüße,

    Tormi

  • Prüfe mal, ob Windows auf dem Laptop das Netzwerk zufällig als Öffentliches Netzwerk "erkannt" hat. Dann sind verschärfte Firewall-Regeln aktiv, die solche Effekte bei SMB-Verbindungen auslösen können. Ich hatte dieses Verhalten nach einer Windows 10 Pro Neuinstallation und konnte Windows nur per Power Shell zum Umdenken bewegen.

  • Was steht im Ereignislog vom NAS und was im Log vom Laptop.


    In der Systemstuerung schon bei den gespeicherten Netzwerkanmeldeinfos nachgesehen, was gespeichert wurde?

  • Ich hatte als erstes auf ein IP-Block gesetzt aber dem widerspricht, dass du dich per GUI einloggen kannst.


    Könnte es eventuell der Bitdefender sein? Der hat in letzter Zeit öfter mal für zwischenfälle gesorgt.

    Nutzt du eine seperate Firewall oder eine Antivirenlösung mit integrierter Firewall?

  • Danke für euer Feedback, folgendes kann ich dazu anmerken:

    • Das Netzwerkprofil ist auf PRIVAT gestellt, daran kanns also nicht liegen
    • Ich habe keine zusätzliche Antivirus Software aktiv, es läuft nur der Windows Defender und den habe ich zusätzlich mal komplett DEAKTIVIERT, keine Veränderung.

    Crazyhorse - Wo kann ich das Ereignislog vom Laptop und wo das Ereignislog von der NAS hierzu einsehen um genaue Insights auszulesen? Und wo genau kann ich die Netzwerkanmeldeinfos nachsehen? (bzw. was genau kann mir das bringen?)

  • Also die Anmelde-Logs für SMB auf dem NAS kannst du über die Systemprotokolle anzeigen lassen, SMB muss aber erst aktiviert werden:

  • Bei Windows ist das, glaube ich, die Ereignisanzeige.

  • Also ich kann mittlerweile Feedback zum Problem geben - wobei das sehr verwirrend ist.


    Bei der Freigabe für's Netzwerk in der Ordnerfreigabe habe ich die IPs meiner Rechner und Geräte im Netzwerk angegeben, die auf die freigegebenen Ordner zugreifen dürfen, darunter auch der Laptop - bei allen habe ich eine feste IP vergeben, alle sind ja draufgekommen, nur der Laptop nicht.


    Nachdem ich die Zuweisung der erlaubten IPs komplett gelöscht habe (also in der Liste war nichts mehr wohlgemerkt) konnte ich mit dem Laptop auch wieder zugreifen.


    Ergibt für mich absolut keinen Sinn - aber okay, es geht, ich hab's akzeptiert :P Vielleicht hilft die Info jemand anders weiter, euch allen vielen Dank fürs Lesen und Unterstützen!

  • Ok... Naja, an sowas hab ich überhaupt nicht gedacht, weil ich irgendwie auch nicht auf die Idee kommen würde, das IP basiert zu machen und nicht einfach auf User Ebene... Zumindest nicht zu Hause.


    Im RZ kann sowas Sinn machen, da segmentiert man Heut zu Tage aber auch...


    Also: Setting einfach aus schalten und per User / PW authen, das reicht doch vollkommen aus...