RAID1 mit 2 SSD Volumegröße

  • Moin zusammen,

    ich steh gerade etwas auf dem Schlauch.

    Ich hab in meinem neuen TVS-882 2x M2.SSD als "System" eingebaut. Wegen SSD hatte ich geplant ein statisches Volume zu nutzen.

    Die Platten, 2x 860EVO mit 250GB und angezeigter Kapazität von 232,89GB sollten dabei, nach dem SSD Overprovisioning, etwa 190GB dabei hergeben.

    Da beim Speicherpool gute 10GB mehr rausgekommen sind, habe ich diesen gewählt, aber egal ob beim Thick- oder beim Thin-Volume, wenn ich dieses auf die max. Kapazität des Speicherpools stellen will, bekomme ich nur gute 130GB zugewiesen.

    Wenn ich es einfach mit der mir bekannten Kapazität überschreibe, bekomme ich über die physikalische Kapazität abonnierten Platz angezeigt.

    Aber 2x ca. 230GB Platten im RAID 1 sollten doch auch die 230GB ergeben. OK, die 10% vom SSD Overprovisioning noch abziehen. Aber gute 200GB sollten doch am Ende zur Verfügung stehen, oder wo ist gerade mein Denkfehler?

  • Du vergisst die QTS Partitionen die auch drauf angelegt werden und einen gewissen Teil belegen.

    Das ist der Speicherplatz der dir fehlt.

  • Du vergisst die QTS Partitionen

    Ja, OK. Auch wenn es 230GB für das System wären...

    Aber was ist mit meinem 2. Pool.

    Da sind in den 2,5"-Slots ebenso 2 SSD's verbaut.

    240er OCZ Trion, ebenso RAID1 und ohne System drauf. Nur rein um virtuelle Maschinen drauf laufen zu lassen.

    Und da ist es das selbe Spiel.

    In meinem 3. Pool, wo die ganzen Spindeln drin sind mit einem RAID5 passt das Ganze...

    Nur eben nicht bei dem RAID1-Pools...

  • QTS legt auf jeder HD aktuell 5 Partitionen an.

    Auch auf deinen normalen HDs. Aber da fällt mir es aufgrund der Größe nicht so stark auf.

  • Das mit den Partitionen hatte ich auch schon mal bei einer ausgebauten gesehen.

    Aber 230GB?

    Da ist man ja gezwungen gleich auf 500GB zu gehen wenn man netto gute 250GB haben möchte...

    Finde ich ganz schön happig.

    Zumal ja bei meinen 2,5"er Platten gar nichts weiter drauf ist...

    230GB für Nix?

  • Und das auf jedem Pool? Beim Systempool würde ich es ja noch zähneknirschend verstehen.

    Was macht man dann wenn man 2x 128er Platten nutzt?

    Dann ist da ja beim RAID1 viel zu wenig Platz, wenn ich das mit meinem 230er RAID1 vergleiche.

    2x 128GB ergibt 128GB, System braucht aber 240GB auf egal was für einer Platte?

  • Das wird auch von der Größe der HD abhängen die verbaut ist, aber es wird auch ein Mindestwert geben, den es sich immer reserviert.

    Den genauen Wert kann ich dir aber nicht verraten.

    Die 211GB beziehen sich bei mir auf einen Pool von 7.62TB, wenn ich mich verrechnet haben sind das bei mir nicht mal 3%.

  • Aber gute 200GB sollten doch am Ende zur Verfügung stehen,

    Denke ich auch …


    So sieht das bei meinem TVS-882 aus:


    Gute 217GB sind bei mir verfügbar, außer dem System ist nichts drauf.


    Eingerichtet ist es auch als statisches Volumen, wobei ich mich nicht erinnern kann, dass ich "overprovisioning" zur Auswahl hatte. Keine Ahnung ob das jetzt dabei ist, das sehe ich jetzt nicht mehr im Speichermanager.

  • Gute 217GB sind bei mir verfügbar, außer dem System ist nichts drauf

    So hätte ich es auch erwartet.

    Schön, Du hast genau die selben EVO's wie ich.

    Aber halt als statisches Volume...

    Das Overprovisioning sollte eigentlich lt. Ergebnis des Tests gerade mal so 10% etwa schlucken.

    Warum schluckt dann der Pool so viel?

    Ich wollte nicht unbedingt meine Systemplatte wieder platt machen müssen.

    OK, ich könnte die anderen Pools sicher entfernen und dann wieder hinzufügen.

    Aber der ganze Aufbau hat schon doch relativ viel Zeit geschluckt.

    Aber so wie es bei Dir, RedDiabolo ist, hatte ich gehofft hinzukommen...

  • Wenn du nur das System drauf hast ist ja ein Neuaufsetzen des Volumens + System nicht wirklich der Aufwand. 2x Reboot + Installation, sagen wir mal 20 - 30 min … Außer du hast echt viele Apps am Laufen :ziped:


    Ich würde es versuchen, zumal es dich offensichtlich "belastet" ;-)

    Einfach alle Platten raus (außer M.2), Config sichern, reboot und RIAD/Volumen neu einrichten, das System kommt ohnehin wieder drauf, da kein anderes Volumen vorhanden ist …


    Overprovisioning ist so eine Sache. Da SSD per se die Daten nie löschen, sondern nur überschreiben können, wurde es implementiert um immer einen freien Platz zu haben … der geht dir jetzt ab.


    Denke ein wöchentliches TRIM, das du im Speichermanager einfach einstellen kannst, bringt genau so viel (außer du schaffst es, deine SSD innerhalb kürzerer Zeit komplett voll zu bekommen, da auch die gelöschten Blöcke bis zum TRIM belegt bleiben).


    Ich bin immer mit der Faustregel gut gefahren, SSD's nie über 3/4 zu belegen, dann wird es nämlich eng, wenn der TRIM nicht läuft und "gelöschte" Blöcke frei gibt. Wenn bei mir eine SSD über 50% belegt ist, denke ich über eine größere nach.

  • Einfach alle Platten raus (außer M.2)

    Alle einfach Raus? Dann meckert er doch rum das ihm seine Pools abhanden gekommen sind.

    Einfach ignorieren?

    Die sichere Variante war ja das mit dem Sicher trennen...

    Und Du meinst das klappt? Außer Rumgepöbel von der lieben Stimme?

  • Alles raus, ja. Aber zuerst das NAS runterfahren!

    Sicher trennen habe ich nie gemacht, kann aber auch nicht schaden ;-)


    Nachdem das Systemvolumen neu eingerichtet ist, machst du wieder einen Neustart, lässt dir etwas zeit (falls QTS aktualisiert werden will, etc...) und fährst dann nochmals runter.


    Alle Platten wieder rein (gleiche Reihenfolge, versteht sich!) und NAS wieder hochfahren.

    Entweder sie werden automatisch eingebunden, oder wenn nicht, dann im Speichermanager auf [Suchen] und dann werden sie dir wieder angebunden.


    Config wieder einspielen und eventuell noch fehlende APPS neu installieren ...

  • @RedDiabolo

    Ich hatte mich nun schon gewagt, ging wirklich easy.

    Aber ich denke jetzt dem Problem auf den Grund gekommen zu sein.

    Ich bin drauf gekommen, weil ich gerade mein RAID5 mit einer größeren Platte versehen hatte, eine alte hatte mir defekte Sektoren angezeigt, die ich nun ersetzen wollte.

    Und dabei musste ich dann natürlich die Kapazität des Pools erweitern. Ging auch völlig problemlos.

    Jetzt habe ich meine anderen beiden SSD's, also nicht das System, zum statischen Laufwerk, (ohne Overprovisioning ;)) gemacht, dann nochmals erneut in ein Pool gebracht und siehe da:

    Hier

    bekomme ich keine Kapazitätserweiterung angeboten:

    Ist doch ein Widerspruch in sich, hier sagt er die Kapazität ist voll ausgeschöpft und hier:

    sagt er das wenn ich das Volume erweitern möchte, der Pool nicht mehr hergäbe...

    @RedDiabolo wichtig... ;), nicht so, aber ich versuche alles sauber aufzuziehen.

    Und mit den beiden Platten die Pool2 abbilden sollen kann ich nun ein wenig versuchen Erkenntnisse zu erlangen... :handbuch: