Hilferuf: RAID 5 im herabgesetzten Modus nach Plattentausch und I/O-Error auf zweiter Platte während der Synchronisation

  • Hallo Leute,
    ich habe folgendes Problem bei meinem aus vier identischen Platten a 3 TB bestehenden RAID 5 auf einem TS 412:
    * Platte zwei meldete einen Fehler und sollte getauscht werden
    * Platte getauscht, Synchronisation / Rebuild hat begonnen
    * I/O-Error auf Platte 4 während der Synchronisation / des Rebuilds nach x Stunden (oder gar Tagen)
    * RAID geht in den herabgesetzten Modus / schreibgeschützt (siehe Screenshot)
    * in der logischen Datenträgerinformation taucht Platte 2 (noch) nicht auf => "RAID 5-Datenträger: Laufwerk 1 3 4" (vgl. Screenshot)

    * in der RAID-Verwaltung kann keine "Aktion" ausgewählt werden (ausgegraut)
    * in der (logischen) Datenträgerverwaltung kann ich das RAID nur entfernen

    * wenn ich Platte 4 durch eine neue ersetze wird das RAID gar nicht mehr erkannt (vermutlich wegen noch fehlendem Laufwerk 2 [s.o.] und zusätzlich neuem Laufwerk 4)


    Wie komme ich aus dieser Patsituation heraus?

    Wie kann ich (evtl. auf Betriebssystemebene) dem RAID mitteilen, dass das Laufwerk 2 Bestandteil seiner Konfiguration ist bzw. die Synchronisation / den Rebuild zum Weitermachen bewegen?

    Ich habe das Gefühl, die GUI bietet hier nur eingeschränkte Möglichkeiten (Buttons) bzw. ist für diesen Fall nicht ausgelegt.

    Gerne kann ich zusätzliche Informationen liefern, sofern hilfreich oder erforderlich.


    Wer kann mir helfen? Bin um jeden konstruktiven Ratschlag dankbar!

    (Bitte keine Belehrungen bzgl. nicht-NAS-tauglicher Festplatten oder was man im Vorfeld ggf. hätte besser machen können. Alle relevanten Daten habe ich prinzipiell als Backup. Aktuell kann via FTP auch noch lesend auf das RAID zugegriffen werden. Alle Daten herunterzuziehen, das RAID neu aufzusetzen und anschließen wieder zurück zu spielen wäre die letzte aller Optionen, da dieser Vorgang bei knapp sechs TB Wochen dauern würde.)


    Einmal editiert, zuletzt von BMW-Fuzzi ()

  • Im Raid 5 Verbund darf eine (!) Platte ausfallen.

    In diesem Fall ist das deine Platte im Slot 2. D.h. du kannst Platte 4 nicht tauschen ohne deine zu zerstören.


    Ich sehe keine andere Möglichkeit als ganz fix ein aktuelles Backup zu ziehen und je nach alter der Platten 3 neue kaufen und das Raid neu aufzusetzen. Und 6 TB dauert höchsten 3 Tage :) Ohne Sync des neuen Raids. :)

  • Dir ist also ganz klassisch das passiert, was bei Raid 5 zum Problem werden kann und daher zigfach im Internet beschrieben ist: es darf nur eine Platte ausfallen, das kann kompensiert bzw. wiederhergestellt werden. Die Belastung und Wärmeentwicklung der verbliebenen Platten kann während des Rebuildvorgangs aber so hoch sein bzw. werden, das auch eine weitere Platte sich mittendrin verabschiedet. Und das wars dann.

    Ja ich weiß, das das nun hart klingt und dir womöglich sogar gefühlskalt dir gegenüber vorkommt, es ist aber nicht so gemeint, einfach nur Fakt. Denn ohne das per dem Rebuild 'alle' für den Betrieb dieser Art Raidverbund notwendige Daten auf deine Platte 2 aufgespielt wurden, kannst du deiner NAS nunmal nicht 'sagen' bzw befehlen, diese Platte gefälligst voll zu akzeptieren und zu nutzen. Deine frisch eingebaute Platte 2 ist allem Anschein nach noch keine deinen Raid 5 mittragende Säule geworden - per abgeschlossen wordenem Rebuild. Deswegen zeigt sie deine NAS auch nicht bzw. NOCH nicht an.

    Wenn du also schreibst, das dir bei FTP Daten angezeigt werden, dann könnten das entweder Fakedaten sein, die nur im Verzeichnisbaum als Namen bzw vom Rebuild schon mit Beschlag belegtem Platz vorhanden sind, aber nicht echt und vor allem fehlerfrei sind. Oder es sind Daten, die echt sind, weil der Rebuildvorgang vor seinem Absturz eben noch bis dahin gekommen ist..

    Im Grunde hast du nun also sozusagen 2,5 nutzbare Platteninhalte, bräuchtest aber 3,0, damit ein Rebuild machbar / überhaupt startbar ist.

    Womöglich hast du aber auch Glück, und jene Platte 4 wurde durch den Rebuildvorgang einfach nur zu warm und ist deswegen mit I/O Fehler ausgestiegen. Nach Abkühlung die Nas neu starten könnte das kleine Wunder bewirken, das ein neuer Rebuildvorgang gestartet wird und du nochmal mit nem blauen Auge (und derweil hoffentlich auf max eingestelltem Kühlventilator) davon kommst. Die Chance, das sie wirklich hin ist, ist aber genauso groß.

    Und selbst wenn du auf die Art dein Raid 5 doch gerettet kriegst, gilt genau das, was Jagi schreibt: intensiv über Austausch der 3 älteren Platten nachdenken, am ehesten bzw. als erstes jene Nr. 4 ;-)


    P. S. : ich ging bei obigem davon aus, das jene ersetzte Platte 2 in der Kompatibilitäts Listung für deine NAS eingetragen ist.

    3 Mal editiert, zuletzt von DerTigga ()