Rsnapshot Fehlermeldungen

  • Hallo zusammen,


    ich habe ein QNAP TS-251 + mit 2GB Ram. Außerdem habe ich auf einer Virtellen Maschine unter HyperV(Win 10) ein Ubuntu 18.04 installiert. Hierauf läuft Nextcloud.


    Ich würde gerne die Daten von der Nextcloud auf das QNAP NAS sichern. Hierzu möchte ich rsnapshot verwenden, weil ich damit jederzeit den Dateistand vor 3 Tagen z.B. wieder herstellen kann (oder per Samba Freigabe direkt drauf zugreifen).


    Ich habe jetzt über Entware rsnapshot als Packet installiert und soweit eingerichtet. Eine Sicherung der Lokalen Daten funktioniert soweit ganz gut. Wenn ich allerdings per SSH auf die Nextcloud/Ubuntu zugreifen möchte, gibt es eine Fehlermeldung:

    Code
    1. [2018-11-07T17:56:33] /opt/bin/rsync -av --delete --numeric-ids --relative --delete-excluded --exclude=/opt/var/run/* --exclude=/tmp/var/run/* --exclude=/opt/var/lock/* --exclude=/tmp/var/lock/* --exclude=/tmp/*.script --exclude=/tmp/ppp/* --rsh=/usr/bin/ssh -o user@192.168.178.23:/mnt/ncdata/Quartz/files/ /share/Andreas/98_Nextcloud_Backup/daily.0/data/
    2. [2018-11-07T17:56:33] command-line: line 0: Bad configuration option: -l
    3. [2018-11-07T17:56:33] rsync: connection unexpectedly closed (0 bytes received so far) [Receiver]
    4. [2018-11-07T17:56:33] rsync error: unexplained error (code 255) at io.c(226) [Receiver=3.1.2]
    5. [2018-11-07T17:56:33] /opt/bin/rsnapshot daily: ERROR: /opt/bin/rsync returned 255 while processing user@192.168.178.23:/mnt/ncdata/Quartz/files/
    6. [2018-11-07T17:56:33] touch /share/Andreas/98_Nextcloud_Backup/daily.0/
    7. [2018-11-07T17:56:33] rm -f /opt/var/run/rsnapshot.pid
    8. [2018-11-07T17:56:33] /opt/bin/rsnapshot daily: ERROR: /opt/bin/rsnapshot daily: completed, but with some errors

    Wenn ich das richtig verstanden habe, hat er Probleme beim ausführen des Befehls rsync, wie er in der ersten Zeile steht.

    Wenn ich diesen Befehl so wie er da steht manuell ausführe, funktioniert alles ohne Fehlermeldungen.

    Ein SSH Zertifikat habe ich erfolgreich eingerichtet.


    Ich bin jetzt nicht so der Profi, kann mir wer hierzu mehr sagen ?


    Vielen Dank,


    Andi


    Im Anhang die Config:

    Dateien

    • rsnapshot.txt

      (8,51 kB, 4 Mal heruntergeladen, zuletzt: )
  • Hallo dr_mike,


    soweit ich das gesehen habe kann ich mit diesem rsnap keine Daten die ich über eine ssh verbindung hole sichern.


    Das komplette Logfile im Anhang. (Auszüge daraus im 1. Post)

  • Wenn du

    Code
    1. /opt/bin/rsync -av --delete --numeric-ids --relative --delete-excluded --exclude=/opt/var/run/* --exclude=/tmp/var/run/* --exclude=/opt/var/lock/* --exclude=/tmp/var/lock/* --exclude=/tmp/*.script --exclude=/tmp/ppp/* --rsh=/usr/bin/ssh -o user@192.168.178.23:/mnt/ncdata/Quartz/files/ /share/Andreas/98_Nextcloud_Backup/daily.0/data/

    eingibst, kommt keine Fehlermeldung?

    soweit ich das gesehen habe kann ich mit diesem rsnap keine Daten die ich über eine ssh verbindung hole sichern.

    Mit einem kleinen "Vorherskript" geht das.

    Einmal editiert, zuletzt von frosch2 ()

  • Nein, wenn ich den Befehl eingebe kommt keine Fehlermeldung. Woran kann das liegen ?

    Mit einem kleinen "Vorherskript" geht das.

    Ok, ich müsste dann die Dateien z.b. per Samba freigeben, und im QNAP mounten oder ? Gibts da einen eleganteren weg ? Das ist erstmal Plan B

  • Ok, dann gibt es einen User "user" auf dem remote host?

    Warum exkludierst du Dateien, die im Sicherungspfad nicht vorkommen?


    zu rsnap

    Wie der entfernte Rechner kontaktiert wird kann man selbst entscheiden smb, nfs, ssh, kommt darauf an was man möchte bzw., was notwendig ist.

  • Den User "user" gibt es, ja. Die Verbindung klappt auch wenn ich den Befehl manuell eingebe.

    Das excludieren stammt noch aus der Musterconfig, habe ich jetzt auskommentiert, Keine Veränderung


    Noch etwas: Wenn ich den Befehl manuell eingebe, finde ich in der auth.log datei auf dem remote host entsprechende Einträge. Läuft hingegen das Script durch, gibt es keinen einzigen Eintrag, sprich, eine ssh Verbindung wird erst gar nicht aufgebaut.


    rsnap: Ich habe leider nichts gefunden wie ich das per ssh hinbekomme. In der GUI finde ich keinerlei einstellungen, und auch sonst hat das scheinbar noch niemand gemacht. Kannst du mir da bitte etwas auf die Sprünge helfen ?

    Einmal editiert, zuletzt von quartz234 ()

  • Vielen Dank, ich habe allerdings die Lösung per rsnapshot (ohne GUI) noch nicht ganz aufgegeben. Fällt dir dazu noch was ein ?

  • Code
    1. [~] # /usr/bin/ssh -o user@192.168.178.23
    2. command-line: line 0: Bad configuration option: user@192.168.178.23


    Gibt auch eine Fehlermeldung. Kommt mir komisch vor...


    Wenn ich eingebe:

    Code
    1. /usr/bin/ssh user@192.168.178.23

    also ohne -o kommt eine Verbindung zustande und ich sehe eine Konsole des Entfernten Rechners

  • Die Zeile ssh_args in der rsnapshot.conf ändern auf ssh_args                /home/httpd/.ssh/key_rsa

  • Ich habe eine Lösung gefunden:


    Warum auch immer (stammt wohl aus einem anderen Beispiel), stand in meiner rsnapshot.conf noch folgende Zeile:

    Code
    1. # ssh has no args passed by default, but you can specify some here.
    2. #
    3. ssh_args -o BatchMode=yes -i /home/httpd/.ssh/key_rsa

    Das habe ich jetzt auskommentiert, und schon funktioniert alles.


    -i ist wohl dafür das er die Schlüsseldatei findet. Aber die findet er wohl automatisch...


    -o Batchmode braucht man scheinbar auch nicht.

    Ich war wieder zu langsam (oder zu schnell ;) )


    Wenn ich es so mache wie du geschrieben hast kommt wieder folgende Fehlermeldung:

    Code
    1. /opt/bin/rsync -av --delete --numeric-ids --relative --delete-excluded \
    2. --rsh=/usr/bin/ssh /home/httpd/.ssh/key_rsa \
    3. user@192.168.178.23:/mnt/ncdata/Quartz/files/ \
    4. /share/Andreas/98_Nextcloud_Backup/daily.0/data/
    5. ssh: Could not resolve hostname /home/httpd/.ssh/key_rsa: Name or service not known

    Kann ich die Argumente auch einfach weg lassen ? Oder geht das dann z.b. nach einem Neustart nicht mehr ?

  • Ok, funktioniert auch nach einem Neustart noch. Manuell funktioniert nun rsnapshot schon ziemlich gut.


    Ich habe nun unter /etc/config/crontab folgende Zeile eingefügt:

    Code
    1. 22 00 * * * /opt/bin/rsnapshot daily

    anschliesend 2 Befehle eingegeben:

    Code
    1. crontab /etc/config/crontab
    2. /etc/init.d/crond.sh restart

    die Zeit ist lange vorbei, aber der Befehl wird nicht ausgeführt. Was mache ich falsch ?

  • Der Klassiker, in meinem NAS geht die Uhr scheinbar eine Stunde vor. Es funktioniert jetzt alles. Vielen Dank frosch 2 für deine Hilfe !