Erstmaliger Versuch mit der Linux-Station - klappt nicht

  • Hallo zusammen,


    ich besitze ja mein TS-453B-16G mit der Linuxstation noch nicht all zu lange. Bisher konnte ich mich wegen wichtigerer Sachen wie z. B. RAID, Backup, Netzwerk u.s.w. noch nicht wirklich mit der Linuxstation beschäftigen. Heute aber der erste Versuch.

    Linuxstation aktiviert, Ubuntu 16.4 installiert und danach angemeldet...User ist Admin und das Passwort ist meines, das ich auch für die Anmeldung am NAS nutze.


    Nun ist es so, dass die Oberfläche von Linux erscheint, der Desktop, auf dem sich schon ein paar Ordner und Programmsymbole befinden. Ich kann die nur nicht auswählen...egal was ich mache...die Mouse bewegt sich zwar, aber ich vermute, dass das der Zeiger der Mouse in der QTS-Oberfläche ist, aber nicht von Linux. Fehlt da noch ein Treiber? Wie bekomme ich den als absoluter Linux-Neuling installiert und die Mouse in Betrieb genommen?

    Was funktioniert ist die Tastatur, bzw. beide Tastaturen. Mit der kann ich mittels Tab-Taste in die Auswahlfelder springen und mit Enter auswählen. So bekomme ich z. B. die Farge weggeklickt, ob ich auf Ubuntu 18.x upgraden möchte. Die INstallation hatte ich auch gemacht und nach ca 1 Std wurde angezeigt, dass das System (weiß nicht was gemeint ist...NAS oder Linuxstation?!?) neu starten würde. Das ging aber irgendwie in die Endlosschleife und nur hin und wieder flackerten die Programmsymbole ganz kurz auf. Ich habe dann das NAS neu gestartet und in der Linuxstation wurde weiterhin Ubuntu 16.4 angezeigt, ließ sich aber nicht mehr starten.

    Also habe ich in der Linuxstation Ubuntu nochmal neu installiert, was einem Downgrade auf 16.4 bedeutet. Nun sitze ich hier mit Ubuntu 16.4 aber kann keine Mouse einsetzen, nichts auswählen und nichts anklicken. Was muß ich machen?


    Meine Mouse: Logitech, G502, mit USB an NAS angeschlossen

    Meine Tastatur: DELL, SK-8115 (mindestens 15 Jahre alt, aber ein hammer-robustes und ergonomisches Teil!!); mit USB an NAS angeschlossen

    Zweite Tastatur: Logitech K830, mit Bluetooth an meinen Windos10-Laptop angesachlossen. Ich kann aber mit beiden Tastaturen das Passwort und den Benutzer in Ubuntu eingeben...


    Und gerade fällt mir noch was auf...der Tab, in meinem Firefox, in dem die Linuxstation läuft, zeigt oben als Namen "hybrid-novnc" an. No VNC? Schon mal gehört, das VNC, aber was das wirklich ist weiß ich nicht. Und wenn da noch was fehlen sollte, dann weiß ich als Linuxanfänger auch nicht wie ich vorgehen müsste.


    Kann sich jemand erbarmen und mir bitte helfen? Vielen Dank! Ich würde so gerne mal Linux ausprobieren und das am besten auf dem NAS.


    VG, Ingo

  • Hallo Ingo,


    warum bei dir die Maus nicht geht kann ich dir nicht sagen, ich hatte nie Probleme damit. Bei mir nutze ich die LinuxStation entweder über VNC bzw. direkt über HDMI. Falls dir VNC nichts sagt, das ist sowas wie Remote Desktop (Google hilft). Im Falle von VNC kannst du die Maus des Remotegerätes verwenden. Und wenn ich mich direkt über HDMI verbinde (Fernsehr), da habe ich am Nas eine Tastaur mit Touchpad dran (Kabelos). Das ging bei mir auch ohne Probleme oder speziellen Treiber.

    Bzgl. der Linuxversion ist ein Upgrade ncht möglich, da die LinuxStation den Kernel des Nas verwendet. Also solange nicht selber vom Nas eine andere Version angeboten wird bist du an die 16.04 gebunden.

    Du könntest mal versuchen mit der Konsole (Terminal) die Updates einzuspielen und vielleicht ist dann schon das Problem behoben:


    Code
    1. sudo apt-get update
    2. sudo apt-get dist-upgrade


    Grüße

    Frank

  • Hallo Frank,


    vielen Dank für Deine Antwort. Wie gesagt---ich bin totaler Anfänger was Linux angeht. Meine einzige Erfahrung damit ist die QTS-Oberfläche und ein vor ca 2 Jahren gescheiterter Versuch Linux Mint auf meinem Ultrabook im Dualboot Modus zu installieren.


    Außerdem habe ich keine Erfahrung mit VNC. Kenne aus der Arbeit nur ein Logo "VNC" im Infobereich meines Windows Rechners neben der Uhr. Aber wenn ich Dich jetzt richtig verstehe, dann muß ich mir wohl auf mein Ultrabook einen VNC Client installieren? (welchen? Hast Du Empfehlungen?).

    Eine HDMI-Anbindung an das TV oder einen Monitor möchte ich nicht. Monitor habe ich keinen und das NAS steht zu weit weg vom TV.


    Habe ich aber richtig verstanden, dass die Containerstation und die Virtualisierungsstation nichts mit der Linux-Station zu tun haben und ich da auch nichts anrühren muß? Die VS geht m.W. sowieso nicht sobald die Linuxstation verwendet wird...glaube ich mal gelesen zu haben.


    Und noch eine Frage zu Deiner Antwort mit der Konsole und den Updates: Meinst Du die Konsole von QTS oder die von Ubuntu 16.04? Auf die bei Ubuntu komme ich ja nicht ran...was ja mein eigentliches Problem ist...die Bedienung der Ubuntu-Oberfläche mit der Maus.


    Übrigens...das Ubuntu 18.xx wurde mir als Upgrade von 16.0.4 in der Ubuntu-Oberfläche der Linuxstation angeboten sobald ich sie geöffnet hatte. Anhand der TAB- und Enter-Tasten konnte ich das Upgrade starten. Da ja das Keybord funktioniert (eiegentlich beide...am Laptop per BT nd am NAS per USB) gehe ich davon aus, das es sich u. U. nur um ein Treiberproblem für die Mouse handeln könnte. Wie könnte ich das als Linux-Laie beheben?

  • Aber wenn ich Dich jetzt richtig verstehe, dann muß ich mir wohl auf mein Ultrabook einen VNC Client installieren?

    Ja, genau das meine ich damit. Ich nutze den Vnc Viewer von RealVNC du kannst aber auch einen beliebig anderen nehmen. Ich hatte auch mal eine zeitlang den UltraVnc Viewer genutzt.

    Hab e ch aber richtig verstanden, dass die Containerstation und die Virtualisierungsstation nichts mit der Linux-Station zu tun haben und ich da auch nichts anrühren muß?

    Also die ContainerStation wird für die LinuxStation benötigt aber du musst sie nicht direkt konfigurieren. Die VS läuft völlig unabhängig von von der LS. Da kannst du auch ein komlpett beliebiges System drauf laufen lassen (z.B. Ubuntu 18.04, Windows 3.11). Die VS kann auch parallel zur LS laufen und verwendet werden.

    Meinst Du die Konsole von QTS oder die von Ubuntu 16.04?

    Ich meine die Konsole von LS Ubuntu 16.04. evtl. kommst du auch nur mit der Tastatur hin. Mit Strg+Alt+T kann man auch den Terminal öffnen. (Habe ich eben mal schnell gegoogelt)


    Das angebotene Upgrade ignorieren bzw. abbrechen.

  • Hey, wollte Deine Tipps mit der Konsole und den Updates gerade ausprobieren....und erstaunlicher Weise funktioniert plötzlich die Tastatur auch für die Icons auf dem Dersktop und in der Sidebar (keine Ahnung wie die in Linux heißt). Und mit Deiner Tastenkombination für di eKonsole konnt eich gerade auch das Update (erster Befehl) durchführen. Hat zwar etwas gedauert bis ich auf meriner deutschen Tastatur den Bindestrich gefunden hatte, aber es hat geklappt. UNd den zweiten Befehl werde ich nach Beendigung des ersten Updates durchführen.


    Den VNC-Server installiere ich dann dort in der Linux-Oberfläche? Oder doch unter QTS? Sorry wenn ich Deine Nerven so strapaziere...aber kannst Du mir den Befehl dafür auch mal schicken? Ist wahrschein irgendwas mit sudo apt-get realvnc ...oder so ähnlich?


    Hab die Updates jetz anhand Deiner o.g. Befehle über das Terminal installiert....aber die Mouse funktioniert immer noch nicht? Ich kann auch irgendwie nicht auf die Systemsteuerung zugreifen weil ich mit der TAB-Taste lediglich auf dem Desktop zwischen den Icons navigieren kann, abe rnicht in der Leiste links (wird wohl die Taskleiste wie bei Windows sein.)

    Unter google hab eich leide rnihcts gefunden wie ich die Treiber manuell nachinstallieren kann...trotz meiner Navigationsprobleme.

    hab es geschafft...Windows-Taste entspricht der Super-Taste.

    Hiermit installier eich gerade Sprachpakete und stelle alles auf Deutsch um. Danach werd eich mal schauen, ob s unnter dem Suchbegriff Mouse und keyboard auch automatisch angebotenen Treiberpakete gibt.

  • Den VNC-Server installiere ich dann dort in der Linux-Oberfläche?

    Du brauchst keinen VNC Server zu installieren. Es reicht unter der LS den Remote Desktop zu aktivieren. Dann kannst du mit einem VNC Client (z.B von dein Windowslaptop) auf die LS zugreifen. Dort musst du nur die Ubuntu IP Adresse angeben und den Port. Bei mir sieht das so aus:

    IP::5900. Die 5900 ist ein Standardport für den Remotedesktop.

  • Danke Dir. Das habe ich inzwischen hin bekommen.

    Ich kämpfe gerade mit einem anderen Problem. Die Mouse (Logitech G502) ist über USB am NAS angeschlossen. HAbe auch schon verschiedene USB-Ports ausprobiert. Nun gehe ich per Remoteverbindung auf die Linuxstation ins Ubuntu. Dort kann ich die Mouse aber nicht benutzen weil ich den Mousezeiger nicht sehe. Ich sehe lediglich den der Windows-Instanz, aber der bringt mir nichts.

    Als zusätzliche Treiber und Updates findet Ubuntu nichts. Die Updates habe ich alle heute Nachmittag gemacht wie weiter oben beschrieben.

    Am Windows-Laptop habe ich eine Logiotech MX-518 am USB hängen. Habe die beiden auch mal getaiuscht, aber der Mousezeiger in der Linuxbox erscheint einfach nicht.


    Die Mouse funktioniert aber. Wenn ich über manche Symbole oder Schaltflächen schwebe, dann werden die hervorgehoben und beim Klicken auch aktiviert. Es ist nur verdammt schwer genau zu treffen, weil ja der Zeiger nicht zu sehen ist. UNd obwohl ich in den Einstellungen die Geschwindigkeit auf ganz langsam gestellt habe scheint sie mir immer noch sehr schnell zu sein...zu schnell.


    Ich habe das System inzwischen auf Deutsch umgestellt und habe mir dabei mit den Tasten beholfen...aber das war eine ganz schöne Frickelei, da ich außer die Windows Shortcuts keine Tastur zum Steuern verwende.


    Auf der Seite https://itsfoss.com/invisible-mouse-cursor-ubuntu-1310/ habe ich bereits eine angebliche Lösung gefunden. Die hat mein Problem aber nicht behoben.


    Kann nochmal jemand bitte helfen? Ich komme seit Stunden nicht weiter. Danke.

  • ...so richtig viel fällt mir nicht mehr zu deinem Problem ein. Im Normalfall ist es beim Remote Desktop so das die Maus vom Gastsystem in das Remotesystem kopiert wird, d.h. die Maus von deinem Windows 10 Laptop sollte sich im Remotesystem bewegen. Wenn die Übertragung schlecht ist oder schnelle Veränderungen auf dem Bildschirm stattfinden solltest du 2 Verschiedene Mauszeiger sehen. Bei mir ist es ein kleines schwarzes Quadrat mit einem weißen Rand (Zeiger vom Gastsystem) und der Linuxpfeil (Standard Mauspfeil von dem Remotesystem). Bei langsamen Bewegungen sollte sich die Maus vom Gastsystem an der Zeigerspitze vom Remotesystem befinden und bei schnellen Mausbewegungen hingt die Maus von dem Remotesystem dem Gastsystem etwas hinterher.

    Vielleicht solltest du mal am Nas keine Maus anschließen und nur die Maus vom Remotesystem verwenden (evtl. ContainerStation und LS löschen und neu installieren).