5.1 surround - Pulseaudio deaktivieren

  • hallo zusammen.


    Ich versuche auf meinem 253pro 5.1 audio über HDMI auszugeben.


    Ich habe versucht pulseaudio zu deaktivieren wie beschrieben. Doch nach dem reboot sind die anpassungen im config-file von pulseaudio einfach wieder resetted.



    Könnt ihr mir evtl einen anderen weg zeigen wie ich 5.1 aktivieren kann?


    Oder weiss jemand wie ich den "reset" unterbinde?


    Besten dank fuer die hilfe!!!!

  • Also ich hab aufgrund von diesem Post


    https://forum.qnap.com/viewtopic.php?t=133575


    Angenommen, das PulseAudio muss raus, da es nur 2.1 kann (will).


    Mit folgender Anleitung habe ich Versucht Pulseaudio zu deaktivieren (was danach ALSA aktivieren sollte - und mich dann mit 5.1 beglückt)


    https://kodi.wiki/view/PulseAu…ng_PulseAudio)_for_Ubuntu



    Das NAS ist an einem DENON X4300 AVR angehängt - der das problemlos schafft - jedoch bekommt er vom NAS definitiv nur Stereo gesendet.


    Ausgabe will ich eigentlich mit allem .... vorallem VLC & KODI


    Mittlerweile hab ich noch den Hinweis gefunden mir PAMAN (PulseAudio Manager) zu installieren und versuchen, das dort einzustellen.

    Doch nach der Installation ist der einfach verschwunden ... wie starte ich das ding? (omg ich noob)


    Hier noch ein Bild vom AlsaMixer

    zu guter letzt noch die VLC und KODI einstellung...









  • Ah, OK. Hatte übersehen, dass es hier um die LinuxStation geht. Die hab ich wieder runtergeworfen, da ich hauptsächlich Kodi verwende und dafür ist mir das zu umständlich, zumal man erst basteln muss, um die Fernbedienung nutzen zu können.


    Wenn es dir hauptsächlich um Kodi geht, warum verwendest du nicht einfach die HD-Station? Da funktioniert das ohne Gefrickel, einfach Passthrough und die Surround-Formate auswählen und fertig.

  • Die LinuxStation ist ein LXC-Container, wie die HD-Station auch (die übrigens ebenfalls auf Ubuntu 14.04 basiert).


    Die echten Konfigurationsdateien findest du nur per ssh auf dem NAS unter:

    Ubuntu 14.04: /share/CACHEDEV1_DATA/.qpkg/ubuntu-hd/lxc/ubuntu-hd

    Ubuntu 16.04: /share/CACHEDEV1_DATA/.qpkg/ubuntu-hd/lxc/ubuntu_1604

    Das root-Filesystem des Ubuntu-Containers befindet sich unter rootfs im jeweiligen Verzeichnis.


    Jede Session wird über ein Start-Script konfiguriert, was möglicherweise deine geänderte Konfiguration wieder überschreibt. Du findest es wahrscheinlich unter /share/CACHEDEV1_DATA/.qpkg/ubuntu-hd bzw. in dem passenden Ubuntu-Verzeichnis (siehe oben, hab die LinuxStation wie gesagt nicht mehr installiert), bei der HD-Station ist es /share/CACHEDEV1_DATA/.qpkg/HD_Station/HD_Station.sh. Da musst du dich selber durchgraben, hab mich damit noch nicht beschäftigt. Evtl. kannst du im Start-Script der HD-Station was finden, was hilfreich ist, denn dort geht ja 5.1 direkt.


    Für die Aktivierung der Fernbedienung in der LinuxStation (ging zumindest damals nicht direkt) hatte ich mal eine Anleitung geschrieben:

    Aktivierung der QNAP-Fernbedienung RM-IR002 in der Linux Station


    EDIT: Das Start-Script der HD-Station unterstützt zusätzliche Parameter zum Abschalten von Puleaudio, evtl. gibt es diese ja auch im Start-Script für die LinuxStation.

    Einmal editiert, zuletzt von warpcam ()

  • ich nutze beim Start von Kodi eine Art Shellscript. Vielleicht hilft dir das (beim mir habe ich zumnindest 5.1 Sound):


    Das habe ich als Icon auf dem Desktop (kodi-alsa.dektop) und wenn ich damit Kodi starte habe ich Alsa und 5.1 Sound an meinen Reciever. Es wurden keine weiteren Veränderungen am System durchgeführt. In Kodi habe ich dann noch Passthrough aktiviert.

  • sorry, aber das Linux muss unbedingt erhalten bleiben :(


    ich werde weiter dran bleiben....


    unglaublich dass Pulseaudio kein 5.1 kann.

    Also Update:


    Habe es mit deinem Tipp hingekriegt dass beim Reboot das Config File stimmt.


    Jedoch hab, ich sobald ich PulseAudio unterbinde, keinen sound mehr ....


    ich habe zusätzlich auch noch den Lösungsansatz probiert:

    https://help.ubuntu.com/community/SurroundSound


    Indem ich die Channelanzahl manuell erhöhe ... Leider mit dem gleichen Ergebnis - der sound ist ganz weg.



    ich dreh echt langsam durch

    scheisse .. jungsjetzt hab ich vor lauter proben . vermute ich die CONF files korrumpiert ...


    auch wenn ich die "standardfiles herstelle" kommt gar kein sound mehr



    das obwohl die PAVUControll einen Stream erkennt und anzeigt