Mit Kodi kein Zugriff mehr auf Netzwerk

  • Hi,


    ich nutze Kodi 17.5.0.0


    Mit der alten Version 16ner Version konnte ich via File auf mein Netzwerk zugreifen und so die Videos aller sich im Netzwerk befindenden Computer erreichen und abspielen.


    Alle Computer befinden sich in der selben Netzwerkgruppe.


    ich habe 2 WIN 7 Rechner ein QNAP TS451+ mit Version 4.3.4.0664 und einen WIN 10 Rechner.


    Gehe ich im Kodi auf Videos --> Files --> auf den Netzwerkordner (die Arbeitsgruppe) erhalte ich 2 Meldungen:


    Code
    1. 1. ERROR
    2. Connection refused
    3. 2. Remote share
    4. Couldn`t connect to network server.


    Alle PC`s sind im Netzwerk erreichbar, lassen sich anpingen etc.


    Was ist zu tun?:/

  • Üblicherweise zentralisiert man die ganzen Medien. Eben um nicht unzählige Shares einbinden zu müssen.

  • Üblicherweise, ja. Aber ich brauch bzw. möchte es halt etwas anders. Sorry.


    Und hier geht es ja nicht um die Einbindung von shares , sondern um den Zugriff auf ein geschlossenes Netzwerk.

  • Wie willst Du denn auf die Computerfreigaben zugreifen?

    Welches Protokoll, welche Version?

  • Ich nutze WIN 10. Habe die entsprechenden Laufwerke freigegeben und alle Computer sind in der gleichen Arbeitsgruppe auch der QNAP. Die Arbeitsgruppe wird auch korrekt angezeigt. Nur wenn ich via Kodi daruf zugreifen will, erhalte ich genannte Meldungen. Aktiviert ist SMB 3.


    Ansonsten, da bin ich ehrlich, verstehe ich deine Frage nicht.

  • Hast Du anstelle des Netbios-Namen auch mal mit der IP probiert?

  • Was ist jetzt der Stand? Du willst in Kodi Freigaben von einem Win10-Rechner einbinden?

    Das ganze über SMB? Dieses Konstrukt habe ich noch nie probiert, aber ich denke es sollte möglich sein. Wäre eine externe HDD mit den Medien keine Alternative?

  • Nun ja, vorstellbar ist vieles, es funktioniert nur nicht. Ich bin jetzt soweit, dass ich im Kodi über Files gehe und mir dann den Pfad via IP nur für den einen Film freigeben muss, also z.B.:


    192.168.178.23/Filme ...... usw.


    Früher brauchte ich das nicht, da war das Netzwerk 'Workgroup' in den Files da und ich konnte so auf jedes File jedes PC's zugreifen, der im Netzwerk integriert war, über die Fernbedienung. Und genau auf dieses Netzwerk komme ich nicht mehr drauf. Warum? Keine Ahnung!

  • Wie sieht denn die Struktur aus?


    192.168.178.23/Filme

    192.168.178.23/Serien/

    192.168.178.23/Dokus


    oder was ganz anderes?

  • Ziemlich genau so, wie du es beschrieben hast.

    Ich beschreibe nochmals den Weg, den ich früher ging und den ich gerne wieder gehen würde:


    Ich liege mit meinem Tablet vorm Fernseher, gehe auf HDMI1 und schalte meinen Receiver auf DB/DVD um, da dort das HDMI-Kabel vom Qnap (ist für Audio) reingeht. Dieser ist wiederrum auch an der Fritzbox via Ethernert angeschlossen, genau wie der Fernseher und der Receiver. und alle PC.


    Via QRemote auf die HD-Station aufgeschalten:


    Kodi aktiviert

    --> Videos

    --> Dateien

    --> Workgroup

    --> hier konnte ich jetzt alle PC's sehen für die ich eine Freigabe verteilt hatte. Nicht die IP-Adressen, sondern die Namen der PC's. Dann ging es ganz normal den Verzeichnisbaum lang bis zur entsprechenden Datei, fertig.


    Das funktioniert aber nicht mehr und ich weiß nicht warum.

  • Dein Nick und mein Avatar passen ja auch hervorragend zusammen. :)

    Warum dies Vorgehen jetzt nicht mehr geht, erschließt sich mir nicht ganz. Kannst Du mal ein par Medien unter einem Share mal zusammenfassen und dort testen?

  • In meinem jetzigen Kodi wird über den Weg 'Dateien' der Ordner Multimedia angezeigt. Ich werde mal was dort reinkopieren und schauen ob ich es daraus starten kann. Bleibt immer noch die Frage:


    Was ist mit Workgroup, dem Windows-Netzwerk. Dem habe ich auch den Qnap zugeornet.


    Mache ich aber erst morgen.

    Übrigens ist der angezeigte Ordner im gleichen Verzeichnis-Baum, sogar der gleichen Ebene wie der Ordner Filme etc.

    So.


    Habe wie oben geschrieben getestet und ........


    es funktioniert. Erstaunlicherweise habe ich plötzlich , ohne den Qnap neu gestartet zu haben auch wieder den Zugriff auf die anderen Ordner des QNAP.


    Worauf ich nach wie vor keinen Zugriff habe sind die freigegebenen Ordner meines Netzwerkes meines PC.


    Den kann ich weder via IP noch über Computernamen ansprechen.

    Übrigens stammt mein Nick noch von den alten WING-Commander-Spielen (ja ich bin etwas älter). Die Katze bei mir zu Hause wird mehr verwöhnt als ich und schläft den ganzen Tag. Natürlich genau dort wo man gerade sitzen will und auch nur wenn dort Kissen liegt.

  • Die Katze bei mir zu Hause wird mehr verwöhnt als ich und schläft den ganzen Tag. Natürlich genau dort wo man gerade sitzen will und auch nur wenn dort Kissen liegt.

    Oh ja. Das kommt mir bekannt vor. Hunde haben Herrchen, Katzen haben Personal. :)

    Kannst Du die Computer von der QNAP aus anpingen? Du solltest evtl. auch detaillierter schreibenw as jetzt geht und nicht geht.
    Wir sind nicht bei Dir zu Hause. Und warum pflegst Du solch eigenwillige strukrur anstatt alle Medien zu zentralisieren. So müßen die Rechner ständig an sein, nur weil man einen Film angucken will.

  • Dann wirds Zeit die Struktur neu zu überdenken.

    Per PuTTY an der NAS anmelden und dann ganz normal ping IP

  • kommen durch.

    wenn ich mich via WinSCP über FTP anmelden will wird die Verbindung seitens des PC abgelehnt. Ich schätze mal WIN 10 macht da auch so einige Probs, die in WIN7 nie hatte. Und ja ich habe entsprechende Ordner freigegeben.

  • Per FTP auf Windows-Kisten?

    Meine mal gelesen zu haben, daß es unter Win10 sporadisch Problemen mit SMB3 gibt.

  • KeineAhnung Jagi

    Solange ich nicht selbst betroffen bin gehen solch Informationen meist an mir vorüber.
    Es ist zu komplex geworden als das man sich für jeden Mist interessieren muß.

    Trotzdem bleibe ich bei meiner Meinung. Medien sollten zentralisiert an einer Stelle gesammelt werden.

    Dort (und nur von dort) holt sie der zuständige Medienplayer ab. Ist auch bei der Fehlersuche hilfreich.
    Hier weiß man ja nicht mal woran es liegt. Medienplayer (neue Version?), Windows-Freigaben?

    Protokoll?