Docker Container startet nicht automatisch

  • Hi!


    Ich habe den Container "webdevops/php-apache:latest-data-3" installiert und eingerichtet.

    In den Settings ist er auf Autostart gesetzt. Aber wenn das NAS hochfährt, dann startet der Container als einziger (der Autostart-Container) nicht.


    Woran könnte das liegen?

  • Danke!


    ... hat sich mitlerweile erledigt.

  • Wenn Du die Lösung auch noch schreben würdest, profitieren auch andere Leute davon.

  • Wenn ich eine Lösung gefunden HÄTTE ...


    Letzten Endes habe ich den Container einfach deinstalliert und von vorne begonnen.

  • Ist manchmal einfach zielführender als Stundenlang Fehlersuche zu betreiben. :)

  • Ich habe exakt das gleiche Problem mit dem gleichen Container.

    Leider hat das neu aufsetzen des Containers nichts gebracht.


    Hat jemand vielleicht doch noch eine Lösung?

  • Das setzen der Restart Policy per

    Code
    1. docker update --restart=unless-stopped php-apache-1
    2. oder
    3. docker update --restart=always php-apache-1

    ist wirkungslos.

  • ja..

    - container stoppen

    - in der "Container Station" Gui diesen auswählen

    - Haken bei "Please restart...." rausnehmen.

    - "Auto start" aktivieren

    - Apply


    zur Sicherheit das ganze nochmal kontrollieren.


    Dann kann der Container wieder gestartet werden... settings bleiben erhalten...bis zum nächsten Update/Ugrade des Containers


    Ist wohl ein Bug - aber so geht es :-D