Problem beim erstellen von Containern

  • Hallo zusammen,


    ich habe das Problem, dass beim Erstellen von Container die ganzen zusätzlichen eintragungen wie "Befehl:", "Eingangspunt:" oder auch alle Umgebungsvariabeln, welche vorher beim Erstellen von Container schon vorhanden waren nun vollständig leer sind bzw. fehlen. Ich hatte vorher die Containerstation entfernt und wieder hinzugefügt mit unterschiedlichen ablageorten ähnlich dem was hier Komplette Neuinstallation der Container Station/Linux Station erzwingen beschrieben wurde. Weiß jemand wo das Problem liegt bzw. wie man es behebt.

    Als beispiel, wie es ausschaut, wenn man ein Container installieren will, hab ich den Vorgang bei Mariadb mal als Screenshot angehangen.



    Grüße

  • Hallo

    Leider kann ich dir nicht weiter helfen, da ich das Selbe Problem habe.

    Aber eventuell hast du ein paar Tips für mich.

    Ich finde nirgends eine Hilfe in welcher die Parameter der Container Station erklärt werden. Die "HowTo"s gehen immer vom Ideal Fall aus und beschreiben Vorgänge die bei mir nicht vorkommen.


    Ich hänge nun schon mehrere Wochenenden an diesem Thema und komme einfach nicht weiter.

    Mittlerweile bin ich von QNAP sehr enttäuscht!

  • Die Parameter hängen vom Image ab und nicht von QNAP. Also die Parameter basierend auf dem Image Recherchieren.

    Es müsste aber auch folgendes funktionieren:

    Container einfach erstellen ohne irgendwelche Änderungen, dann in die Settings des Containers dort sollten dann die Default Parameter sichtbar sein.

  • Mittlerweile bin ich von QNAP sehr enttäuscht!

    Die hier beschriebenen Probleme haben generell recht wenig mit QNAP zu tun...

    Warum versucht ihr nicht einfach die zu erstellenden Container über die Kommandozeile zu starten, dafür kann die offizielle Docker Dokumentation und die jeweilige Beschreibung des Containers genutzt und meist 1 zu 1 kopiert werden. Einmal über die Kommandozeile erstellt, tauchen die Container dann automatisch in der Container Station GUI auf und können dort gestoppt oder neugestartet werden.

  • Hallo und vielen Dank für die Bisherigen Antworten.


    yield :

    ich habe bisher keine Tips oder Lösungen dafür gefunden.


    puffi & tuxflo:

    Ja die Parameter werden vom Image breit gestellt. Dies war auch anfangs der fall. Aber wie beschrieben ist das nun bei keinem von mir getestetem Image mehr der Fall. Da die Images sich ja nicht alle geändert haben werden ist die Schlussfolgerung schon naheliegend, dass das Problem an der Containerstation (von QNAP) liegt. Deswegen auch die Anfrage in diesem Forum.


    Hier in der Beschreibung ist im Übrigen zu sehen, wie die Parameter in meinem Screenshot eigentlich gefült sein sollten.:
    [Howto] MariaDB + phpMyAdmin im Docker-Container

  • Ich schließe hier keinen Fehler der Container Station aus sonder versuche eine alternativen Weg aufzuzeigen damit du mit deinem Vorhaben vorankommst.

    Basierend auf allen Beiträgen kann ich drei alternative Wegen erkennen.

    1. Einen leeren Container erstellen und danach die settings checken.

    2. Die Parameter basierend auf dem Image recherieren und beim erstellen der Container manuell eingeben.

    3. Genau wie 2. Aber über ssh die Parameter an docker übergeben (Tipp von tuxflo)

    (Mache ich bei mir so bei über 30 Containern zwecks der absoluter Kontrolle darüber was passieren soll, da mein Vertrauen in die CS auch nicht so groß ist und docker sehr gut dokumentiert ist)

  • Hallo zusammen,
    Ich habe mal,wie von euch empfohlen, erstmal den Container ohne weitere Änderungen installiert. Anschließend konnte ich feststellen, dass wenn ich einen weiteren Container erstelle, dass dann die nötigen Einstellungen von der Containerstation schon mit angezeigt und übernommen werden. :)