Port 443 GUI und Webserver vereinbar?!

  • Hallo zusammen,


    ich habe mal wieder eine Frage und vielleicht kann mir ja jemand weiter helfen. Ich habe eine TS-453 Pro. Die GUI lauscht auf Port 8080 und HTTPS auf 443. Der Webserver läuft auf Port 80 und HTTPS 8081. Bisher war dies kein Problem, da ich den Webserver nicht genutzt habe. Die GUI wird über eine Domain, da diese auf 443 lauscht, auch verschlüsselt und mit passenden Zertifikat geladen, was (eigentlich) auch so bleiben soll.


    Nun habe ich Owncloud aufgesetzt, welches sich natürlich nur über https://xxxxx.de:8081/owncloud/ aufrufen lässt und theoretisch funktioniert. Allerdings ist die Seite nicht überall erreichbar, da dort Port 8081 gesperrt ist. Nun klar, ich könnte GUI und den Webserver mit den Ports tauschen oder eben andere Bereiche vergeben, was ich allerdings nur ungern möchte, da sonst die GUI nicht überall erreichbar ist.


    Nun ist mir aufgefallen, dass gewisse Dienste, wie zb. die VirtualizationStation3 oder QVRPro auch über 443 aufrufbar sind, nämlich über: https://xxxxxxx.de/qvr bzw. https://xxxxx.de/qvrpro. Lässt sich hier nicht irgendein "Symbollink" erzeugen, der auf Owncloud umleitet und den Port 443 hält, wie es bei den zwei Anwendungen, die ja eigentlich auch auf nem Webserver laufen müssten, auch funktioniert? :handbuch:


    Vielen Dank und viele Grüße

    Mike

  • Hallo,


    die gleiche Frage habe ich auch. Versuche nach Anleitung: nextcloud mit nginx reverse proxy und LetsEncrypt auf Docker nextcloud zum laufen zu bringen, bekomme es aber nicht hin, dass der Port 443 nicht mehr für die QNAP Dienste wie AdminGUI etc. genutzt wird.


    Kann hier jemand weiterhelfen?


    VIelen Dank!

    cunctator

    konnte mir die Frage zumindest für das AdminGUI selber beantworten... || manchmal sieht man den Wald vor lauter Bäumen nicht...


    Systemsteuerung-> Allgemeine Einstellungen-> Systemadministration->Sicheren Anschluss (HTTPS) aktivieren -> Portnummer