Pi-Hole auf QNAP installieren

  • Und, schon mal nachgesehen ob dein Handy auch die PiHole-IP als DNS-Server eingetragen hat?

  • Der DNS Server (Pi hole) ist ja in der Fritzbox hinterlegt, von daher gehe ich stark davon aus, dass das korrekt ist. Habe allerdings keine Option am Handy gefunden, die mir den DNS Server anzeigt (Android 8.1)


    Update: okay, scheint alles richtig zu laufen. Mit der kostenlosen App AIDA64 habe ich den DNS Server ermittelt. Des weiteren lässt sich über das Webinterface des Pi Holmes über Tools und dann Taille pihole.log quasi live verfolgen, was gerade passiert. Mich wundert es halt, dass diese Testseiten immer noch Werbung zeigen. Deshalb wäre es interessant zu wissen, ob das bei euch ebenfalls so ist.

    2 Mal editiert, zuletzt von whocares81 ()

  • Hallo,


    ich habe Pi-Hole bereits seit geraumer Zeit auf einem Raspi im EInsatz und bin sehr zufrieden.

    Jetzt wollte ich aus redundanzgründen einen zweiten als Container einrichten.

    Läuft soweit ganz gut und die Einrichtung als "Bridge und fester IP" war erfolgreich.


    Einzig die Konfiguration mit ipV6 gelingt nicht...das scheint in Containern nicht wirklich umsetzbar zu sein.


    VG

    Christian

  • Hi,


    rock_franky wärst du so nett und könntest deine Installation etwas genauer beschreiben? Ich hab die VMware Version importiert aber bekommen es nicht wirklich hin. Wäre über etwas hilfe dankbar!



    BG Jürgen

  • Hab jetzt den Pi-hole Container auch korrekt zum werkeln gebracht und mir gedacht ich stell hier kurz die Anleitung hinein, da die Installation schnell vollbracht war, die Endkonfiguration hab ich allerdings nicht auf Anhieb hinbekommen.


    Anfangs wurde mir als Client im Pi-hole Interface immer nur openwrt.lan angezeigt, bzw. konnte ich zwischendurch im LAN keine Hostnames direkt ansprechen.

    War ein bisschen eine Spielerei, für jemanden der sich mit DNSMasq & Co nicht wirklich auskennt, hatte dann teilweise 20.000 Queries pro Stunde auf der Pi-hole Oberfläche angezeigt, ich vermute weil Router und Pi-hole Ping-Pong gespielt haben mit den Anfragen.


    Im Endeffekt hat es dann folgende Konfiguration bei mir getan:


    Ich verwende das "diginc/pi-hole"-Image.

    Container-Einstellungen wie hier:


    Einfach den Network-Mode in den Advanced Settings auf Bridge-Mode stellen, eine fixe IP-Adresse vergeben und als Gateway die IP-Adresse vom Router angeben.

    Die Beschränkungen für CPU-Auslastung und Arbeitsspeicher sind vermutlich nicht notwendig, bzw. können deutlich gesenkt werden, ich wollte nur sicher gehen dass mir das Pi-hole nicht das NAS abschießt und hab danach nicht weiter experimentiert.


    Die Pi-hole admin-Oberfläche konnte ich dann nach der Installation über http://192.168.x.y/admin aufrufen (IP-Adresse der Pi-hole wie in den Container-Einstellungen verwenden)

    Diese DNS-Einstellungen musste ich dort dann noch anpassen:

    Als Custom DNS die IP-Adresse vom Router eingeben, die anderen Upstream-DNS Server deaktivieren.

    Außerdem die beiden Haken bei Never forward non-FQDNs und Never forward reverse lookups for private IP ranges wegklicken.


    Ich verwende noch openWRT am Router, hier musste ich folgende Einstellungen vornehmen:


    Unter Network > Interfaces > LAN (edit) in den Advanced Settings des DHCP-Servers (mein Router bleibt weiterhin der DHCP-Server) folgendes eingeben:

    Code
    1. 6,192.168.x.y,192.168.a.b

    Die DHCP-Option 6 setzt den DNS-Server für den DHCP-Server (https://www.incognito.com/tips…options-in-plain-english/)

    .x.y ist das Pi-hole, .a.b ist die LAN-IP des Routers, falls das Pi-hole mal nicht erreichbar sein sollte


    Ich hab für die LAN-Konfiguration sonst keinen eigenen DNS-Server bzw. DNS-Forward vergeben, das hat bei mir nicht korrekt funktioniert, die tatsächlichen DNS-Server sind dann am WAN-Interface hinterlegt (ich verwende 1.1.1.1 und 1.0.0.1 als DNS-Server).


    Das war's dann auch schon, ich hab dann einfach noch mal das LAN-Interface neugestartet und an den Endgeräten im LAN den DNS-Cache geflusht (in Windows geht das über die Eingabeaufforderung und dann ipconfig /flushdns), bzw. das W-LAN am Smartphone deaktiviert und wieder aktiviert. Das hat gereicht damit die DNS-Server für die Geräte richtig übernommen wurden (Windows: Eingabeaufforderung ipconfig /all, in Android 8.0 konnte ich die DNS-Server anzeigen lassen indem ich einfach unter W-LAN auf das verbundene Netzwerk geklickt habe).


    Seitdem läuft alles und das Pi-hole blockt 20-30% der Queries, bei den falschen Konfigurationen war das Verhältnis bei ca. 2-10% der Queries, weil einfach so viele Queries kamen, und - so denke ich - auch nicht alles richtig geblockt wurde, ganz hab ich das auch nicht durchschaut.


    Würde mich freuen wenn das jemandem hilft, bzw. sich jemand mit der Anleitung etwas Zeit und Frust erspart. Selbst wenn nicht hat es Spaß gemacht die Anleitung zu schreiben 8)

  • danke für das Tutorial!

    Habe die Einstellungen bei mir mal entsprechend angepasst.

    Was mir auffällt:

    Auf der Pi Hole Adminoberfläche unter dem Menüpunkt "settings" steht bei "Pi-hole IPv4 address:" 0.0.0.0.


    Das finde ich irgendwie seltsam, muss das so? Auch finde ich die Temperaturanzeige oben links etwas hoch, mein QNAP zeigt mir eine Temperatur von 31°C an.



  • Auf der Pi Hole Adminoberfläche unter dem Menüpunkt "settings" steht bei "Pi-hole IPv4 address:" 0.0.0.0.


    Das finde ich irgendwie seltsam, muss das so? Auch finde ich die Temperaturanzeige oben links etwas hoch, mein QNAP zeigt mir eine Temperatur von 31°C an.

    Ja - bei mir wird auch 0.0.0.0 angezeigt, hab aber nicht weiter drüber nachgedacht.


    Die Temperatur stimmt bei mir mit der CPU-Temperatur vom NAS überein, sichtbar z.B. in den Hardware-Informationen (nicht die System-Temperatur!)

  • Hi,


    von mir auch ein Danke für die Anleitung, hat super funktioniert.

    Bei mir wird auch 0.0.0.0 angezeigt als IP-Adresse, die Temperatur stimmt bei mir auch, wenn nicht wäre es mir dort auch egal. ;)


    Mfg Jürgen

  • Huhu, bei mir scheint es nicht zu funktionieren. Im Error-Log steht folgendes wenn ich versuche den Container zu starten:

    Code
    1. ::: Starting docker specific setup for docker diginc/pi-hole
    2. ERROR: To function correctly you must pass an environment variables of 'ServerIP' into the docker container with the IP of your docker host from which you ar
    3. e passing web (80) and dns (53) ports from
    4. [cont-init.d] 20-start.sh: exited 1.
    5. [cont-finish.d] executing container finish scripts...
    6. [cont-finish.d] done.
    7. [s6-finish] syncing disks.
    8. [s6-finish] sending all processes the TERM signal.
    9. [s6-finish] sending all processes the KILL signal and exiting.

    Habe die Anleitung von austria89 benutzt und dem Container eine statische IP zugewiesen.

  • hab mal nur kurz Google angeworfen, nachdem ich in der Materie auch eher weniger auskenne, und bin dabei auf folgendes gestoßen:

    https://github.com/diginc/docker-pi-hole/issues/135 - du dürftest also nicht der einzige mit dem Problem sein.


    Evtl. klappt es wenn man den Docker-Container über die Shell einrichtet - aber da steig ich leider noch aus, vielleicht kann da wer anderer weiterhelfen!

  • Wenn man eine richtige IP-Adressde haben möchte, so9llte man die Konfigurationsanweisungen auf https://hub.docker.com/r/diginc/pi-hole/ befolgen.


    Bei mir habe folgende Umgebungsvariablen bei der Erstellung von Container definiert:


    ServerIP=Bridge IP-Adresse (192.168.1.xxx)

    IPv6=False (brauche IP6 nicht)

    TZ=Europe/Berlin (richtige Docker-Zeit )